aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/qcbor/qcbor_1.3.bb')
-rw-r--r--meta-oe/recipes-extended/qcbor/qcbor_1.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb b/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
new file mode 100644
index 0000000000..f90e814f7a
--- /dev/null
+++ b/meta-oe/recipes-extended/qcbor/qcbor_1.3.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = " \
+ QCBOR is a powerful, commercial-quality CBOR encoder/decoder that \
+ implements these RFCs: RFC8949, RFC7049, RFC8742, RFC8943 \
+"
+
+HOMEPAGE = "https://github.com/laurencelundblade/QCBOR"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=498c298542365dfcfe29948c72a5849b"
+
+SRC_URI = "git://github.com/laurencelundblade/QCBOR;protocol=https;branch=master"
+
+SRCREV = "1eba85dbbe78fc1938f8aba2112ba1b228caed30"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+CFLAGS += " \
+ -DUSEFULBUF_DISABLE_ALL_FLOAT \
+"
+
+do_install(){
+ install -d ${D}${libdir}
+ install -m 755 ${S}/libqcbor.a ${D}${libdir}/
+ install -d ${D}${includedir}/qcbor
+ install -m 644 ${S}/inc/*.h ${D}${includedir}
+ install -m 644 ${S}/inc/qcbor/*.h ${D}${includedir}/qcbor
+}
+