aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb')
-rw-r--r--meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb
new file mode 100644
index 0000000000..ae4493d41d
--- /dev/null
+++ b/meta-oe/recipes-graphics/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Machine specific xorg.conf files"
+PR = "r43"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${TOPDIR}/meta-shr/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://xorg.conf"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+}
+
+# Set some dependencies to make the confs actually work
+RDEPENDS_omap3 = "xf86-video-omapfb"
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+PACKAGE_ARCH = "${MACHINE_ARCH}"