aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/freerdp/freerdp.inc2
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.23.bb2
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp.inc b/meta-oe/recipes-support/freerdp/freerdp.inc
index 46aecf6130..673b37240a 100644
--- a/meta-oe/recipes-support/freerdp/freerdp.inc
+++ b/meta-oe/recipes-support/freerdp/freerdp.inc
@@ -23,7 +23,7 @@ PACKAGES =+ "libfreerdp"
LEAD_SONAME = "libfreerdp.so"
FILES_libfreerdp = "${libdir}/lib*${SOLIBS}"
-PACKAGES_DYNAMIC = "libfreerdp-plugin-*"
+PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*"
python populate_packages_prepend () {
freerdp_root = bb.data.expand('${libdir}/freerdp', d)
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
index 3ef12d3a1f..8d9bd6c6b6 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
@@ -249,7 +249,7 @@ pkg_prerm_${PN}-slapd () {
update-rc.d $D openldap remove
}
-PACKAGES_DYNAMIC = "openldap-backends openldap-backend-*"
+PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*"
python populate_packages_prepend () {
backend_dir = bb.data.expand('${libexecdir}/openldap', d)
diff --git a/meta-oe/recipes-support/pidgin/pidgin.inc b/meta-oe/recipes-support/pidgin/pidgin.inc
index 90e2fd4b66..cb2a59799a 100644
--- a/meta-oe/recipes-support/pidgin/pidgin.inc
+++ b/meta-oe/recipes-support/pidgin/pidgin.inc
@@ -56,7 +56,7 @@ RRECOMMENDS_${PN} = "${PN}-data libpurple-plugin-ssl-gnutls libpurple-protocol-i
FILES_${PN}-data = "${datadir}/pixmaps ${datadir}/sounds ${datadir}/icons"
FILES_${PN}-dev += "${libdir}/${PN}/*.la"
-PACKAGES_DYNAMIC = "libpurple-protocol-* libpurple-plugin-* pidgin-plugin-* finch-plugin-*"
+PACKAGES_DYNAMIC += "^libpurple-protocol-.* ^libpurple-plugin-.* ^pidgin-plugin-.* ^finch-plugin-.*"
python populate_packages_prepend () {
pidgroot = bb.data.expand('${libdir}/pidgin', d)