aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch18
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.1.10.bb7
2 files changed, 21 insertions, 4 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch
new file mode 100644
index 0000000000..5dbb0547df
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/fltk-no-freetype-config.patch
@@ -0,0 +1,18 @@
+--- a/configure.in.orig 2015-03-01 16:00:35.956432907 +0100
++++ b/configure.in 2015-03-01 16:04:23.269580093 +0100
+@@ -865,11 +865,11 @@
+ AC_ARG_ENABLE(xft, [ --enable-xft turn on Xft support [default=no]])
+
+ if test x$enable_xft = xyes; then
+- AC_PATH_PROG(FTCONFIG,freetype-config)
++ AC_PATH_PROG(PKGCONFIG,pkg-config)
+
+- if test "x$FTCONFIG" != x; then
+- CPPFLAGS="`$FTCONFIG --cflags` $CPPFLAGS"
+- CXXFLAGS="`$FTCONFIG --cflags` $CXXFLAGS"
++ if test "x$PKGCONFIG" != x; then
++ CPPFLAGS="`$PKGCONFIG --cflags xft` $CPPFLAGS"
++ CXXFLAGS="`$PKGCONFIG --cflags xft` $CXXFLAGS"
+
+ AC_CHECK_HEADER(X11/Xft/Xft.h,
+ AC_CHECK_LIB(Xft, XftDrawCreate,
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
index 4fd3645c66..3229ed0e7e 100644
--- a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
+++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
@@ -6,19 +6,18 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=1c0b73db66884b6a925e727400315130"
DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
-PR = "r1"
-
-PNBLACKLIST[fltk] ?= "broken: still uses /usr/bin/freetype-config"
+PR = "r2"
SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
file://disable_test.patch \
file://dso-fix.patch \
file://libpng15.patch \
+ file://fltk-no-freetype-config.patch \
"
S = "${WORKDIR}/fltk-${PV}"
-inherit lib_package autotools-brokensep binconfig
+inherit lib_package autotools-brokensep binconfig pkgconfig
TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"