aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/mysql/mysql-python/remove-distribute.patch17
-rw-r--r--meta-oe/recipes-support/mysql/mysql-python_1.2.4.bb18
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mysql/mysql-python/remove-distribute.patch b/meta-oe/recipes-support/mysql/mysql-python/remove-distribute.patch
new file mode 100644
index 0000000000..0ce750d63d
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mysql-python/remove-distribute.patch
@@ -0,0 +1,17 @@
+Upstream-Status: Innapropriate
+
+Index: MySQL-python-1.2.4/setup.py
+===================================================================
+--- MySQL-python-1.2.4.orig/setup.py
++++ MySQL-python-1.2.4/setup.py
+@@ -3,8 +3,8 @@
+ import os
+ import sys
+
+-from distribute_setup import use_setuptools
+-use_setuptools()
++#from distribute_setup import use_setuptools
++#use_setuptools()
+ from setuptools import setup, Extension
+
+ if not hasattr(sys, "hexversion") or sys.hexversion < 0x02040000:
diff --git a/meta-oe/recipes-support/mysql/mysql-python_1.2.4.bb b/meta-oe/recipes-support/mysql/mysql-python_1.2.4.bb
new file mode 100644
index 0000000000..37ad21c8e7
--- /dev/null
+++ b/meta-oe/recipes-support/mysql/mysql-python_1.2.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Python interface to MySQL"
+HOMEPAGE = "https://github.com/farcepest/MySQLdb1"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://GPL-2.0;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+PR = "r0"
+SRCNAME = "MySQL-python"
+
+SRC_URI = "https://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.zip \
+ file://remove-distribute.patch"
+
+SRC_URI[md5sum] = "ddf2386daf10a97af115ffad2ed4a9a0"
+SRC_URI[sha256sum] = "e405f9d6be33923d428acaa4db4f4470427f1d15ea0d2d82a933449ace26bbd9"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools