aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/gyp/gyp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/gyp/gyp_git.bb')
-rw-r--r--meta-python/recipes-devtools/gyp/gyp_git.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
index 8e48a27fae..61f3c86370 100644
--- a/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -1,2 +1,15 @@
+DESCRIPTION = "GYP is a Meta-Build system: a build system that generates other build systems."
+HOMEPAGE = "https://gyp.gsrc.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
+SECTION = "devel"
+
+SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https"
+SRCREV = "fcd686f1880fa52a1ee78d3e98af1b88cb334528"
+
+S = "${WORKDIR}/git"
+PV = "0.1+git${SRCPV}"
+
inherit setuptools3
-require gyp.inc
+
+BBCLASSEXTEND = "native nativesdk"