aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-rfc3986-validator.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-rfc3986-validator.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator.inc b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
new file mode 100644
index 0000000000..71f7a7904f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
@@ -0,0 +1,23 @@
+SUMMARY = "Pure python rfc3986 validator"
+HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3986-validator:"
+
+SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
+SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
+
+PYPI_PACKAGE = "rfc3986_validator"
+
+inherit pypi
+
+SRC_URI_append = " \
+ file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
+"
+
+RDEPENDS_${PN} += "\
+ python3-core \
+"
+
+BBCLASSEXTEND = "native nativesdk"