aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
index 415a430672..2dc57a6bb0 100644
--- a/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-aspectlib_1.5.2.bb
@@ -8,7 +8,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e"
SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa"
-inherit pypi setuptools3
+inherit ptest pypi setuptools3
+
+SRC_URI += "file://run-ptest \
+ file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \
+ "
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+RDEPENDS_${PN}-ptest += "\
+ python3-tornado \
+ python3-process-tests \
+"
RDEPENDS_${PN} += "python3-core python3-fields"