aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb')
-rw-r--r--toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb b/toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb
new file mode 100644
index 0000000000..d0f889cafa
--- /dev/null
+++ b/toolchain-layer/recipes-devtools/binutils/binutils_2.20.1.bb
@@ -0,0 +1,52 @@
+require binutils.inc
+
+PR = "r9"
+
+LIC_FILES_CHKSUM="\
+ file://src-release;endline=17;md5=4830a9ef968f3b18dd5e9f2c00db2d35\
+ file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552\
+ file://COPYING.LIB;md5=9f604d8a4f8e74f4f5140845a21b6674\
+ file://COPYING3;md5=d32239bcb673463ab874e80d47fae504\
+ file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6\
+ file://gas/COPYING;md5=d32239bcb673463ab874e80d47fae504\
+ file://include/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552\
+ file://include/COPYING3;md5=d32239bcb673463ab874e80d47fae504\
+ file://libiberty/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7\
+ file://bfd/COPYING;md5=d32239bcb673463ab874e80d47fae504\
+ "
+
+SRC_URI = "\
+ ${GNU_MIRROR}/binutils/binutils-${PV}a.tar.bz2 \
+ file://binutils-uclibc-100-uclibc-conf.patch \
+ file://110-arm-eabi-conf.patch \
+ file://binutils-uclibc-300-001_ld_makefile_patch.patch \
+ file://binutils-uclibc-300-006_better_file_error.patch \
+ file://binutils-uclibc-300-012_check_ldrunpath_length.patch \
+ file://binutils-uclibc-gas-needs-libm.patch \
+ file://binutils-x86_64_i386_biarch.patch \
+ file://binutils-mips-pie.patch \
+ file://libtool-2.4-update.patch \
+ file://binutils-2.19.1-ld-sysroot.patch \
+ file://libiberty_path_fix.patch \
+ file://binutils-poison.patch \
+ file://libtool-rpath-fix.patch \
+ file://152_arm_branches_to_weak_symbols.patch \
+ file://200_elflink_%B_fixes.patch \
+ file://201_elflink_improve_noaddneeded_errors.patch \
+ file://202_elflink_noaddneeded_vs_weak.patch \
+ "
+
+SRC_URI[md5sum] = "2b9dc8f2b7dbd5ec5992c6e29de0b764"
+SRC_URI[sha256sum] = "71d37c96451333c5c0b84b170169fdcb138bbb27397dc06281905d9717c8ed64"
+
+BBCLASSEXTEND = "native"
+
+do_configure_prepend() {
+ sed -i -e 's: -Werror::g' ${S}/bfd/warning.m4
+
+ # These aren't getting regenerated by autotools.bbclass
+ for i in $(find ${S} -name "configure") ; do
+ sed -i -e 's: -Werror::g' $i
+ done
+}
+