aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain-layer
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain-layer')
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc138
-rw-r--r--toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb6
-rw-r--r--toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb68
3 files changed, 106 insertions, 106 deletions
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc b/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc
index 20ceb4986d..83e9a9f55c 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-4.6.inc
@@ -28,55 +28,55 @@ NATIVEDEPS = "mpfr-native gmp-native libmpc-native zlib-native"
LICENSE="GPL-3.0-with-GCC-exception & GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
- file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
- file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
- file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
- file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8"
+ file://COPYING3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://COPYING3.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
+ file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
+ file://COPYING.RUNTIME;md5=fe60d87048567d4fe8c8a0ed2448bcc8"
SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};protocol=http \
- file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
- file://100-uclibc-conf.patch \
- file://gcc-uclibc-locale-ctype_touplow_t.patch \
- file://cache-amnesia.patch \
- file://gcc-flags-for-build.patch \
- file://103-uclibc-conf-noupstream.patch \
- file://200-uclibc-locale.patch \
- file://203-uclibc-locale-no__x.patch; \
- file://204-uclibc-locale-wchar_fix.patch; \
- file://205-uclibc-locale-update.patch; \
- file://301-missing-execinfo_h.patch \
- file://302-c99-snprintf.patch \
- file://303-c99-complex-ugly-hack.patch \
- file://304-index_macro.patch \
- file://305-libmudflap-susv3-legacy.patch \
- file://306-libstdc++-namespace.patch \
- file://740-sh-pr24836.patch \
- file://800-arm-bigendian.patch \
- file://904-flatten-switch-stmt-00.patch \
- file://arm-nolibfloat.patch \
- file://arm-softfloat.patch \
- file://zecke-xgcc-cpp.patch \
- file://gcc-poison-system-directories.patch \
- file://gcc-poison-dir-extend.patch \
- file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \
- file://64bithack.patch \
- file://optional_libstdc.patch \
- file://disable_relax_pic_calls_flag.patch \
- file://COLLECT_GCC_OPTIONS.patch \
- file://use-defaults.h-and-t-oe-in-B.patch \
- file://powerpc-e5500.patch \
- file://fix-for-ice-50099.patch \
- file://gcc-with-linker-hash-style.patch \
- file://pr46934.patch \
- file://pr32219.patch \
- file://pr47551.patch \
- file://gcc-arm-set-cost.patch \
- file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
- file://fortran-cross-compile-hack.patch \
- file://cpp-honour-sysroot.patch \
- file://mips64-default-n64.patch \
- file://gcc-argument-list-too-long.patch \
- "
+ file://gcc-4.3.1-ARCH_FLAGS_FOR_TARGET.patch \
+ file://100-uclibc-conf.patch \
+ file://gcc-uclibc-locale-ctype_touplow_t.patch \
+ file://cache-amnesia.patch \
+ file://gcc-flags-for-build.patch \
+ file://103-uclibc-conf-noupstream.patch \
+ file://200-uclibc-locale.patch \
+ file://203-uclibc-locale-no__x.patch; \
+ file://204-uclibc-locale-wchar_fix.patch; \
+ file://205-uclibc-locale-update.patch; \
+ file://301-missing-execinfo_h.patch \
+ file://302-c99-snprintf.patch \
+ file://303-c99-complex-ugly-hack.patch \
+ file://304-index_macro.patch \
+ file://305-libmudflap-susv3-legacy.patch \
+ file://306-libstdc++-namespace.patch \
+ file://740-sh-pr24836.patch \
+ file://800-arm-bigendian.patch \
+ file://904-flatten-switch-stmt-00.patch \
+ file://arm-nolibfloat.patch \
+ file://arm-softfloat.patch \
+ file://zecke-xgcc-cpp.patch \
+ file://gcc-poison-system-directories.patch \
+ file://gcc-poison-dir-extend.patch \
+ file://gcc-4.3.3-SYSROOT_CFLAGS_FOR_TARGET.patch \
+ file://64bithack.patch \
+ file://optional_libstdc.patch \
+ file://disable_relax_pic_calls_flag.patch \
+ file://COLLECT_GCC_OPTIONS.patch \
+ file://use-defaults.h-and-t-oe-in-B.patch \
+ file://powerpc-e5500.patch \
+ file://fix-for-ice-50099.patch \
+ file://gcc-with-linker-hash-style.patch \
+ file://pr46934.patch \
+ file://pr32219.patch \
+ file://pr47551.patch \
+ file://gcc-arm-set-cost.patch \
+ file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
+ file://fortran-cross-compile-hack.patch \
+ file://cpp-honour-sysroot.patch \
+ file://mips64-default-n64.patch \
+ file://gcc-argument-list-too-long.patch \
+"
SRC_URI_append_sh3 = " file://sh3-installfix-fixheaders.patch "
@@ -89,31 +89,31 @@ FORTRAN = ""
JAVA = ""
EXTRA_OECONF_BASE = " --enable-lto \
- --enable-libssp \
- --disable-bootstrap \
- --disable-libgomp \
- --disable-libmudflap \
- --with-system-zlib \
- --with-linker-hash-style=${LINKER_HASH_STYLE} \
- --with-ppl=no \
- --with-cloog=no \
- --enable-cheaders=c_global "
+ --enable-libssp \
+ --disable-bootstrap \
+ --disable-libgomp \
+ --disable-libmudflap \
+ --with-system-zlib \
+ --with-linker-hash-style=${LINKER_HASH_STYLE} \
+ --with-ppl=no \
+ --with-cloog=no \
+ --enable-cheaders=c_global "
EXTRA_OECONF_INITIAL = "--disable-libmudflap \
- --disable-libgomp \
- --disable-libssp \
- --disable-libquadmath \
- --with-system-zlib \
- --disable-lto \
- --disable-plugin \
- --enable-decimal-float=no"
+ --disable-libgomp \
+ --disable-libssp \
+ --disable-libquadmath \
+ --with-system-zlib \
+ --disable-lto \
+ --disable-plugin \
+ --enable-decimal-float=no"
EXTRA_OECONF_INTERMEDIATE = "--disable-libmudflap \
- --disable-libgomp \
- --disable-libquadmath \
- --with-system-zlib \
- --disable-lto \
- --disable-plugin \
- --disable-libssp"
+ --disable-libgomp \
+ --disable-libquadmath \
+ --with-system-zlib \
+ --disable-lto \
+ --disable-plugin \
+ --disable-libssp"
EXTRA_OECONF_append_libc-uclibc = " --disable-decimal-float "
diff --git a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
index 788391a2e9..5c2435fc9a 100644
--- a/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb
@@ -13,9 +13,9 @@ SYSTEMLIBS = "/lib/"
SYSTEMLIBS1 = "/usr/lib/"
EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
- --disable-libgomp --disable-libmudflap \
- --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
- --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
+ --disable-libgomp --disable-libmudflap \
+ --with-mpfr=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-mpc=${STAGING_DIR_HOST}${layout_exec_prefix}"
# to find libmpfr
# export LD_LIBRARY_PATH = "{STAGING_DIR_HOST}${layout_exec_prefix}"
diff --git a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
index 4dade08392..fc2c1e31ae 100644
--- a/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
+++ b/toolchain-layer/recipes-devtools/gcc/libgcc_4.6.bb
@@ -8,56 +8,56 @@ PKGSUFFIX = ""
PKGSUFFIX_class-nativesdk = "-nativesdk"
PACKAGES = "\
- ${PN} \
- ${PN}-dev \
- ${PN}-dbg \
- libgcov${PKGSUFFIX}-dev \
- "
+ ${PN} \
+ ${PN}-dev \
+ ${PN}-dbg \
+ libgcov${PKGSUFFIX}-dev \
+"
FILES_${PN} = "${base_libdir}/libgcc*.so.*"
FILES_${PN}-dev = " \
- ${base_libdir}/libgcc*.so \
- ${libdir}/${TARGET_SYS}/${BINV}/*crt* \
- ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
+ ${base_libdir}/libgcc*.so \
+ ${libdir}/${TARGET_SYS}/${BINV}/*crt* \
+ ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
FILES_libgcov${PKGSUFFIX}-dev = " \
- ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \
- "
+ ${libdir}/${TARGET_SYS}/${BINV}/libgcov.a \
+"
FILES_${PN}-dbg += "${base_libdir}/.debug/"
do_configure () {
- target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
- install -d ${D}${base_libdir} ${D}${libdir}
- cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
- mkdir -p ${B}/${BPN}
- cd ${B}/${BPN}
- chmod a+x ${S}/${BPN}/configure
- ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
+ target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
+ install -d ${D}${base_libdir} ${D}${libdir}
+ cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${B}
+ mkdir -p ${B}/${BPN}
+ cd ${B}/${BPN}
+ chmod a+x ${S}/${BPN}/configure
+ ${S}/${BPN}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
}
do_compile () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
- cd ${B}/${BPN}
- oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
+ target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ cd ${B}/${BPN}
+ oe_runmake MULTIBUILDTOP=${B}/$target/${BPN}/
}
do_install () {
- target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
- cd ${B}/${BPN}
- oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
+ target=`echo ${TARGET_SYS} | sed -e s#-nativesdk##`
+ cd ${B}/${BPN}
+ oe_runmake 'DESTDIR=${D}' MULTIBUILDTOP=${B}/$target/${BPN}/ install
- # Move libgcc_s into /lib
- mkdir -p ${D}${base_libdir}
- if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
- mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
- else
- mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
- fi
+ # Move libgcc_s into /lib
+ mkdir -p ${D}${base_libdir}
+ if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
+ mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
+ else
+ mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
+ fi
- # install the runtime in /usr/lib/ not in /usr/lib/gcc on target
- # so that cross-gcc can find it in the sysroot
+ # install the runtime in /usr/lib/ not in /usr/lib/gcc on target
+ # so that cross-gcc can find it in the sysroot
- mv ${D}${libdir}/gcc/* ${D}${libdir}
- rm -rf ${D}${libdir}/gcc/
+ mv ${D}${libdir}/gcc/* ${D}${libdir}
+ rm -rf ${D}${libdir}/gcc/
}
do_package_write_ipk[depends] += "virtual/${MLPREFIX}libc:do_package"