aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* cpuburn-neon: fix packaging to use a date as version and valid sourcesdenzil-nextOtavio Salvador2013-01-181-7/+5
| | | | | | | | | | | | * The package were not versioning the sources as the files had no version on its name. We workaround it mangling the DL_DIR; * We now dynamically check if the machine has or not neon feature and set COMPATIBLE_MACHINE. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd_v189: add D_P=-1Eric Bénard2013-01-071-0/+2
| | | | | | | | | | | | now users have the choice : * keep the old behaviour when not using systemd : PREFERRED_PROVIDER_udev = "udev" * switch to systemd (while keeping upgrade path) : PREFERRED_PROVIDER_udev = "systemd" PREFFERED_VERSION_systemd = "v189" Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
* systemd: recover previous _git recipeEric Bénard2013-01-073-0/+560
| | | | Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd: move _git to _v189Eric Bénard2013-01-0712-4/+4
| | | | | Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
* kmod: fix git repo URLEric Bénard2012-12-211-1/+1
| | | | | | backported from OE-Core : 156e0fca979585f72323041f8d8aeafcbd43dfc3 Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd: use system variables instead of hardcoded pathsTing Liu2012-12-161-1/+4
| | | | | | | | | | | | | | | | | | | | | | Back port commit 980b338fb5100ff4c779335a86f3d9450ea8c54a Below is the original commit message: Fix build for ppc64 Consider /lib64 and /usr/lib64 Some 64bit architectures chose lib64 instead of lib for default library dirnames. So we dig this from metadata vars base_libdir and libdir instead of hardcoding 'lib' ppc64 in OE uses lib64 for default libdir and this leaves lot of udev/systemd files unpackaged since 'lib' was hardcoded Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Ting Liu <b28495@freescale.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd: update to v189Koen Kooi2012-12-1613-413/+1123
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* gdm: do not rely on dev-tty7.deviceAndreas Müller2012-12-162-3/+2
| | | | | | | | | | | | | Error message was: [ TIME ] Timed out waiting for device dev-tty7.device. [DEPEND] Dependency failed for Gnome Display Manager. run tested on overo/xfce Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* meta-systemd: systemd-systemctl-native: Also add support for WantedBy=*.serviceDenis 'GNUtoo' Carikli2012-12-162-2/+2
| | | | | | | | | Right now there was only WantedBy=*.target, which prevented some services from beeing installed, which prevent them from running at boot. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd-systemctl-native: handle ALIAS tagAndreas Müller2012-12-162-1/+18
| | | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd-systemctl-native: extend systemctl wrapper to support mask actionMartin Jansa2012-12-162-1/+19
| | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd-systemctl-native: Add additional messages for better debuggingAndreas Müller2012-12-162-1/+6
| | | | | | | | These messages helped me to fix the breakage of networkmanager/systemd Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libxaw: Fix libxaw-dev to not depends on non-existent libxaw packageOtavio Salvador2012-09-141-0/+4
| | | | | | | | | | The libxaw recipe generate a binary package for each soname of libxaw (currently libxaw6-6 and libxaw-7-7) but no libxaw so libxaw-dev cannot depends on it. Reported-by: Daiane Angolini <daiane.angolini@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
* sox: add 14.4.0Koen Kooi2012-09-021-0/+26
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd.bbclass: introduce SYSTEMD_AUTO_ENABLE variableAndreas Müller2012-09-021-2/+4
| | | | | | | | Currently all services introduced are enabled and started at installation. By setting SYSTEMD_AUTO_ENABLE = "disable" the default behaviour can be overridden. Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd.bbclass: do not warn for systemd files are in ${PN}Andreas Müller2012-09-021-7/+2
| | | | | | Since we have our own layer there is no need to separate out systemd packages Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd.bbclass: extract SYSTEMD_SERVICE properlyAndreas Müller2012-09-021-5/+9
| | | | | | | | | | | | | | | | | | | | To set service files the following syntax is allowed: SYSTEMD_SERVICE = <service_file> or SYSTEMD_SERVICE_{<systemd_package_name>} = <service_file> A function get_package_var was introduced to handle all use-cases [1] properly. Build tested / buildhistory checks [1] http://lists.linuxtogo.org/pipermail/openembedded-devel/2012-May/039870.html Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd.bbclass: remove unused codeAndreas Müller2012-09-021-5/+0
| | | | | | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* nodejs: update to 0.6.20Koen Kooi2012-09-021-3/+2
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* orc: update to 0.4.16Koen Kooi2012-09-022-6/+6
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* cramfs_cvs.bb: fix compile step so it can be rerun without failingMatthew McClintock2012-08-131-1/+2
| | | | | | Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* systemd: cleanup /var/run on boot and create /var/run/utmpMartin Jansa2012-08-132-1/+8
| | | | | | | | | | | | | | * Angstrom uses /var/run cleanup because: Some apps (e.g. avahi-daemon) to clean up their old-style pid files and fail to start every other boot. Se we let systemd clean it on boot. Which seems general enough, so lets move var-run.conf from base-files.bbappend to systemd recipe. * /var/run/utmp was created by volatiles before, but without sysvinit installed systemd-update-utmp-runlevel.service fails to start without this file Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Eric Bénard <eric@eukrea.com>
* ltrace: Fix make errorFranklin Cooper Jr2012-08-131-2/+2
| | | | | | | | * Fixes the make: invalid option -- '/' error Signed-off-by: Franklin S Cooper Jr <fcooper@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* xserver-common 1.34: sync /etc/X11/Xsession.d/90xXWindowManager with ↵Denis Carikli2012-07-302-11/+8
| | | | | | | | | | | x11-common(oe-core) Without that fix environments like sato cannot start because they require x-session-manager to be started instead of x-window-manager. Signed-off-by: Denis Carikli <denis@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
* v4l-utils 0.8.8: disable qv4l2 buildKoen Kooi2012-07-302-1/+44
| | | | | | | It picks up host qmake and breaks the build. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libnl: upgrade to 3.2.9 and fix upgrade pathMartin Jansa2012-07-151-5/+9
| | | | | | | | | * COPYING change is only formal from http://git.infradead.org/users/tgr/libnl.git/commitdiff/c857625be074a7b9ef6adbcdde986a0b23aae901 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libnl: bump PEMartin Jansa2012-07-151-0/+2
| | | | | | | | * libnl-2 in oe-core has PE 1, so in order to have upgrade patch from libnl-2 to libnl-3 we need PE 1 here too Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* ntp: unbreak fetching of ntp-sslKoen Kooi2012-07-131-1/+1
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* opencv, opencv-samples: drop 2.3.1Koen Kooi2012-07-133-155/+0
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* opencv, opencv-samples: add 2.4.2Koen Kooi2012-07-133-0/+155
| | | | | | | Libav is easier to get right than gstreamer, so switch back. Also enable libv4l for better v4l(2) support Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* python-docutils: update to 0.9.1Koen Kooi2012-07-131-5/+3
| | | | | | | This fixes the 'no module named Roman' errors. License checksum changed due to date changes Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* cheese: add 2.30.1Koen Kooi2012-07-131-0/+14
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* yavta: add patch to enable streaming to stdoutKoen Kooi2012-07-132-2/+857
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libjpeg-turbo: add LEAD_SONAME to fix upgrade to 8dMartin Jansa2012-07-131-0/+3
| | | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* edje: explicitly enable libsndfile for target recipeMartin Jansa2012-07-131-1/+6
| | | | | | | | | * there is no native/nativesdk support in libsndfile so disable it fro native/nativesdk edje * Thanks to Koen for noticing that it's autodetected and sometimes leaks into feeds Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libjpeg-turbo: update 1.2.1 / use version 8d to follow oe-core libjpeg updateAndreas Müller2012-07-131-2/+2
| | | | | | | | | without following oe-core's version PREFERRED_PROVIDER_jpeg does not work and libjpeg is build. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* kernel.bbclass: pass KERNEL_VERSION to depmod calls in postinstMartin Jansa2012-07-131-2/+2
| | | | | | | | | | | * without this, kernel upgrades where KERNEL_VERSION is changed e.g. 3.4.2 -> 3.4.3 generate .dep for running 3.4.2 and after reboot user ends up without any module loaded to make it worse after reboot nothing is upgraded to trigger another kernel(-module) postinst to generate .dep for now running 3.4.3 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* python-numpy : Correct difflib dependency.Dan McDougall2012-07-131-2/+2
| | | | | | | | | The previous patch had python-diffutils when it should have been python-difflib. Signed-off-by: Dan McDougall <daniel.mcdougall@liftoffsoftware.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* gateone: add config fileKoen Kooi2012-07-132-1/+9
| | | | | | | | | The config file changes some options to have a lower latency for key input Based on https://github.com/liftoff/meta-oe/commit/9cb653845d7bb4416d2e8e6c5a09a54e08dd7578 by Dan McDougall Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* gateone: update to 1.1Koen Kooi2012-07-131-20/+25
| | | | | | | | | Sort RDEPENDS alphabetically as well. Based on https://github.com/liftoff/meta-oe/commit/9cb653845d7bb4416d2e8e6c5a09a54e08dd7578 by Dan McDougall Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* owfs: enable/disable modules to make build predicableOtavio Salvador2012-07-131-0/+7
| | | | | | | | | We enforce the avaiability of w1 kernel support and owfs filesystem but disable Perl, Python and PHP buildings for now. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* owfs: update to 2.8p15Otavio Salvador2012-07-131-2/+2
| | | | | | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* python-numpy: Fixed numpy dependencies.Dan McDougall2012-07-131-0/+5
| | | | | | | | | Numpy was missing a number of dependencies in the .bb file without which it will not work. Signed-off-by: Dan McDougall <daniel.mcdougall@liftoffsoftware.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* libidl: Update LICENSE to contain actual versionchase maupin2012-07-132-2/+2
| | | | | | | | | | * Updated the LICENSE field to contain the version of the LGPL being used which is LGPLv2+ * Update the PR to reflect this license change Signed-off-by: Chase Maupin <Chase.Maupin@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* bootchart: update to v1.16Koen Kooi2012-07-133-5/+99
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* nodejs 0.6.18: fix patch nameKoen Kooi2012-07-131-1/+1
| | | | | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* nodejs: update to 0.6.18 and fix hardfloat detectionOtavio Salvador2012-07-132-5/+29
| | | | | | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* fb-test: add latest git versionKoen Kooi2012-07-131-0/+19
| | | | | | | This is a suite of utils to test the linux framebuffer and aid in debugging problems. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* rrdtool: add 1.4.7Koen Kooi2012-07-132-0/+1766
| | | | | | | All binding are disabled since they are not safe for cross-compilation. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
* cloud9: add patch to make it use nodejs 0.6.x for executing scriptsKoen Kooi2012-05-182-2/+32
| | | | | | | This matches the default nodejs version in OE Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>