aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* mozjs: Avoid use of X11 from host when X11 is disabledstable/thud-nmutstable/thud-nextOtavio Salvador2019-02-031-1/+1
| | | | | | | | | | The mozjs build system makes use of host headers and libraries if not passed an invalid path for `--x-includes` and `--x-libraries`. This fixes host contamination while building in a development host. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* polkit: Fix CVE-2019-6133Ovidiu Panait2019-01-232-0/+191
| | | | | | | | | | | | | | | | In PolicyKit (aka polkit) 0.115, the start time protection mechanism can be bypassed because fork() is not atomic, and therefore authorization decisions are improperly cached. This is related to lack of uid checking in polkitbackend/polkitbackendinteractiveauthority.c. Reference: https://nvd.nist.gov/vuln/detail/CVE-2019-6133 Upstream patch: https://gitlab.freedesktop.org/polkit/polkit/commit/c898fdf4b1aafaa04f8ada9d73d77c8bb76e2f81 Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openjpeg: fix build for multilibAndreas Müller2019-01-111-0/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | ERROR: openjpeg-2.3.0-r0 do_package: QA Issue: openjpeg: Files/directories were installed but not shipped in any package: | /usr/lib/libopenjp2.a | /usr/lib/libopenjp2.so | /usr/lib/libopenjp2.so.2.3.0 | /usr/lib/libopenjp2.so.7 | /usr/lib/cmake | /usr/lib/pkgconfig | /usr/lib/cmake/openjpeg-2.3 | /usr/lib/cmake/openjpeg-2.3/OpenJPEGConfig.cmake | /usr/lib/cmake/openjpeg-2.3/OpenJPEGTargets.cmake | /usr/lib/cmake/openjpeg-2.3/OpenJPEGTargets-noconfig.cmake | /usr/lib/pkgconfig/libopenjp2.pc * Addresses [1] * Build tested with poppler in multilib and non-multilib environment (From master: a96e6d71) [1] https://github.com/openembedded/meta-openembedded/issues/103 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* networkmanager: move udev-rules from /usr/lib -> /libAndreas Müller2019-01-111-1/+2
| | | | | | | | | | | Seems udev-rules in /usr/lib are ignored: systemd-analayse reported >3min! for system startup time! (From master: 331b717b) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libmtp: upgrade 1.1.5 -> 1.1.16 and reworkAndreas Müller2019-01-115-1093/+93
| | | | | | | | | | | | | | | | | * fixes gvfs with libmtp in PACKAGECONFIG: | Cross dependency libmtp found: NO found '1.1.5' but need: '>= 1.1.12' | | meson.build:436:2: ERROR: Invalid version of dependency, need 'libmtp' ['>= 1.1.12'] found '1.1.5'. * license checksum changed by change of copyright year * Do not pin udev rules to old version -> let native binary create them * Install udev rules to /lib/udev (as before the update) otherwise they are ignored (From master: a4fc0577) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libxklavier: Fix keyboard layout bug for xfce4-settingsAndreas Müller2019-01-113-0/+40
| | | | | | | | | | | * This was one the longest lasting and most annoying bug * While we are at it: rename path files -> libxklavier (From master: 97055da2) Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update SRC_URIChangqing Li2018-12-221-4/+4
| | | | | | | | | | previous database on maxmind website will be removed from January 2, 2019. and also we met checksum weekly change problem, so update the SRC_URI to http://sources.openembedded.org/ Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update geolite database checksumChangqing Li2018-12-221-12/+14
| | | | | | | | | Geolite database checksum changed today, so update it to the lastest one. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: add downloadfilename for geoip database filesChangqing Li2018-12-221-12/+12
| | | | | | | | | | | | | | | previous change of checksum don't trigger archive to re-downloaded, , which will cause checksum mismatch. add downloadfilename to trigger re-download. 1. for user with PREMIRROR, another benefit is it can still compile success event upstream checksum change frequently. 2. but for user don't use PREMIRROR, if upstream checksum changed, still might have checksum mismatch problem. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* glog: fix installation pathVyacheslav Yurkov2018-12-222-0/+66
| | | | | | | | | | When glog is compiled with multilib support, it shouldn't use hardcoded paths. Paths substitued by CMake should be used instead. Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> Tested-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* glog: fixed the build for mips and other platformsVyacheslav Yurkov2018-12-221-23/+30
| | | | | | | | | | | According to build log http://errors.yoctoproject.org/Errors/Details/201286/ FindLibunwind wokred only for x86, arm, and x86_64. This patch extends the cmake module to work with mips, ia64, ppc(64) and other architectures supported by libunwind Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* sblim-sfc-common: use official SPDX license for EPLArmin Kuster2018-11-221-1/+1
| | | | | | | | | | WARNING: sblim-sfc-common-1.0.1-r0 do_populate_lic: sblim-sfc-common: No generic license file exists for: EPL in any provider it is EPL-1.0 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* packagegroup-meta-oe: fix build issuesArmin Kuster2018-11-221-5/+7
| | | | | | | | | | | | | | | | | | | | | ERROR: Required build target 'meta-oe-image' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-oe-image', 'packagegroup-meta-oe', 'freeglut'] ERROR: Required build target 'meta-oe-image' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-oe-image', 'packagegroup-meta-oe', 'libsdl2-ttf'] ERROR: Required build target 'meta-oe-image' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-oe-image', 'packagegroup-meta-oe', 'libmad'] ERROR: Required build target 'meta-oe-image' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-oe-image', 'packagegroup-meta-oe', 'faad2'] ERROR: Required build target 'meta-oe-image' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-oe-image', 'packagegroup-meta-oe', 'mpv'] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ndctl: fix compile issueArmin Kuster2018-11-221-0/+3
| | | | | | | | | | | | No package 'systemd' found | configure: error: systemd support requested but pkg-config unable to query systemd package add PACKCONFIG to disable systemd Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* opensc: 0.18.0 version fix fetch errorArmin Kuster2018-11-181-1/+1
| | | | | | | | | | | ERROR: opensc-0.18.0-r0 do_fetch: Fetcher failure for URL: 'http://ftp.debian.org/debian/pool/main/o/opensc/opensc_0.18.0.orig.tar.gz'. Unable to fetch URL from any source. This version is no longer hosted on the main debian URL so use the archive URL Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* fio: Upgrade to 3.12Mingli Yu2018-11-182-5/+5
| | | | | | | | | | Refresh 0001-update-the-interpreter-paths.patch as the folder unit_tests/ is renamed to t/ in below commit: c44d2c6e Move steady state unit test to t/ Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* log4cplus: Upgrade to 2.0.2Mingli Yu2018-11-181-2/+2
| | | | | | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* iozone3: Upgrade to 484Mingli Yu2018-11-181-2/+2
| | | | | | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mcelog: Upgrade to 161Mingli Yu2018-11-181-1/+1
| | | | | | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libestr: Upgrade to 0.1.11Mingli Yu2018-11-181-2/+2
| | | | | | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* tk: export TK_LIBRARY='${libdir}/tk${VER}'Mingli Yu2018-11-181-9/+1
| | | | | | | | | | | | | | | | | | | | | | | As there is below logic in configure.in [snip] test -z "$TK_LIBRARY" && TK_LIBRARY='$(prefix)/lib/tk$(VERSION)' [snip] It can make TK_LIBRARY to be $(prefix)/lib/tk$(VERSION) and then result in some files installed to /usr/lib/tk8.6 even when ${libdir} actually extract as /usr/lib64 and there is also a commit as below adding hack to workaround this. 1ca29d1cd tk: make multilib build compatible and fix library install Export TK_LIBRARY='${libdir}/tk${VER}' to guarantee the files installed to the expected places and also remove the workaround in the previous commit 1ca29d1cd. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* tk: update the parameter for --with-tclMingli Yu2018-11-181-1/+1
| | | | | | | | | | | Update the parameter for --with-tcl to fix below do_configure issue: $ bitbake tk-native | checking for Tcl configuration... configure: error: /mybuild/tmp/work/x86_64-linux/tk-native/8.6.8-r0/recipe-sysroot-native/usr/bin directory doesn't contain tclConfig.sh Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* meta-oe: add selftest for sources.oe.orgArmin Kuster2018-11-181-0/+30
| | | | | | Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* networkmanager: package additional .la filesMark Asselstine2018-11-151-0/+1
| | | | | | | | | | | | | | | | | | | This fixes: ERROR: networkmanager-1.14.4-r0 do_package: QA Issue: networkmanager: Files/directories were installed but not shipped in any package: /usr/lib64/NetworkManager/1.14.4/libnm-settings-plugin-ifupdown.la /usr/lib64/NetworkManager/1.14.4/libnm-device-plugin-adsl.la /usr/lib64/NetworkManager/1.14.4/libnm-device-plugin-wifi.la /usr/lib64/NetworkManager/1.14.4/libnm-device-plugin-ovs.la Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. networkmanager: 4 installed and not shipped files. [installed-vs-shipped] As with similar changes in the past, if the distro makes use of 'remove-libtool' this issue is not seen but we should add .la files to the -dev package when they do exist. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* xscreensaver: add distro_features_check for x11Martin Jansa2018-11-151-1/+3
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* xscreensaver: fix indentation and use BPN/BP in SRC_URIMartin Jansa2018-11-151-5/+7
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ntp: Reproducible build: Use fixed path to posix shelldouglas.royds2018-11-152-0/+16
| | | | | | | | | | | | | | | At configure time, the ntp build goes looking on the build machine for a posix shell, using `which` to find it. Under OE, it settles on hosttools/bash, resulting in this build host path being written into several binaries. This did not affect the Debian reproducibility project, presumably because it consistently found bash at /bin/bash. Don't go looking, just use a fixed path to /bin/sh instead. Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3551 Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ntp: Reproducible build: Respect SOURCE_DATE_EPOCHdouglas.royds2018-11-152-0/+17
| | | | | | | | | | | | | | | If a SOURCE_DATE_EPOCH is set in the environment, use that date in the build version string, otherwise use the current build date. See https://reproducible-builds.org/docs/source-date-epoch/ Should GNU date options fail, try BSD date options as a fall-back. This patch can potentially be pushed upstream for use on Mac OSX or OpenBSD, though it has not been tested on OSX or any BSD platform. Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3550 Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* stress-ng: Upgrade from 0.09.37 to 0.09.45Randy MacLeod2018-11-154-70/+34
| | | | | | | | | | | | Drop the upstreamed patch: 0001-stress-ng-don-t-enable-TARGET_CLONES-for-musl.patch Rebase other patches except for the stress-malloc.c change which has made it upstream: c3a2e662 stress-malloc: use HAVE_MALLOPT check for mallopt glibc function Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update GeoLite Database checksumChangqing Li2018-11-151-4/+4
| | | | | | | | | GeoLite Database checksum changed again recently, so update it. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ptest: add addition packagegroups and image for ptestsArmin Kuster2018-11-155-0/+270
| | | | | | | | | Need a method to run ptests in meta-oe and to build test tasks not done via a world build Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* imagemagick: add PACKAGECONFIG[rsvg]Binghua Guan2018-11-151-1/+2
| | | | | | Signed-off-by: Binghua Guan <freebendy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* nftables: Upgrade to 0.9.0Alex Kiernan2018-11-1510-918/+20
| | | | | | | | Drop all the backports as they're upstream Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libnftnl: Upgrade to 1.1.1Alex Kiernan2018-11-154-3068/+441
| | | | | | Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libgpiod: bump version to v1.2Bartosz Golaszewski2018-11-151-2/+2
| | | | | | Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* hwloc: Update the SRC_URIMingli Yu2018-11-151-1/+1
| | | | | | | | | | | | Update the SRC_URI to fix below issue: $ bitbake -cfetch lib32-hwloc ERROR: lib32-hwloc-1.11.10-r0 do_fetch: Fetcher failure for URL: 'https://www.open-mpi.org/software/lib32-hwloc/v1.11/downloads/hwloc-1.11.10.tar.bz2'. Unable to fetch URL from any source. Actually the source located under https://www.open-mpi.org/software/hwloc/v1.11/downloads/hwloc-1.11.10.tar.bz2 Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* libunique: fix installed-vs-shipped qa issueKai Kang2018-11-151-0/+4
| | | | | | | | | | | | | | | | libunique shows installed-vs-shipped QA issue if configure option '--disable-introspection' is set by: 1) in gobject-introspection*.bbclass that the 'qemu-usermode' is not supported by bsp and then not set in MACHINE_FEATURES or: 2) set in local.conf directly: EXTRA_OECONF_append_pn-libunique = " --disable-introspection" Remove empty directory to fix the QA issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* sedutil: Add recipePrimoz Fiser2018-11-151-0/+17
| | | | | | | | | sedutil is utility to manage self encrypting drives that conform to the Trusted Computing Group OPAL 2.0 SSC specification. Signed-off-by: Primoz Fiser <primoz.fiser@norik.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* curlpp: Fix packaging and reference to licenseRobert Tiemann2018-11-151-16/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | This patch fixes three issues: 1. The recipe used "libcurlpp" for its package base name. It defined PACKAGES and corresponding package contents manually, but the non-standard naming led to an error message when trying to depend on it (nothing provides curlpp needed by curlpp-dev). See also https://lists.yoctoproject.org/pipermail/poky/2018-February/011236.html. Fixed by removing PACKAGES and corresponding FILES_*, relying on automatic packaging now. 2. Upstream ships a license file (MIT), which is referenced by the recipe now (instead of the stock COPYING.MIT file). 3. There was a do_install_append() function which patched the installed curlpp.pc file. Since it seemed to be of no use, it was removed. Signed-off-by: Robert Tiemann <rtie@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* tk: extend to nativesdkMingli Yu2018-11-151-1/+1
| | | | | | | | | | | | After enable tk via PACKAGECONFIG for python3, there comes below error: Missing or unbuildable dependency chain was: ['buildtools-tarball', 'nativesdk-python3', 'nativesdk-tk'] Extend tk to nativesdk to fix this issue. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* networkmanager: Fix build with muslKhem Raj2018-11-152-0/+54
| | | | | | | | Remove redundant header includes Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* Adding support for xscreensaver-5.39Parthiban Nallathambi2018-11-154-0/+428
| | | | | | | | | - This patch enables the support for xscreensaver 5.39 version - xscreensaver.service created for the system with systemd Signed-off-by: Parthiban Nallathambi <pn@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* meta-xfce: xfconf: fixup installed-vs-shipped QA issueMark Asselstine2018-11-151-0/+2
| | | | | | | | | | | | | | | | | | Since the xfconf uprev, commit 4222cac97678 [xfconf: 4.13.5 -> 4.13.6], we are getting a QA issue: ERROR: xfconf-4.13.6-r0 do_package: QA Issue: xfconf: Files/directories were installed but not shipped in any package: /usr/lib64/gio/modules/libxfconfgsettingsbackend.la Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. xfconf: 1 installed and not shipped files. [installed-vs-shipped] ERROR: xfconf-4.13.6-r0 do_package: Fatal QA errors found, failing task. ERROR: xfconf-4.13.6-r0 do_package: Function failed: do_package We need to include the .la file in the -dev package to avoid this. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* python-configparser.inc: Fix SUMMARYAlexandru Vasiu2018-11-151-1/+1
| | | | | | | | | SUMMARY contained a non-ascii char (’ instead of ') which caused pkg.info_installed to fail. Signed-off-by: Alexandru Vasiu <alexandru.vasiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* network-manager-applet: move GNOMEBASEBUILDCLASS to correct positionChangqing Li2018-11-151-2/+1
| | | | | | | | | GNOMEBASEBUILDCLASS is used by gnomebase, if put it after inherit gnomebase, GNOMEBASEBUILDCLASS in recipe will not take effect Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* vim-tiny: remove alternative for xxdRicardo Salveti2018-11-151-0/+1
| | | | | | | | | | | | xxd is not available in vim-tiny, so remove from the default ALTERNATIVE list to fix the following warning: vim-tiny: alternative target (/usr/bin/xxd or /usr/bin/xxd.vim-tiny) does not exist, skipping Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* modemmanager: set udev base dir to ${nonarch_base_libdir}/udevRicardo Salveti2018-11-151-0/+4
| | | | | | | | | Fixes QA issue when building modemmanager with usrmerge: /lib should be relocated to /usr. [usrmerge] Signed-off-by: Ricardo Salveti <ricardo@foundries.io> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* cpprest: upgrade to version 2.10.7 and add support for brotli libraryGianfranco Costamagna2018-11-155-49/+74
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* brotli: add initial recipe, based on meta-webkit layerGianfranco Costamagna2018-11-151-0/+14
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* glog: updated libunwind look up functionVyacheslav Yurkov2018-11-153-34/+115
| | | | | | | | | | | | Updated FindLinunwind cmake file to locate libunwind properly in the system. This includes settings all needed defines in config.h file, which are used for glog compilation. Changed unwind cmake target to interface, because in cross-compilation environment we could link against several libunwind shared libraries. Signed-off-by: Vyacheslav Yurkov <Vyacheslav.Yurkov@bruker.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>