aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
Commit message (Collapse)AuthorAgeFilesLines
* utilities: Fix build failure with -Werror=maybe-uninitializedHe Zhe2019-03-192-0/+36
| | | | | | | | | | | Initialize magic_number to zero to avoid such failure. utilities/blob_db/blob_log_format.cc:91:3: error: 'magic_number' may be used uninitialized in this function [-Werror=maybe-uninitialized] if (magic_number != kMagicNumber) { ^~ Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Fix build for RISC-VKhem Raj2019-03-152-0/+42
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: fix atomic support on armMingli Yu2019-03-152-1/+35
| | | | | | | | | | Check to link with libatomic to enable C11 atomics support to fix below build error on arm: | /build/tmp/work/armv5e-wrs-linux-gnueabi/mariadb/10.3.13-r0/recipe-sysroot-native/usr/bin/arm-wrs-linux-gnueabi/../../libexec/arm-wrs-linux-gnueabi/gcc/arm-wrs-linux-gnueabi/8.3.0/ld.bfd: librocksdblib.a(env_posix.cc.o): in function `std::__atomic_base<unsigned long long>::store(unsigned long long, std::memory_order)': | /usr/include/c++/8.3.0/bits/atomic_base.h:374: undefined reference to `__atomic_store_8' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mysql-python: fix compilation with MariaDB 10.3.13Mingli Yu2019-03-072-1/+37
| | | | | | | | | | | | Use standard API function MYSQL_OPT_RECONNECT instead of direct modification of internal structures which does not work for MariaDB to fix below compile issue. | _mysql.c: In function '_mysql_ConnectionObject_ping': | _mysql.c:2005:41: error: 'MYSQL' {aka 'struct st_mysql'} has no member named 'reconnect' Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: Upgrade to 10.3.13Mingli Yu2019-03-0614-271/+248
| | | | | | | | | | | | | | | | | | | | | | | | | | Per https://mariadb.org/about/maintenance-policy/, mariadb 5.5.x series only supported until next year April 2020, so upgrade it to 10.3.13. Remove some deprecated patches, add some new patches to fix build failure and rework two patches to avoid fuzz warnings. Add -latomic to linker flags for armv5 Use -pthread to link for mussing atomic symbols on arches e.g. riscv Fixes issues like ld.bfd: librocksdblib.a(memtable.cc.o):/usr/include/c++/9.0.1/bits/atomic_base.h:438: more undefined references to `__atomic_compare_exchange_1' follow Fix build with musl add libxml2 to depends Fix build with clang Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* leveldb: restrict building for mips64Slater, Joseph2019-03-041-0/+4
| | | | | | | Do not try to build lib32-leveldb. libn32-leveldb will build. Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: upgrade 1.11.1 -> 1.11.2Changqing Li2019-02-222-10/+10
| | | | | | | License-Update: Copyright Year Update Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Fix build with clangKhem Raj2019-02-132-0/+58
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Fix build with clangKhem Raj2019-02-052-0/+29
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Upgrade to 4.0.6Khem Raj2019-02-052-56/+5
| | | | | | Change License to SSPL version 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Update to 5.18 branch ( 5.18.2 )Khem Raj2019-02-051-3/+3
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: make resulting cmake config relocatablePascal Bach2019-01-191-3/+3
| | | | | | | | | | | | | RocksDB is still using CMake 2.8 and thus does not make use of importet targets. This leads to hardcoded paths to the build directory in the resulting packaged files. The workaround for the issue is to bypass CMakes detection and let the linker deal with finding the right library. This is necessary until RocksDB moves to a more modern CMake. It's also applied in the Poco recipe right now. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: fix qa warning of buildpathsKai Kang2019-01-191-0/+5
| | | | | | | | | | | | | rocksdb fails qa check buildpaths: | WARNING: rocksdb-5.17.2-r0 do_package_qa: QA Issue: File | /work/core2-64-poky-linux/rocksdb/5.17.2-r0/packages-split/rocksdb-dev/usr/lib64/cmake/rocksdb/RocksDBTargets.cmake | in package contained reference to tmpdir [buildpaths] Removing buildpath info from the cmake file. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Update the regex to determine PGMAJORVERSION to match v10+ ↵Akram Hameed2019-01-151-2/+2
| | | | | | | | database clusters Older versions of postgresql would generate MAJVER.MINVER in new clusters. 10+ do not. Update the regex to determine PGMAJORVERSION as a single int. Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: correctly build against target perlAlexander Kanavin2019-01-111-2/+6
| | | | | | | | Previously perl-native headers were erroneously included, which was causing issues with the new perl recipe. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Upgrade to 5.17.2Khem Raj2018-12-182-198/+3
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: upgrade to 11.1Changqing Li2018-11-295-7636/+27
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Allow successful run of postgresql-setupOtavio Salvador2018-11-262-4/+4
| | | | | | | | | | | | The postgresql-setup utility log-in on postgres user to create the database, however, the shell was set to bash and it wasn't being installed as runtime dependency. This rework this expectation to use busybox ash as shell and avoid the new dependency Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: Upgrade to 5.5.62Mingli Yu2018-11-023-2/+2
| | | | | | | | | | | | | | MariaDB 5.5.62 is a maintenance release. It includes bugfixes and updates, including from MySQL 5.5.62. . XtraDB updated to 5.5.61-38.13 . Fixes for the following security vulnerabilities: CVE-2018-3282 CVE-2018-3174 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Fix build issue with timezone 2018f updateArmin Kuster2018-10-223-0/+7618
| | | | | | | Sync our copy of the timezone library with IANA release tzcode2018f. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Consolidate COMPATIBLE_HOSTKhem Raj2018-09-291-13/+6
| | | | | | | | Its only available on fewer arches so express that via COMPATIBLE_HOST wiredtiger is only for 64bit, so add it directly to config args based on bitness Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: split one dpg packageHongxu Jia2018-09-181-5/+4
| | | | | | | | | | | Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: split one dpg packageHongxu Jia2018-09-181-55/+19
| | | | | | | | | | | Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Exclude on mips archKhem Raj2018-08-271-1/+2
| | | | | | Support does not exist Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mongodb: Upgrade to 4.0.1 releaseKhem Raj2018-08-2413-158/+125
| | | | | | | | Drop/adapt patches as some of them are not needed anymore Add patches to support musl especially thread stack and resolver functionality Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: Upgrade 10.4 -> 10.5Changqing Li2018-08-221-2/+2
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: upgrade 9.4.18 -> 10.4Changqing Li2018-08-113-25/+28
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: Upgrade to 5.5.61Mingli Yu2018-08-033-2/+2
| | | | | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: use util-linux's uuidRoss Burton2018-07-271-1/+1
| | | | | | | | | | Postgreqsql was configured to use ossp-uuid but ossp-uuid is dead and everyone will be building util-linux anyway, so use the libuuid.so from there. Confusing the option is called e2fs because the library originated in e2fsprogs. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: upgrade 9.4.17 -> 9.4.18changqing.li@windriver.com2018-06-292-9/+13
| | | | | Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: add UPSTREAM_CHECK_URIYi Zhao2018-05-291-0/+2
| | | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: rely on cmake.bbclass to put cmake package files in dev packageTrevor Woerner2018-05-291-2/+0
| | | | | | | | | | | | The cmake.bbclass in oe-core now ensures that ${libdir}/cmake and ${datadir}/cmake end up in the dev package, so recipes no longer need to provide custom packaging rules to handles these files. http://git.openembedded.org/openembedded-core/commit/?id=d91dc4666683a96e9d03cbbd21b8a546f9069c93 Originally-conceived-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Trevor Woerner <twoerner@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: update to 5.13.1Pascal Bach2018-05-261-3/+3
| | | | | | | The GCC 8 patch is still needed as the changes are not yet included in 5.13.x Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postgresql: remove *_config from SSTATE_SCAN_FILESKai Kang2018-05-261-0/+1
| | | | | | | | | | | | | | | | | It fails to run command pg_config with segment fault. The root cause is function sstate_hardcode_path takes elf file pg_config as a configure file and edits it with 'sed'. And then file pg_config is corrupt: $ readelf -a package/usr/bin/pg_config >/dev/null readelf: Error: Unable to read in 0x700 bytes of section headers readelf: Error: Section headers are not available! There is not other '*_config' file installed by postgresql except pg_config, so remove '*_config' from SSTATE_SCAN_FILES for postgresql. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* mariadb: Upgrade to 5.5.60Khem Raj2018-05-263-3/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* rocksdb: Fix build with gcc8Khem Raj2018-05-172-1/+197
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* postgresql: Depend on external libnslKhem Raj2018-05-172-6/+1
| | | | | | | glibc has dropped libnsl support Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mariadb: 5.5.57 -> 5.5.59Hongxu Jia2018-05-013-2/+2
| | | | | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* rocksdb: update to 5.12.2Pascal Bach2018-05-011-3/+4
| | | | | | | | Also remove the +gitSRCPV suffix from the version. This is an official release and the version should be enough, it adds only clutter. Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
* postgresql: update to 9.4.17Jackie Huang2018-04-133-30/+14
| | | | | | | | | | | | | | | | * Release notes: https://www.postgresql.org/docs/9.4/static/release-9-4-17.html * Drop the patch emove.autoconf.version.check.patch since the required autoconf version is used in oe-core. * LICENSE checksum updated since the copyright year is changed. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> [fixup for master-next context] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mongodb: refresh patches and remove un-needed patchArmin Kuster2018-04-135-112/+30
| | | | | | | | | | [V2] remove patch, changes upstream [v3] Actually remove the patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
* postgresql: refresh patchesArmin Kuster2018-04-133-21/+14
| | | | | | | | | | | | | | | | | | | | | | | | WARNING: postgresql-9.4.15-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch remove.autoconf.version.check.patch patching file configure.in Hunk #1 succeeded at 19 with fuzz 2. Now at patch remove.autoconf.version.check.patch Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mariadb(-native): refresh fix-mysqlclient-r-version.patchAndreas Müller2018-04-081-11/+10
| | | | | Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* rocksdb: move to recipe-dbsArmin Kuster2018-03-291-0/+31
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>
* leveldb: move to recipes-dbsArmin Kuster2018-03-294-0/+151
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>
* soci: update to version 3.2.3Derek Straka2018-03-121-3/+3
| | | | | | | Add dos2unix as the source now has windows line endings Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mongodb: update to version 3.4.13Derek Straka2018-03-121-2/+2
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* postgres: move to recipes-dbsArmin Kuster2018-03-0110-0/+789
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>
* mongodb: move to recipes-dbsArmin Kuster2018-03-0113-0/+616
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>
* soci: move to recipes-dbsArmin Kuster2018-03-012-0/+77
| | | | Signed-off-by: Armin Kuster <akuster808@gmail.com>