aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-09-17 14:55:22 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-09-17 14:43:22 +0100
commitdf881400d4593e68d076ee9e7560eba99d95b09b (patch)
treeb2d1b11a07dc8f27e36a777380fad1a768964182
parenta7cffceeced41d8368354e73b298ecbfa937cf2d (diff)
downloadmeta-opie-df881400d4593e68d076ee9e7560eba99d95b09b.tar.gz
opie-taskbar: fix server.pro patch for current git
Also rename the 1.2.5 version of the patch so that the name makes more sense. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/server-pro-125.patch (renamed from recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch)0
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/server-pro-git.patch69
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb2
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar_git.bb2
4 files changed, 71 insertions, 2 deletions
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-125.patch
index eb214da..eb214da 100644
--- a/recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch
+++ b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-125.patch
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/server-pro-git.patch b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-git.patch
new file mode 100644
index 0000000..fc9b34d
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-git.patch
@@ -0,0 +1,69 @@
+--- launcher/server.pro
++++ launcher/server.pro
+@@ -2,7 +2,7 @@ TEMPLATE = app
+
+ CONFIG += qt warn_on
+
+-DESTDIR = $$(OPIEDIR)/bin
++DESTDIR =
+
+ HEADERS += server.h \
+ qrr.h \
+@@ -20,7 +20,7 @@ HEADERS += server.h \
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.h \
++ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+@@ -31,7 +31,7 @@ HEADERS += server.h \
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.h \
++ mediummount/mediumwidget.h \
+ mediadlg.h \
+ virtualfs.h \
+ syncaccessmanager.h
+@@ -52,7 +52,7 @@ SOURCES += server.cpp \
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.cpp \
++ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+@@ -65,22 +65,22 @@ SOURCES += server.cpp \
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.cc \
++ mediummount/mediumwidget.cc \
+ mediadlg.cpp \
+ virtualfs.cpp \
+ syncaccessmanager.cpp
+
+
+-INCLUDEPATH += $(OPIEDIR)/core/apps/calibrate
+-DEPENDPATH += $(OPIEDIR)/core/apps/calibrate
++INCLUDEPATH += calibrate
++DEPENDPATH += calibrate
+
+-INCLUDEPATH += $(OPIEDIR)/include $(OPIEDIR)/rsync
+-DEPENDPATH += $(OPIEDIR)/rsync
++INCLUDEPATH += $(OPIEDIR)/include rsync
++DEPENDPATH += rsync
+
+-INCLUDEPATH += $(OPIEDIR)/noncore/settings/mediummount
+-DEPENDPATH += $(OPIEDIR)/noncore/settings/mediummount
++INCLUDEPATH += mediummount
++DEPENDPATH += mediummount
+
+-LIBS += -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync -lsysfs -lcrypt -lm
++LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync -lsysfs -lcrypt -lm
+ TARGET = qpe
+
+ ## not ready for use yet
diff --git a/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb b/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb
index ee01b35..e71926f 100644
--- a/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb
+++ b/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb
@@ -12,7 +12,7 @@ SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_apps_calibrate.
file://no-builtin-qss-startup-2.patch \
file://kbdlocks-runtime.patch \
file://restart-from-bindir.patch \
- file://server-pro-cvs.patch \
+ file://server-pro-125.patch \
file://firstuse-path.patch \
file://force-firstuse-calibrate.patch \
"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar_git.bb b/recipes-opie/opie-taskbar/opie-taskbar_git.bb
index 9036e72..062ff32 100644
--- a/recipes-opie/opie-taskbar/opie-taskbar_git.bb
+++ b/recipes-opie/opie-taskbar/opie-taskbar_git.bb
@@ -13,7 +13,7 @@ SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/apps/calibrate \
file://no-builtin-qss-startup-2.patch \
file://kbdlocks-runtime.patch \
file://restart-from-bindir.patch \
- file://server-pro-cvs.patch \
+ file://server-pro-git.patch \
file://firstuse-path.patch \
file://force-firstuse-calibrate.patch \
"