aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-examples
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-examples
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-examples')
-rw-r--r--recipes-opie/opie-examples/opie-examples.inc20
-rw-r--r--recipes-opie/opie-examples/opie-examples_1.2.5.bb11
-rw-r--r--recipes-opie/opie-examples/opie-examples_cvs.bb7
3 files changed, 38 insertions, 0 deletions
diff --git a/recipes-opie/opie-examples/opie-examples.inc b/recipes-opie/opie-examples/opie-examples.inc
new file mode 100644
index 0000000..d90c3e1
--- /dev/null
+++ b/recipes-opie/opie-examples/opie-examples.inc
@@ -0,0 +1,20 @@
+DESCRIPTION = "Developer Examples for Opie"
+SECTION = "opie/base"
+PRIORITY = "optional"
+DEPENDS = "opie-networksettings"
+LICENSE = "GPL"
+APPTYPE = "binary"
+
+S = "${WORKDIR}/examples"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/
+
+ for i in `find . -perm 0755 -type f`
+ do
+ install -m 0755 $i ${D}${palmtopdir}/bin/`basename $i`
+ done
+}
+
diff --git a/recipes-opie/opie-examples/opie-examples_1.2.5.bb b/recipes-opie/opie-examples/opie-examples_1.2.5.bb
new file mode 100644
index 0000000..e6d1d05
--- /dev/null
+++ b/recipes-opie/opie-examples/opie-examples_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_examples.tar.bz2;name=split_examples \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_examples.md5sum] = "9e6a0e76e883a27cc1fcb8f3df3c844e"
+SRC_URI[split_examples.sha256sum] = "73547a40fc8a0cea3561ec5402341cc49c857111df1af5217d7fb02d407e1e88"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-examples/opie-examples_cvs.bb b/recipes-opie/opie-examples/opie-examples_cvs.bb
new file mode 100644
index 0000000..fa426a8
--- /dev/null
+++ b/recipes-opie/opie-examples/opie-examples_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=examples \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"