aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-eye
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-eye
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-eye')
-rw-r--r--recipes-opie/opie-eye/opie-eye.inc27
-rw-r--r--recipes-opie/opie-eye/opie-eye_1.2.5.bb13
-rw-r--r--recipes-opie/opie-eye/opie-eye_cvs.bb8
3 files changed, 48 insertions, 0 deletions
diff --git a/recipes-opie/opie-eye/opie-eye.inc b/recipes-opie/opie-eye/opie-eye.inc
new file mode 100644
index 0000000..019d2ce
--- /dev/null
+++ b/recipes-opie/opie-eye/opie-eye.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "A image viewer"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libopiecore2 libopieui2 libopiemm2"
+RDEPENDS_${PN} = "opie-advancedfm-pics"
+APPNAME = "opie-eye"
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+do_configure_append() {
+ cd slave && qmake -makefile -spec ${QMAKESPEC} slave.pro -after ${EXTRA_QMAKEVARS_POST}
+}
+
+do_compile_append() {
+ cd slave && oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 opie-eye_slave ${D}${bindir}
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes-opie/opie-eye/opie-eye_1.2.5.bb b/recipes-opie/opie-eye/opie-eye_1.2.5.bb
new file mode 100644
index 0000000..ddaf54c
--- /dev/null
+++ b/recipes-opie/opie-eye/opie-eye_1.2.5.bb
@@ -0,0 +1,13 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_graphics_opie-eye.tar.bz2;name=split_noncore_graphics_opie-eye \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_noncore_graphics_opie-eye.md5sum] = "301fa084aaeacd10ae37698749a46403"
+SRC_URI[split_noncore_graphics_opie-eye.sha256sum] = "aa7b355eac4792aa7293362ae44c4331a642a9c9918d7231e98fca6fcb5df781"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-eye/opie-eye_cvs.bb b/recipes-opie/opie-eye/opie-eye_cvs.bb
new file mode 100644
index 0000000..7ae0402
--- /dev/null
+++ b/recipes-opie/opie-eye/opie-eye_cvs.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r1"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/graphics/opie-eye \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"