aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-notes
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-notes
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-notes')
-rw-r--r--recipes-opie/opie-notes/opie-notes.inc15
-rw-r--r--recipes-opie/opie-notes/opie-notes_1.2.5.bb11
-rw-r--r--recipes-opie/opie-notes/opie-notes_cvs.bb7
3 files changed, 33 insertions, 0 deletions
diff --git a/recipes-opie/opie-notes/opie-notes.inc b/recipes-opie/opie-notes/opie-notes.inc
new file mode 100644
index 0000000..b3a9d44
--- /dev/null
+++ b/recipes-opie/opie-notes/opie-notes.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Notes"
+SECTION = "opie/pim"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "opie-notes"
+APPTYPE = "binary"
+
+S = "${WORKDIR}/notes"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.* ${D}${palmtopdir}/pics/${APPNAME}/
+}
diff --git a/recipes-opie/opie-notes/opie-notes_1.2.5.bb b/recipes-opie/opie-notes/opie-notes_1.2.5.bb
new file mode 100644
index 0000000..ac964db
--- /dev/null
+++ b/recipes-opie/opie-notes/opie-notes_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_pim_notes.tar.bz2;name=split_core_pim_notes \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_core_pim_notes.md5sum] = "9e0de33d009052ffc926bc835ca0d968"
+SRC_URI[split_core_pim_notes.sha256sum] = "4f34029d18f015fea73c529313be2537cdb60bdcf32681ae6671898c36e14c8f"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-notes/opie-notes_cvs.bb b/recipes-opie/opie-notes/opie-notes_cvs.bb
new file mode 100644
index 0000000..a1a91d9
--- /dev/null
+++ b/recipes-opie/opie-notes/opie-notes_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/pim/notes \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"