aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-qcop
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-qcop
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-qcop')
-rw-r--r--recipes-opie/opie-qcop/files/unbreak-logging.patch16
-rw-r--r--recipes-opie/opie-qcop/opie-qcop.inc13
-rw-r--r--recipes-opie/opie-qcop/opie-qcop_1.2.5.bb8
-rw-r--r--recipes-opie/opie-qcop/opie-qcop_cvs.bb7
4 files changed, 44 insertions, 0 deletions
diff --git a/recipes-opie/opie-qcop/files/unbreak-logging.patch b/recipes-opie/opie-qcop/files/unbreak-logging.patch
new file mode 100644
index 0000000..d2b5228
--- /dev/null
+++ b/recipes-opie/opie-qcop/files/unbreak-logging.patch
@@ -0,0 +1,16 @@
+Index: opie/core/apps/qcop/qcopimpl.cpp
+===================================================================
+RCS file: /cvs/opie/core/apps/qcop/qcopimpl.cpp,v
+retrieving revision 1.2
+diff -u -r1.2 qcopimpl.cpp
+--- qcop/qcopimpl.cpp 2 Mar 2005 19:23:54 -0000 1.2
++++ qcop/qcopimpl.cpp 3 May 2007 03:09:36 -0000
+@@ -46,7 +46,7 @@
+
+ int doqcopimpl (int argc, char *argv[])
+ {
+- qInstallMsgHandler( disableqdebug );
++ //qInstallMsgHandler( disableqdebug );
+
+ if ( argc > 1 ) {
+ QString opt = argv[1];
diff --git a/recipes-opie/opie-qcop/opie-qcop.inc b/recipes-opie/opie-qcop/opie-qcop.inc
new file mode 100644
index 0000000..b9b0309
--- /dev/null
+++ b/recipes-opie/opie-qcop/opie-qcop.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Opie QCOP IPC Client"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/qcop"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/qcop ${D}${bindir}/qcop
+}
diff --git a/recipes-opie/opie-qcop/opie-qcop_1.2.5.bb b/recipes-opie/opie-qcop/opie-qcop_1.2.5.bb
new file mode 100644
index 0000000..c499d7c
--- /dev/null
+++ b/recipes-opie/opie-qcop/opie-qcop_1.2.5.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_apps_qcop.tar.bz2;name=split_core_apps_qcop \
+ file://unbreak-logging.patch"
+SRC_URI[split_core_apps_qcop.md5sum] = "9afc33ac0e5205de5008bf13b22117b2"
+SRC_URI[split_core_apps_qcop.sha256sum] = "59cf36bb4c192a36855819771eb3d986588b4c786f799b232b01bc33c0377516"
diff --git a/recipes-opie/opie-qcop/opie-qcop_cvs.bb b/recipes-opie/opie-qcop/opie-qcop_cvs.bb
new file mode 100644
index 0000000..61abdb0
--- /dev/null
+++ b/recipes-opie/opie-qcop/opie-qcop_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r3"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/apps/qcop \
+ file://unbreak-logging.patch"