aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-qss
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-qss
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-qss')
-rw-r--r--recipes-opie/opie-qss/opie-qss.inc13
-rw-r--r--recipes-opie/opie-qss/opie-qss_1.2.5.bb7
-rw-r--r--recipes-opie/opie-qss/opie-qss_cvs.bb6
3 files changed, 26 insertions, 0 deletions
diff --git a/recipes-opie/opie-qss/opie-qss.inc b/recipes-opie/opie-qss/opie-qss.inc
new file mode 100644
index 0000000..1e7ea3a
--- /dev/null
+++ b/recipes-opie/opie-qss/opie-qss.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Opie Sound Sever Daemon"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+S = "${WORKDIR}/qss"
+
+inherit opie
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/qss ${D}${bindir}/qss
+}
diff --git a/recipes-opie/opie-qss/opie-qss_1.2.5.bb b/recipes-opie/opie-qss/opie-qss_1.2.5.bb
new file mode 100644
index 0000000..ea0a426
--- /dev/null
+++ b/recipes-opie/opie-qss/opie-qss_1.2.5.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_apps_qss.tar.bz2;name=split_core_apps_qss"
+SRC_URI[split_core_apps_qss.md5sum] = "093627fc686e1e82c63f4a871d7be1d6"
+SRC_URI[split_core_apps_qss.sha256sum] = "243ad89cbeff81f414d7286199c2e43020ce23cc92ed2b1ab16a2e60783f0f7b"
diff --git a/recipes-opie/opie-qss/opie-qss_cvs.bb b/recipes-opie/opie-qss/opie-qss_cvs.bb
new file mode 100644
index 0000000..ae3eb3a
--- /dev/null
+++ b/recipes-opie/opie-qss/opie-qss_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r1"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/apps/qss"