aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-securityplugins
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-05-13 23:58:58 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-05-20 22:34:17 +0100
commit1786b04aa2fde02e0b1db4dcd2ff7be54381e8ce (patch)
treeba88dc80edd9c2f2614053065b46794878131ea8 /recipes-opie/opie-securityplugins
parenta4791297c8f8ee265337beb3678e5411cabaddf1 (diff)
downloadmeta-opie-1786b04aa2fde02e0b1db4dcd2ff7be54381e8ce.tar.gz
Fix Opie Git recipes to use SRCPV
Using SRCPV we get e.g. 1.2.5+git1+... and the number will increment when OPIE_SRCREV changes, ensuring that the version number doesn't go backwards (although it will once for this change if you have existing packages beforehand, unfortunately). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-securityplugins')
-rw-r--r--recipes-opie/opie-securityplugins/opie-securityplugin-blueping_git.bb4
-rw-r--r--recipes-opie/opie-securityplugins/opie-securityplugin-dummy_git.bb4
-rw-r--r--recipes-opie/opie-securityplugins/opie-securityplugin-notice_git.bb4
-rw-r--r--recipes-opie/opie-securityplugins/opie-securityplugin-pin_git.bb4
4 files changed, 8 insertions, 8 deletions
diff --git a/recipes-opie/opie-securityplugins/opie-securityplugin-blueping_git.bb b/recipes-opie/opie-securityplugins/opie-securityplugin-blueping_git.bb
index 37e661f..c8779d0 100644
--- a/recipes-opie/opie-securityplugins/opie-securityplugin-blueping_git.bb
+++ b/recipes-opie/opie-securityplugins/opie-securityplugin-blueping_git.bb
@@ -1,7 +1,7 @@
require opie-securityplugin-blueping.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/blueping \
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/blueping;name=first \
${OPIE_GIT};protocol=git;subpath=pics "
diff --git a/recipes-opie/opie-securityplugins/opie-securityplugin-dummy_git.bb b/recipes-opie/opie-securityplugins/opie-securityplugin-dummy_git.bb
index 0bb50d6..dd875c1 100644
--- a/recipes-opie/opie-securityplugins/opie-securityplugin-dummy_git.bb
+++ b/recipes-opie/opie-securityplugins/opie-securityplugin-dummy_git.bb
@@ -1,7 +1,7 @@
require opie-securityplugin-dummy.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/dummy \
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/dummy;name=first \
${OPIE_GIT};protocol=git;subpath=pics "
diff --git a/recipes-opie/opie-securityplugins/opie-securityplugin-notice_git.bb b/recipes-opie/opie-securityplugins/opie-securityplugin-notice_git.bb
index 93df53c..22f4e9b 100644
--- a/recipes-opie/opie-securityplugins/opie-securityplugin-notice_git.bb
+++ b/recipes-opie/opie-securityplugins/opie-securityplugin-notice_git.bb
@@ -1,7 +1,7 @@
require opie-securityplugin-notice.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/notice \
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/notice;name=first \
${OPIE_GIT};protocol=git;subpath=pics "
diff --git a/recipes-opie/opie-securityplugins/opie-securityplugin-pin_git.bb b/recipes-opie/opie-securityplugins/opie-securityplugin-pin_git.bb
index 4b6f7f8..b063af2 100644
--- a/recipes-opie/opie-securityplugins/opie-securityplugin-pin_git.bb
+++ b/recipes-opie/opie-securityplugins/opie-securityplugin-pin_git.bb
@@ -1,7 +1,7 @@
require opie-securityplugin-pin.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/pin \
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/securityplugins/pin;name=first \
${OPIE_GIT};protocol=git;subpath=pics "