aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-taskbar
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-taskbar
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-taskbar')
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images.inc75
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpgbin0 -> 16113 bytes
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpgbin0 -> 7807 bytes
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images_1.2.5.bb6
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar-images_cvs.bb5
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar.inc65
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/firstuse-path.patch11
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch20
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch35
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/no-builtin-qss-startup-2.patch11
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/nomax.patch30
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/restart-from-bindir.patch12
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch69
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb33
-rw-r--r--recipes-opie/opie-taskbar/opie-taskbar_cvs.bb20
15 files changed, 392 insertions, 0 deletions
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images.inc b/recipes-opie/opie-taskbar/opie-taskbar-images.inc
new file mode 100644
index 0000000..0286f48
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images.inc
@@ -0,0 +1,75 @@
+DESCRIPTION = "Opie Launcher and Taskbar"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "qpe"
+
+S = "${WORKDIR}/pics"
+
+inherit opie
+
+# Wallpaper and welcome splash
+PIXMAP_SIZE = ""
+PIXMAP_SIZE_c7x0 = "-640x480"
+PIXMAP_SIZE_spitz = "-640x480"
+PIXMAP_SIZE_akita = "-640x480"
+PIXMAP_SIZE_tosa = "-480x640"
+PIXMAP_SIZE_simpad = "-800x600"
+PIXMAP_SIZE_asus730 = "-480x640"
+PIXMAP_SIZE_htcuniversal= "-480x640"
+PIXMAP_SIZE_hx4700 = "-480x640"
+PIXMAP_SIZE_palmz31 = "-160x160"
+PIXMAP_SIZE_palmz71 = "-320x320"
+PIXMAP_SIZE_palmz72 = "-320x320"
+PIXMAP_SIZE_palmt650 = "-320x320"
+PIXMAP_SIZE_palmt680 = "-320x320"
+PIXMAP_SIZE_palmt3 = "-320x480"
+PIXMAP_SIZE_palmt5 = "-320x480"
+PIXMAP_SIZE_palmtx = "-320x480"
+PIXMAP_SIZE_palmld = "-320x480"
+
+do_configure() {
+ :
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/launcher
+
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse.jpg ${D}${palmtopdir}/pics/launcher/firstuse-240x320.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background.jpg ${D}${palmtopdir}/pics/launcher/opie-background-240x320.jpg
+
+# for res in 320x240 240x320 320x320 320x480 480x320 480x640 640x480 600x800 800x600; do
+ for res in 240x240 320x320 320x480 480x320 480x640 640x480 800x600; do
+ install -m 0644 ${WORKDIR}/pics/launcher/firstuse-${res}.jpg ${D}${palmtopdir}/pics/launcher/firstuse-${res}.jpg
+ install -m 0644 ${WORKDIR}/pics/launcher/opie-background-${res}.jpg ${D}${palmtopdir}/pics/launcher/opie-background-${res}.jpg
+ done
+}
+
+python do_package_prepend () {
+ reslist = ['240x320','320x240', '320x320', '320x480', '480x320', '480x640','640x480', '800x600','600x800']
+ dir = bb.data.expand('${palmtopdir}/pics/launcher/', d)
+ ft = bb.data.expand('${palmtopdir}/pics/*/*-%s.*', d)
+ pn = bb.data.getVar('PN', d, 1)
+ for res in reslist:
+ bb.data.setVar('FILES_%s-%s' % (pn,res), ft % res, d )
+ postinst = ''
+ postinst = 'update-alternatives --install %sfirstuse.jpg opie-firstuse-pixmap %sfirstuse-%s.jpg 50\n' % (dir,dir,res)
+ postinst += 'update-alternatives --install %sopie-background.jpg opie-background-pixmap %sopie-background-%s.jpg 50\n' % (dir,dir,res)
+ bb.data.setVar('pkg_postinst_%s-%s' % (pn,res),postinst, d)
+ prerm = ''
+ prerm = 'update-alternatives --remove opie-firstuse-pixmap %sfirstuse-%s.jpg 50\n' % (dir,res)
+ prerm += 'update-alternatives --remove opie-background-pixmap %sopie-background-%s.jpg 50\n' % (dir,res)
+ bb.data.setVar('pkg_prerm_%s-%s' % (pn,res),prerm, d)
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}-dbg ${PN}-320x480 ${PN}-480x320 ${PN}-480x640 ${PN}-640x480 ${PN}-800x600 ${PN}-600x800 ${PN}-320x240 ${PN}-240x320 ${PN}-320x320"
+RPROVIDES_${PN}-320x480 = "opie-taskbar-images"
+RPROVIDES_${PN}-480x320 = "opie-taskbar-images"
+RPROVIDES_${PN}-480x640 = "opie-taskbar-images"
+RPROVIDES_${PN}-640x480 = "opie-taskbar-images"
+RPROVIDES_${PN}-800x600 = "opie-taskbar-images"
+RPROVIDES_${PN}-600x800 = "opie-taskbar-images"
+RPROVIDES_${PN}-320x240 = "opie-taskbar-images"
+RPROVIDES_${PN}-240x320 = "opie-taskbar-images"
+RPROVIDES_${PN}-320x320 = "opie-taskbar-images"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg b/recipes-opie/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg
new file mode 100644
index 0000000..67523f1
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images/firstuse-320x320.jpg
Binary files differ
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg b/recipes-opie/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg
new file mode 100644
index 0000000..194816f
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images/opie-background-320x320.jpg
Binary files differ
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images_1.2.5.bb b/recipes-opie/opie-taskbar/opie-taskbar-images_1.2.5.bb
new file mode 100644
index 0000000..a64829f
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images_1.2.5.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PR = "r0"
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar-images_cvs.bb b/recipes-opie/opie-taskbar/opie-taskbar-images_cvs.bb
new file mode 100644
index 0000000..3a90e79
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar-images_cvs.bb
@@ -0,0 +1,5 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+PR = "r8"
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar.inc b/recipes-opie/opie-taskbar/opie-taskbar.inc
new file mode 100644
index 0000000..14a65b2
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar.inc
@@ -0,0 +1,65 @@
+DESCRIPTION = "Opie Launcher and Taskbar"
+SECTION = "opie/base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "opie-libqrsync opie-qss"
+# Unfortunately, ipkg has buggy handling of Rdepends to multiple packages with the same Provides.
+# Instead of seeing if something in package package lists selects needed package among the rest
+# or errors out otherwise, it just install random package which has needed Provides. So, comment
+# this out.
+#RDEPENDS_${PN} = "opie-taskbar-images"
+APPNAME = "qpe"
+
+S = "${WORKDIR}/launcher"
+
+inherit opie
+
+do_configure_prepend() {
+ ln -s ${WORKDIR}/calibrate ${S}/calibrate
+ ln -s ${WORKDIR}/mediummount ${S}/mediummount
+}
+
+SECTIONS = "1Pim Applications Examples Games Opie-SH Python Settings"
+PICS = "opielogo32x32.png start_button.png new_wait.png opielogo16x16.png sidebar.png"
+
+do_install() {
+ install -d ${D}${bindir}
+ for i in ${SECTIONS}
+ do
+ install -d ${D}${palmtopdir}/apps/$i/
+ install -m 0644 ${WORKDIR}/apps/$i/.directory ${D}${palmtopdir}/apps/$i/
+ done
+ install -d ${D}${palmtopdir}/pics/launcher
+ install -d ${D}${palmtopdir}/pics/logo
+ install -d ${D}${palmtopdir}/pics/RoH/star/
+ install -d ${D}${palmtopdir}/etc/colors
+ install -d ${D}${palmtopdir}/etc/skel
+ install -d ${D}${sysconfdir}
+
+ install -m 0755 ${S}/qpe ${D}${bindir}/qpe
+ install -m 0644 ${WORKDIR}/apps/Settings/calibrate.desktop ${D}${palmtopdir}/apps/Settings/
+ install -m 0644 ${WORKDIR}/apps/Settings/quit.desktop ${D}${palmtopdir}/apps/Settings/
+
+ for p in ${PICS}
+ do
+ install -m 0644 ${WORKDIR}/pics/launcher/$p ${D}${palmtopdir}/pics/launcher/$p
+ done
+
+ install -m 0644 ${WORKDIR}/pics/logo/*.* ${D}${palmtopdir}/pics/logo/
+ install -m 0644 ${WORKDIR}/pics/RoH/star/*.png ${D}${palmtopdir}/pics/RoH/star/
+
+ install -m 0644 ${WORKDIR}/etc/colors/*.scheme ${D}${palmtopdir}/etc/colors/
+ install -m 0644 ${WORKDIR}/etc/mime.types ${D}${sysconfdir}/
+
+ install -m 0644 ${WORKDIR}/pics/capslock.xpm ${D}${palmtopdir}/pics/
+ install -m 0644 ${WORKDIR}/pics/numlock.xpm ${D}${palmtopdir}/pics/
+
+ install -d ${D}${includedir}
+ install obexinterface.h ${D}${includedir}/
+
+ install -d ${D}${sysconfdir}/apm/event.d/
+ install -m 0755 ${WORKDIR}/etc/03opiesignal ${D}${sysconfdir}/apm/event.d/
+ install -m 0644 ${WORKDIR}/etc/opie_sysevents.conf ${D}${sysconfdir}/
+}
+
+FILES_opie-taskbar_append = " ${sysconfdir} ${palmtopdir}/apps ${palmtopdir}/pics"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/firstuse-path.patch b/recipes-opie/opie-taskbar/opie-taskbar/firstuse-path.patch
new file mode 100644
index 0000000..636eb81
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/firstuse-path.patch
@@ -0,0 +1,11 @@
+--- launcher/firstuse.cpp 2007-10-14 12:47:55.000000000 +1300
++++ launcher/firstuse.cpp 2007-10-14 13:58:54.000000000 +1300
+@@ -124,7 +124,7 @@
+ #endif
+
+ for ( int i = 0; settingsTable[i].app; i++ ) {
+- QString file = QPEApplication::qpeDir() + "bin/";
++ QString file = OPIE_BINDIR + QString("/");
+ file += settingsTable[i].app;
+ file += exeSuffix;
+ if ( QFile::exists(file) )
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch b/recipes-opie/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch
new file mode 100644
index 0000000..44d5d25
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/force-firstuse-calibrate.patch
@@ -0,0 +1,20 @@
+diff --git a/core/launcher/firstuse.cpp b/core/launcher/firstuse.cpp
+index 8c02ab0..cf731c2 100644
+--- launcher/firstuse.cpp
++++ launcher/firstuse.cpp
+@@ -175,10 +175,13 @@ FirstUse::FirstUse(QWidget* parent, const char * name, WFlags wf) :
+ m_calHandler = ( QWSServer::mouseHandler() && QWSServer::mouseHandler()->inherits("QCalibratedMouseHandler") ) ? true : false;
+
+ if ( m_calHandler) {
+- if ( !QFile::exists("/etc/pointercal") ) {
++ // Since Angstrom is installing default pointer calibration files
++ // that don't match everyone's devices, we need to force calibration
++ // on first use.
++// if ( !QFile::exists("/etc/pointercal") ) {
+ needCalibrate = TRUE;
+ grabMouse();
+- }
++// }
+ }
+
+ Config config("locale");
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch b/recipes-opie/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch
new file mode 100644
index 0000000..e356682
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/kbdlocks-runtime.patch
@@ -0,0 +1,35 @@
+--- launcher/taskbar.h.org 2004-08-23 00:35:22.000000000 +0300
++++ launcher/taskbar.h 2007-07-04 19:23:54.000000000 +0300
+@@ -84,6 +84,7 @@
+ LockKeyState* lockState;
+ StartMenu *sm;
+ bool resizeRunningApp;
++ bool showKbdLockState;
+ };
+
+
+--- launcher/taskbar.cpp.org 2005-07-04 01:13:00.000000000 +0300
++++ launcher/taskbar.cpp 2007-07-04 19:24:48.000000000 +0300
+@@ -213,12 +213,9 @@
+ (void)new SafeMode( this );
+ #endif
+
+- // ## make customizable in some way?
+-#ifdef OPIE_TASKBAR_LOCK_KEY_STATE
+- lockState = new LockKeyState( this );
+-#else
+ lockState = 0;
+-#endif
++ if ( showKbdLockState )
++ lockState = new LockKeyState( this );
+
+ #if defined(Q_WS_QWS)
+ #if !defined(QT_NO_COP)
+@@ -388,6 +385,7 @@
+ Config cfg( "Launcher" );
+ cfg.setGroup( "InputMethods" );
+ resizeRunningApp = cfg.readBoolEntry( "Resize", true );
++ showKbdLockState = cfg.readBoolEntry( "ShowKbdLocks", true );
+ }
+
+ #include "taskbar.moc"
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/no-builtin-qss-startup-2.patch b/recipes-opie/opie-taskbar/opie-taskbar/no-builtin-qss-startup-2.patch
new file mode 100644
index 0000000..65b54c9
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/no-builtin-qss-startup-2.patch
@@ -0,0 +1,11 @@
+--- launcher/server.cpp
++++ launcher/server.cpp
+@@ -1111,6 +1111,8 @@ void Server::finishedQueuedRequests()
+
+ void Server::startSoundServer()
+ {
++ owarn << "Sound server (qss) now needs to be started standalone" << oendl;
++ return;
+ if ( !process ) {
+ process = new Opie::Core::OProcess( this );
+ connect(process, SIGNAL(processExited(Opie::Core::OProcess*)),
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/nomax.patch b/recipes-opie/opie-taskbar/opie-taskbar/nomax.patch
new file mode 100644
index 0000000..468038b
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/nomax.patch
@@ -0,0 +1,30 @@
+--- opie-x86/core/launcher/server.cpp~nomax
++++ opie-x86/core/launcher/server.cpp
+@@ -76,7 +76,7 @@
+ return 0;
+ #endif
+ }
+-
++#ifndef OPIE_NO_WINDOWED
+ #define FACTORY(T) \
+ static QWidget *new##T( bool maximized ) { \
+ QWidget *w = new T( 0, 0, QWidget::WDestructiveClose | QWidget::WGroupLeader ); \
+@@ -90,7 +90,18 @@
+ w->show(); \
+ return w; \
+ }
++#else
++#define FACTORY(T) \
++ static QWidget *new##T( bool maximized ) { \
++ QWidget *w = new T( 0, 0, QWidget::WDestructiveClose | QWidget::WGroupLeader ); \
++ if ( maximized ) { \
++ w->showMaximized(); \
++} \
++ w->show(); \
++ return w; \
++}
+
++#endif
+
+ #ifdef SINGLE_APP
+ #define APP(a,b,c,d) FACTORY(b)
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/restart-from-bindir.patch b/recipes-opie/opie-taskbar/opie-taskbar/restart-from-bindir.patch
new file mode 100644
index 0000000..1a73588
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/restart-from-bindir.patch
@@ -0,0 +1,12 @@
+diff --git a/serverapp.cpp b/serverapp.cpp
+index 0e92040..b933340 100644
+--- a/serverapp.cpp
++++ b/serverapp.cpp
+@@ -763,6 +763,7 @@ void ServerApplication::restart()
+ for ( int fd = 3; fd < 100; fd++ )
+ close( fd );
+ execl( ( qpeDir() + "/bin/qpe" ).local8Bit(), "qpe", NULL );
++ execl( OPIE_BINDIR "/qpe", "qpe", NULL );
+ exit( 1 );
+ #endif
+ }
diff --git a/recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch
new file mode 100644
index 0000000..eb214da
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar/server-pro-cvs.patch
@@ -0,0 +1,69 @@
+--- launcher/server.pro
++++ launcher/server.pro
+@@ -2,7 +2,7 @@ TEMPLATE = app
+
+ CONFIG += qt warn_on
+
+-DESTDIR = $$(OPIEDIR)/bin
++DESTDIR =
+
+ HEADERS += server.h \
+ qrr.h \
+@@ -20,7 +20,7 @@ HEADERS += server.h \
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.h \
++ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+@@ -31,7 +31,7 @@ HEADERS += server.h \
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.h \
++ mediummount/mediumwidget.h \
+ mediadlg.h \
+ virtualfs.h \
+ syncaccessmanager.h
+@@ -52,7 +52,7 @@ SOURCES += server.cpp \
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.cpp \
++ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+@@ -65,22 +65,22 @@ SOURCES += server.cpp \
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.cc \
++ mediummount/mediumwidget.cc \
+ mediadlg.cpp \
+ virtualfs.cpp \
+ syncaccessmanager.cpp
+
+
+-INCLUDEPATH += $(OPIEDIR)/core/apps/calibrate
+-DEPENDPATH += $(OPIEDIR)/core/apps/calibrate
++INCLUDEPATH += calibrate
++DEPENDPATH += calibrate
+
+-INCLUDEPATH += $(OPIEDIR)/include $(OPIEDIR)/rsync
+-DEPENDPATH += $(OPIEDIR)/rsync
++INCLUDEPATH += $(OPIEDIR)/include rsync
++DEPENDPATH += rsync
+
+-INCLUDEPATH += $(OPIEDIR)/noncore/settings/mediummount
+-DEPENDPATH += $(OPIEDIR)/noncore/settings/mediummount
++INCLUDEPATH += mediummount
++DEPENDPATH += mediummount
+
+-LIBS += -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync -lsysfs
++LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync -lsysfs
+ TARGET = qpe
+
+ ## not ready for use yet
diff --git a/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb b/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb
new file mode 100644
index 0000000..ee01b35
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar_1.2.5.bb
@@ -0,0 +1,33 @@
+require ${PN}.inc
+PR = "r1"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_apps_calibrate.tar.bz2;name=split_core_apps_calibrate \
+ http://sources.openembedded.org/opie-1.2.5-split_noncore_settings_mediummount.tar.bz2;name=split_noncore_settings_mediummount \
+ http://sources.openembedded.org/opie-1.2.5-split_core_launcher.tar.bz2;name=split_core_launcher \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps \
+ http://sources.openembedded.org/opie-1.2.5-split_root.tar.bz2;name=split_root \
+ http://sources.openembedded.org/opie-1.2.5-split_etc.tar.bz2;name=split_etc \
+ file://nomax.patch;striplevel=3 \
+ file://no-builtin-qss-startup-2.patch \
+ file://kbdlocks-runtime.patch \
+ file://restart-from-bindir.patch \
+ file://server-pro-cvs.patch \
+ file://firstuse-path.patch \
+ file://force-firstuse-calibrate.patch \
+ "
+SRC_URI[split_core_apps_calibrate.md5sum] = "ee5e06b781e92f01271d883f91f101b0"
+SRC_URI[split_core_apps_calibrate.sha256sum] = "5e0164a195a166fd15451164edf8a44d8f3a9f81dcf3edc3a8975f24bd4b45b6"
+SRC_URI[split_noncore_settings_mediummount.md5sum] = "5309e48475c721a9cda3c9a1701789cd"
+SRC_URI[split_noncore_settings_mediummount.sha256sum] = "8554f74b00f5a3425a8a3d667eda5f0edd8f197bc33e78a59f3231eacd8c4f5c"
+SRC_URI[split_core_launcher.md5sum] = "cd3708a2d074f108d81ffea590995725"
+SRC_URI[split_core_launcher.sha256sum] = "fca1501398f1e4d0690455b145b17a68287de422592bca73c2afdf6762d021ce"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
+SRC_URI[split_root.md5sum] = "47b2ea2c59ac34b3df21d43c53baaccd"
+SRC_URI[split_root.sha256sum] = "0fb78622bb7ab459860aaa65fbea6145c45141195c1981164b40807b884628eb"
+SRC_URI[split_etc.md5sum] = "74ef523ef12e242155bbb745072434d9"
+SRC_URI[split_etc.sha256sum] = "eef55ea2248b4f45f3a07beb6012e431dd71d4eefa134d39cc50b4d194c53087"
+
diff --git a/recipes-opie/opie-taskbar/opie-taskbar_cvs.bb b/recipes-opie/opie-taskbar/opie-taskbar_cvs.bb
new file mode 100644
index 0000000..9036e72
--- /dev/null
+++ b/recipes-opie/opie-taskbar/opie-taskbar_cvs.bb
@@ -0,0 +1,20 @@
+require ${PN}.inc
+PV = "${OPIE_GIT_PV}"
+PR = "r22"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/apps/calibrate \
+ ${OPIE_GIT};protocol=git;subpath=noncore/settings/mediummount \
+ ${OPIE_GIT};protocol=git;subpath=core/launcher \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps \
+ ${OPIE_GIT};protocol=git;subpath=root \
+ ${OPIE_GIT};protocol=git;subpath=etc \
+ file://nomax.patch;striplevel=3 \
+ file://no-builtin-qss-startup-2.patch \
+ file://kbdlocks-runtime.patch \
+ file://restart-from-bindir.patch \
+ file://server-pro-cvs.patch \
+ file://firstuse-path.patch \
+ file://force-firstuse-calibrate.patch \
+ "
+