aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-theme
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-theme
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-theme')
-rw-r--r--recipes-opie/opie-theme/opie-theme.inc45
-rw-r--r--recipes-opie/opie-theme/opie-theme_1.2.5.bb9
-rw-r--r--recipes-opie/opie-theme/opie-theme_cvs.bb7
3 files changed, 61 insertions, 0 deletions
diff --git a/recipes-opie/opie-theme/opie-theme.inc b/recipes-opie/opie-theme/opie-theme.inc
new file mode 100644
index 0000000..0017154
--- /dev/null
+++ b/recipes-opie/opie-theme/opie-theme.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Themed style"
+SECTION = "opie/styles"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "theme"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/styles/libtheme.so*
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/
+ install -d ${D}${palmtopdir}/plugins/styles/themes/
+ for t in cleannsimple GradE8 ixpe luna
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ for f in ../styles/pixmaps/$t/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/$t/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+ for t in lumonmarble lumonwave
+ do
+ install -d ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ for f in ../styles/pixmaps/lumon/*
+ do
+ [ -f $f ] && install -m 0644 $f ${D}${palmtopdir}/plugins/styles/pixmaps/lumon/
+ done
+ install -m 0644 ../styles/themes/$t.themerc ${D}${palmtopdir}/plugins/styles/themes/
+ done
+}
+
+PACKAGES += " opie-theme-cleannsimple opie-theme-grade8 opie-theme-ixpe opie-theme-lumonmarble \
+ opie-theme-lumonwave opie-theme-luna "
+
+FILES_opie-theme = " ${palmtopdir}/plugins/styles/libtheme.so*"
+FILES_opie-theme-cleannsimple = " ${palmtopdir}/plugins/styles/themes/cleannsimple.themerc ${palmtopdir}/plugins/styles/pixmaps/cleannsimple/*.png"
+FILES_opie-theme-grade8 = " ${palmtopdir}/plugins/styles/themes/GradE8.themerc ${palmtopdir}/plugins/styles/pixmaps/GradE8/*.png"
+FILES_opie-theme-ixpe = " ${palmtopdir}/plugins/styles/themes/ixpe.themerc ${palmtopdir}/plugins/styles/pixmaps/ixpe/*.png"
+FILES_opie-theme-lumonmarble = " ${palmtopdir}/plugins/styles/themes/lumonmarble.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwhitemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundbluemarble.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-lumonwave = " ${palmtopdir}/plugins/styles/themes/lumonwave.themerc ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/arrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwave.png ${palmtopdir}/plugins/styles/pixmaps/lumon/backgroundwaveblue.png ${palmtopdir}/plugins/styles/pixmaps/lumon/button.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborder.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttonborderdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/buttondown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkbox.png ${palmtopdir}/plugins/styles/pixmaps/lumon/checkboxdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/hscrollgroove.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menubar.png ${palmtopdir}/plugins/styles/pixmaps/lumon/menuitemdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radio.png ${palmtopdir}/plugins/styles/pixmaps/lumon/radiodown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/scrollbutton.png ${palmtopdir}/plugins/styles/pixmaps/lumon/splitter.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowleft.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowright.png ${palmtopdir}/plugins/styles/pixmaps/lumon/sunkenarrowup.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tab.png ${palmtopdir}/plugins/styles/pixmaps/lumon/tabdown.png ${palmtopdir}/plugins/styles/pixmaps/lumon/vscrollgroove.png"
+FILES_opie-theme-luna = " ${palmtopdir}/plugins/styles/themes/luna.themerc ${palmtopdir}/plugins/styles/pixmaps/luna/*.png"
diff --git a/recipes-opie/opie-theme/opie-theme_1.2.5.bb b/recipes-opie/opie-theme/opie-theme_1.2.5.bb
new file mode 100644
index 0000000..d7707d6
--- /dev/null
+++ b/recipes-opie/opie-theme/opie-theme_1.2.5.bb
@@ -0,0 +1,9 @@
+require ${PN}.inc
+PR = "r0"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_styles_theme.tar.bz2;name=split_noncore_styles_theme \
+ http://sources.openembedded.org/opie-1.2.5-split_plugins_styles.tar.bz2;name=split_plugins_styles"
+SRC_URI[split_noncore_styles_theme.md5sum] = "c20ee13eb4ab10fe9b8ca1750e112cd9"
+SRC_URI[split_noncore_styles_theme.sha256sum] = "a5c478b7001938a5a1250c0a05d56b8cf673df9a2b75726b5ce27264c1170d2d"
+SRC_URI[split_plugins_styles.md5sum] = "4d09f3be9e8b904412d368763d974d50"
+SRC_URI[split_plugins_styles.sha256sum] = "cecf5695ea1297f899efba863af5e8de6156181ff56e1b4a68fef8289e247446"
diff --git a/recipes-opie/opie-theme/opie-theme_cvs.bb b/recipes-opie/opie-theme/opie-theme_cvs.bb
new file mode 100644
index 0000000..c3a1161
--- /dev/null
+++ b/recipes-opie/opie-theme/opie-theme_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+PR = "r1"
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/styles/theme \
+ ${OPIE_GIT};protocol=git;subpath=plugins/styles "