aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-today-stocktickerplugin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-today-stocktickerplugin
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-today-stocktickerplugin')
-rw-r--r--recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin.inc18
-rw-r--r--recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_1.2.5.bb11
-rw-r--r--recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_cvs.bb7
3 files changed, 36 insertions, 0 deletions
diff --git a/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin.inc b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin.inc
new file mode 100644
index 0000000..7fb97e1
--- /dev/null
+++ b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Stock ticker plugin for Today"
+SECTION = "opie/today"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "opie-today libqtaux2"
+APPNAME = "todaystocktickerplugin"
+
+
+S = "${WORKDIR}/stockticker"
+
+inherit opie
+
+# FILES plugins/today/libtodaystocktickerplugin.so* bin/stockticker pics/stockticker/stockticker.png
+do_install() {
+ install -d ${D}${palmtopdir}/pics/stockticker/
+ install -m 0644 ${WORKDIR}/pics/stockticker/*.png ${D}${palmtopdir}/pics/stockticker/
+}
+
diff --git a/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_1.2.5.bb b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_1.2.5.bb
new file mode 100644
index 0000000..f47ad88
--- /dev/null
+++ b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_todayplugins_stockticker.tar.bz2;name=split_noncore_todayplugins_stockticker \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_noncore_todayplugins_stockticker.md5sum] = "6cb8c961f51572bc9c39476e4e78b992"
+SRC_URI[split_noncore_todayplugins_stockticker.sha256sum] = "77a65b971e560b46aedd0575439a27c407b905207d17a6832aea83a6d2404dce"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_cvs.bb b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_cvs.bb
new file mode 100644
index 0000000..2fc4d9f
--- /dev/null
+++ b/recipes-opie/opie-today-stocktickerplugin/opie-today-stocktickerplugin_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/todayplugins/stockticker \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"