aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-today-weatherplugin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-today-weatherplugin
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-today-weatherplugin')
-rw-r--r--recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin.inc19
-rw-r--r--recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_1.2.5.bb8
-rw-r--r--recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_cvs.bb6
3 files changed, 33 insertions, 0 deletions
diff --git a/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin.inc b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin.inc
new file mode 100644
index 0000000..b7718e2
--- /dev/null
+++ b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Weather plugin for Today"
+SECTION = "opie/today"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libopiecore2 libopiepim2"
+RDEPENDS_${PN} = "opie-today"
+APPNAME = "todayweatherplugin"
+
+
+S = "${WORKDIR}/weather"
+
+inherit opie
+
+# FILES plugins/today/libtodayweatherplugin.so* pics/todayweatherplugin
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_1.2.5.bb b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_1.2.5.bb
new file mode 100644
index 0000000..61c6010
--- /dev/null
+++ b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_1.2.5.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_todayplugins_weather.tar.bz2;name=split_noncore_todayplugins_weather \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics"
+SRC_URI[split_noncore_todayplugins_weather.md5sum] = "4900e1091a1473ef6d8b722ff1cbfb6a"
+SRC_URI[split_noncore_todayplugins_weather.sha256sum] = "990e2ef1ae38ca427abc4c466840ce183c637cb90587f971767b781be5dfebc4"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
diff --git a/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_cvs.bb b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_cvs.bb
new file mode 100644
index 0000000..64630c8
--- /dev/null
+++ b/recipes-opie/opie-today-weatherplugin/opie-today-weatherplugin_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/todayplugins/weather \
+ ${OPIE_GIT};protocol=git;subpath=pics"