aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/tasks/task-opie-connman.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 01:01:34 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 01:04:06 +0000
commit9ff08ca516195c498a0e7f8f6ca84d93195c770d (patch)
tree0cbfa430e1fc1e2b40aa48eae31b21238fdccc56 /recipes-opie/tasks/task-opie-connman.bb
parent458c6002e029c5f72355414504c3109f38e34d48 (diff)
downloadmeta-opie-9ff08ca516195c498a0e7f8f6ca84d93195c770d.tar.gz
task-opie-connman: minor fixesconnman
* Rename to task-opie-connman * Make connman plugins RRECOMMENDS instead of RDEPENDS * Add the task recipe to opie-image-connman DEPENDS Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/tasks/task-opie-connman.bb')
-rw-r--r--recipes-opie/tasks/task-opie-connman.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes-opie/tasks/task-opie-connman.bb b/recipes-opie/tasks/task-opie-connman.bb
new file mode 100644
index 0000000..e46dc74
--- /dev/null
+++ b/recipes-opie/tasks/task-opie-connman.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Tasks for Opie ConnMan settings"
+LICENSE = "MIT"
+
+PR = "r0"
+
+inherit task
+
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+RDEPENDS_${PN} = "opie-connmansettings opie-connmanapplet"
+
+RRECOMMENDS_${PN} = "connman-plugin-ethernet \
+ ${@base_contains('DISTRO_FEATURES', 'wifi', 'connman-plugin-wifi', '',d)} \
+ ${@base_contains('DISTRO_FEATURES', 'bluetooth', 'connman-plugin-bluetooth', '',d)} \
+ "
+