aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-16 18:54:47 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-16 18:57:04 +0100
commit82cf86be7fd0218c56f181b080e4109c896875ea (patch)
tree32e5bfc10ad6844bc75e19b5f670ea3b97d37194 /recipes-opie
parent0f322a26656190b1d7b9b275eb02293b52208079 (diff)
downloadmeta-opie-82cf86be7fd0218c56f181b080e4109c896875ea.tar.gz
opie-image: inherit from core-image instead of image
Simplifies the image recipe and allows use of base IMAGE_FEATURES. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie')
-rw-r--r--recipes-opie/images/opie-image.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/recipes-opie/images/opie-image.bb b/recipes-opie/images/opie-image.bb
index f7f3e21..dd654c1 100644
--- a/recipes-opie/images/opie-image.bb
+++ b/recipes-opie/images/opie-image.bb
@@ -4,8 +4,10 @@ IMAGE_LINGUAS = ""
DEPENDS = "task-base task-opie"
+IMAGE_FEATURES = "ssh-server-dropbear"
+
ANGSTROM_EXTRA_INSTALL ?= ""
-IMAGE_INSTALL = "task-base-extended task-opie-base task-opie-base-applets \
+IMAGE_INSTALL = "task-core-boot ${ROOTFS_PKGMANAGE} task-opie-base task-opie-base-applets \
task-opie-base-inputmethods task-opie-base-apps \
task-opie-base-settings task-opie-base-decorations \
task-opie-base-styles task-opie-base-pim \
@@ -14,8 +16,5 @@ IMAGE_INSTALL = "task-base-extended task-opie-base task-opie-base-applets \
${@base_contains("COMBINED_FEATURES", "irda", "task-opie-irda", "",d)} \
${ANGSTROM_EXTRA_INSTALL} "
-inherit image
-
-# Create /etc/timestamp during image construction to give a reasonably sane default time setting
-ROOTFS_POSTPROCESS_COMMAND += "rootfs_update_timestamp ; "
+inherit core-image