aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb')
-rw-r--r--recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb b/recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb
new file mode 100644
index 0000000..bb4995a
--- /dev/null
+++ b/recipes-qtopia/camera-assistant/camera-assistant_0.2.0.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Camera Assistant aims to be an allround calculator for photographers & Cinematographers. \
+It currently has the following features: \
+ \
+ * Depth of field calculator. \
+ * Inverse Depth of field calculator. (Calculate what aperture you need for a given depth/distance & lens) \
+ * Field of view calculator. \
+ * Variants of the above, calculate distance to object or lens for a given field of view. \
+ * Database of TV cameras, Motion picture cameras and Still photography cameras."
+SECTION = "opie/applications"
+
+
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "zaurus@bredband.net"
+HOMEPAGE = "http://cameraassistant.sourceforge.net/"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cameraassistant/camera-assistant_0.2.0.tar.gz \
+ file://g++-3.4-compile-fixes.patch \
+ file://ca.desktop \
+ file://ca.png "
+
+
+S = "${WORKDIR}/CameraAssistant"
+
+APPNAME = "ca"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/ca.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
+
+inherit opie
+
+
+SRC_URI[md5sum] = "538e8d4691062524c4181da487d83250"
+SRC_URI[sha256sum] = "9caa3e654af03e55582dd515bfcc9bf5aa93c9d22842af16a87a9a226ec581ed"