aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/cumulus
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/cumulus
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/cumulus')
-rw-r--r--recipes-qtopia/cumulus/cumulus/open_max.patch11
-rw-r--r--recipes-qtopia/cumulus/cumulus_1.2.1.bb46
-rw-r--r--recipes-qtopia/cumulus/cumulus_cvs.bb47
3 files changed, 104 insertions, 0 deletions
diff --git a/recipes-qtopia/cumulus/cumulus/open_max.patch b/recipes-qtopia/cumulus/cumulus/open_max.patch
new file mode 100644
index 0000000..0a7cfcc
--- /dev/null
+++ b/recipes-qtopia/cumulus/cumulus/open_max.patch
@@ -0,0 +1,11 @@
+--- cumulus/gpscon.cpp.old 2008-11-18 23:39:12.000000000 +0000
++++ cumulus/gpscon.cpp 2008-11-18 23:43:32.000000000 +0000
+@@ -416,7 +416,7 @@
+
+ if( maxOpenFds == -1 ) // call failed
+ {
+- maxOpenFds = OPEN_MAX; // normal default from limits.h
++ maxOpenFds = sysconf(_SC_OPEN_MAX);
+ }
+ else
+ {
diff --git a/recipes-qtopia/cumulus/cumulus_1.2.1.bb b/recipes-qtopia/cumulus/cumulus_1.2.1.bb
new file mode 100644
index 0000000..e636a7f
--- /dev/null
+++ b/recipes-qtopia/cumulus/cumulus_1.2.1.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "cumulus"
+APPDESKTOP = "${S}"
+PR = "r1"
+
+SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_downloads/${PV}/cumulus-${PV}.src.tar.bz2 \
+ file://open_max.patch"
+S = "${WORKDIR}/cumulus_${PV}/cumulus"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=-I."
+
+#
+# nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
+#
+do_compile() {
+ echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
+ oe_runmake
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/mapicons \
+ ${D}${palmtopdir}/pics/mapicons/small \
+ ${D}${palmtopdir}/pics/mapicons/windarrows \
+ ${D}${palmtopdir}/bin
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
+ install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/mapicons
+ install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/mapicons/small
+ install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/mapicons/windarrows
+
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
+}
+
+SRC_URI[md5sum] = "a13e49376594c51fbfa74067f8d14d45"
+SRC_URI[sha256sum] = "e3ed263ee98971674f3f3cf55e42b7f2e79755b0f931f8a105676108185e8010"
diff --git a/recipes-qtopia/cumulus/cumulus_cvs.bb b/recipes-qtopia/cumulus/cumulus_cvs.bb
new file mode 100644
index 0000000..36c8bff
--- /dev/null
+++ b/recipes-qtopia/cumulus/cumulus_cvs.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "cumulus"
+APPDESKTOP = "${S}"
+PV = "${OPIE_CVS_PV}"
+PR = "r0"
+
+SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_snapshots/cumulus-snapshot.tbz"
+S = "${WORKDIR}/cumulus/cumulus"
+
+inherit opie
+
+DEFAULT_PREFERENCE = "-1"
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=-I."
+
+#
+# nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
+#
+do_compile() {
+ echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
+ oe_runmake
+ qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/cumulus \
+ ${D}${palmtopdir}/pics/cumulus/small \
+ ${D}${palmtopdir}/pics/cumulus/windarrows
+ install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus/cumulus.png
+ install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/cumulus
+ install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/cumulus
+ install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/cumulus/small
+ install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/cumulus/small
+ install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/cumulus/windarrows
+
+ install -m 0755 gpsClient ${D}${palmtopdir}/bin/
+}
+
+SRC_URI[md5sum] = "c5b0ca7f2164e47ef72889baf23690f6"
+SRC_URI[sha256sum] = "e862f8327a3ba42c7bc756fe846764754b3dab76d8ccbedd5a195b582070b791"