aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/kaffe
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/kaffe
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/kaffe')
-rw-r--r--recipes-qtopia/kaffe/kaffe-qt_cvs.bb24
-rw-r--r--recipes-qtopia/kaffe/kaffe.inc86
2 files changed, 110 insertions, 0 deletions
diff --git a/recipes-qtopia/kaffe/kaffe-qt_cvs.bb b/recipes-qtopia/kaffe/kaffe-qt_cvs.bb
new file mode 100644
index 0000000..37085e6
--- /dev/null
+++ b/recipes-qtopia/kaffe/kaffe-qt_cvs.bb
@@ -0,0 +1,24 @@
+BROKEN = "1"
+
+SRCDATE = "20060814"
+PV = "1.1.4+cvs${SRCDATE}"
+SRC_URI = "cvs://readonly:readonly@cvs.kaffe.org/cvs/kaffe;module=kaffe"
+S = "${WORKDIR}/kaffe"
+
+require kaffe.inc
+
+DEPENDS += "libqpe-opie"
+
+CXXFLAGS += " -DQPE "
+EXTRA_OEMAKE += "MOC=${STAGING_BINDIR_NATIVE}/moc"
+EXTRA_OECONF += " --with-qtdir=$QTDIR \
+ --with-awt=qt \
+ --enable-pure-java-math \
+ --without-x \
+ --without-classpath-gtk-awt \
+ --without-kaffe-x-awt \
+ --with-kaffe-qt-awt"
+
+do_configure_prepend() {
+ rm -f m4/libtool.m4
+}
diff --git a/recipes-qtopia/kaffe/kaffe.inc b/recipes-qtopia/kaffe/kaffe.inc
new file mode 100644
index 0000000..d0997de
--- /dev/null
+++ b/recipes-qtopia/kaffe/kaffe.inc
@@ -0,0 +1,86 @@
+DESCRIPTION = "Kaffe is a clean room implementation of the Java Virtual Machine"
+HOMEPAGE = "http://www.kaffe.org/"
+LICENSE = "GPL LGPL W3C Classpath BSD"
+
+DEPENDS = "virtual/javac-native fastjar-native libffi zip-native libart-lgpl"
+RDEPENDS_${PN} = "${PN}-common (>= ${PV})"
+
+SRC_URI += "file://disable-automake-checks.patch"
+
+inherit autotools gettext
+
+EXTRA_OECONF = "--with-engine=intrp \
+ --with-libffi \
+ --with-threads=unix-pthreads \
+ --disable-alsatest \
+ --disable-esdtest \
+ --disable-sound \
+ --with-jikes"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+# kaffe installs to non-standard locations. apply a similar workaround to
+# the one used in debian. i.e. override prefix
+oe_runconf () {
+ if [ -x ${S}/configure ] ; then
+ cfgcmd="${S}/configure \
+ --build=${BUILD_SYS} \
+ --host=${HOST_SYS} \
+ --target=${TARGET_SYS} \
+ --prefix=${libdir}/${PN} \
+ --datadir=${datadir} \
+ --sysconfdir=${sysconfdir} \
+ --sharedstatedir=${sharedstatedir}/${PN} \
+ --includedir=${includedir} \
+ --oldincludedir=${oldincludedir} \
+ --infodir=${infodir} \
+ --mandir=${mandir} \
+ ${EXTRA_OECONF} \
+ $@"
+ oenote "Running $cfgcmd..."
+ $cfgcmd || oefatal "oe_runconf failed"
+ else
+ oefatal "no configure script found"
+ fi
+}
+
+do_install () {
+ autotools_do_install
+
+ # move partially duplicate stuff to a single location
+ mv -f ${D}${libdir}/${PN}/bin/* ${D}${libdir}/${PN}/jre/bin
+ rmdir ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN} && ln -s jre/bin
+}
+
+# use update-alternatives for the various wrapper scripts
+alternative_names = "appletviewer \
+install-jar \
+jar \
+java \
+javac \
+javadoc \
+javah \
+javap \
+kaffe \
+kaffeh \
+native2ascii \
+rmic \
+rmiregistry \
+serialver"
+
+pkg_postinst_${PN} () {
+ for name in ${alternative_names}; do
+ update-alternatives --install ${bindir}/$name $name ${libdir}/${PN}/jre/bin/$name 300
+ done
+}
+
+pkg_postrm_${PN} () {
+ for name in ${alternative_names}; do
+ update-alternatives --remove $name ${libdir}/${PN}/jre/bin/$name
+ done
+}
+
+PACKAGES =+ "${PN}-common"
+FILES_${PN} += "${libdir}/${PN}"
+FILES_${PN}-common = "${libdir}/${PN}/jre/lib/*.jar"