aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/knights
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/knights
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/knights')
-rw-r--r--recipes-qtopia/knights/knights-1.14/gcc3.patch16
-rw-r--r--recipes-qtopia/knights/knights-1.14/libqpe-opie.patch26
-rw-r--r--recipes-qtopia/knights/knights_1.14.bb34
3 files changed, 76 insertions, 0 deletions
diff --git a/recipes-qtopia/knights/knights-1.14/gcc3.patch b/recipes-qtopia/knights/knights-1.14/gcc3.patch
new file mode 100644
index 0000000..be6a065
--- /dev/null
+++ b/recipes-qtopia/knights/knights-1.14/gcc3.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- knights/knights/knights.cpp~gcc3 2002-09-01 14:06:29.000000000 +0200
++++ knights/knights/knights.cpp 2004-01-16 00:30:04.000000000 +0100
+@@ -24,7 +24,7 @@
+ #include <qpe/qpeapplication.h>
+ #include <qpe/applnk.h>
+ #include "aboutdialog.h"
+-Knights::Knights(QWidget *parent, const char *name, const QString &args="") : QMainWindow(parent, name)
++Knights::Knights(QWidget *parent, const char *name, const QString &args) : QMainWindow(parent, name)
+ {
+ setCaption("Knights");
+ InitAll = TRUE;
diff --git a/recipes-qtopia/knights/knights-1.14/libqpe-opie.patch b/recipes-qtopia/knights/knights-1.14/libqpe-opie.patch
new file mode 100644
index 0000000..ca47227
--- /dev/null
+++ b/recipes-qtopia/knights/knights-1.14/libqpe-opie.patch
@@ -0,0 +1,26 @@
+--- knights/knights/core.cpp~knights-opie 2002-09-01 12:02:49.000000000 +0200
++++ knights/knights/core.cpp 2003-06-24 14:38:11.000000000 +0200
+@@ -24,9 +24,8 @@
+ #include <qmessagebox.h>
+ #include <qpe/fileselector.h>
+ #include "core.h"
+-#include "qinputdialog.h"
++#include <qtcompat/qinputdialog.h>
+ #include <unistd.h>
+-#include "qinputdialog.h"
+
+ ///////////////////////////////////////
+ //
+@@ -864,9 +863,9 @@
+ if (fileSelectorDialog->exec()==QDialog::Accepted)
+ {
+
+- const DocLnk *d = selector->selected();
+- load(*d);
+- delete d;
++ // const DocLnk *d = selector->selected();
++ // load(*d);
++ // delete d;
+ }
+ delete fileSelectorDialog;
+
diff --git a/recipes-qtopia/knights/knights_1.14.bb b/recipes-qtopia/knights/knights_1.14.bb
new file mode 100644
index 0000000..f1589f8
--- /dev/null
+++ b/recipes-qtopia/knights/knights_1.14.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Chess Game for Qt/Embedded based palmtop environments. \
+Uses the Phalanx chess engine."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "phalanx"
+RDEPENDS_${PN} = "phalanx"
+PR = "r3"
+
+SRC_URI = "http://www.openzaurus.org/mirror/knights.tar.gz \
+ file://libqpe-opie.patch \
+ file://gcc3.patch"
+S = "${WORKDIR}/knights"
+
+inherit palmtop
+
+QMAKE_PROFILES = "knights.pro"
+
+do_configure_prepend() {
+ printf "TEMPLATE=subdirs\nSUBDIRS=qtcompat microkde knights\n" >knights.pro
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/pics
+ install -D -m 755 knights/knights ${D}${palmtopdir}/bin/knights
+ install -D -m 644 knights.desktop ${D}${palmtopdir}/apps/Games/knights.desktop
+ install -d ${D}${palmtopdir}/pics
+ cp -pPR pics/knights ${D}${palmtopdir}/pics/
+}
+
+SRC_URI[md5sum] = "fea3047d5501a1abea868bb661cbc0c8"
+SRC_URI[sha256sum] = "1f6d50b3602f01b852810ab1e62f3328edee5130fe3ba21fd868f376c89e66fd"