aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/kstars
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/kstars
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/kstars')
-rw-r--r--recipes-qtopia/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch34
-rw-r--r--recipes-qtopia/kstars/kstars-embedded_0.8.5.bb29
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-qtopia/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch b/recipes-qtopia/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch
new file mode 100644
index 0000000..4004ede
--- /dev/null
+++ b/recipes-qtopia/kstars/kstars-embedded-0.8.5/gcc45-compilation-fixes.patch
@@ -0,0 +1,34 @@
+Index: kstars/kstars.cpp
+===================================================================
+--- kstars.orig/kstars.cpp
++++ kstars/kstars.cpp
+@@ -37,9 +37,9 @@
+ #include <qpe/mimetype.h>
+ #include <qpe/applnk.h>
+
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <stream.h>
++#include <cstdio>
++#include <cstdlib>
++#include <iostream>
+
+ #include "timedialog.h"
+ #include "locationdialog.h"
+Index: kstars/skymap.cpp
+===================================================================
+--- kstars.orig/skymap.cpp
++++ kstars/skymap.cpp
+@@ -36,9 +36,9 @@
+ #include <qpe/mimetype.h>
+ #include <qpe/applnk.h>
+
+-#include <math.h>
+-#include <stdlib.h>
+-#include <stream.h>
++#include <cmath>
++#include <cstdlib>
++#include <iostream>
+ #include <unistd.h>
+
+ #include "kstars.h"
diff --git a/recipes-qtopia/kstars/kstars-embedded_0.8.5.bb b/recipes-qtopia/kstars/kstars-embedded_0.8.5.bb
new file mode 100644
index 0000000..a792972
--- /dev/null
+++ b/recipes-qtopia/kstars/kstars-embedded_0.8.5.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "KDE Stars: The Universe, in your hands! QtE based Palmtop Environments Edition"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "kstars"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}/apps/Applications"
+PR = "r2"
+
+SRC_URI = "http://kstars.sourceforge.net/kstars-embedded-${PV}.tar.gz \
+ file://gcc45-compilation-fixes.patch \
+ "
+S = "${WORKDIR}/kstars"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST += 'DEFINES+=I18N_NOOP='
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics/kstars \
+ ${D}${palmtopdir}/share/apps/kstars
+ cp -pPR ${WORKDIR}/pics ${D}${palmtopdir}
+ cp -pPR ${WORKDIR}/share/apps/kstars ${D}${palmtopdir}/share/apps/
+}
+
+SRC_URI[md5sum] = "ae02647516a4a5c47674316ef8343c11"
+SRC_URI[sha256sum] = "650f0b3ae4d30282b191e456ebf2679a4ec549da83f69667bd4396bad9abf9f5"