aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/pocketcellar
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/pocketcellar
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/pocketcellar')
-rw-r--r--recipes-qtopia/pocketcellar/pocketcellar-1.1/cellardb.patch88
-rw-r--r--recipes-qtopia/pocketcellar/pocketcellar-1.1/gcc3.patch16
-rw-r--r--recipes-qtopia/pocketcellar/pocketcellar-1.1/pocketcellar.patch14
-rw-r--r--recipes-qtopia/pocketcellar/pocketcellar-1.1/winedb.patch92
-rw-r--r--recipes-qtopia/pocketcellar/pocketcellar_1.1.bb35
5 files changed, 245 insertions, 0 deletions
diff --git a/recipes-qtopia/pocketcellar/pocketcellar-1.1/cellardb.patch b/recipes-qtopia/pocketcellar/pocketcellar-1.1/cellardb.patch
new file mode 100644
index 0000000..ff55044
--- /dev/null
+++ b/recipes-qtopia/pocketcellar/pocketcellar-1.1/cellardb.patch
@@ -0,0 +1,88 @@
+#
+#Try to remove hardcoded /home path
+#
+--- pocketcellar-1.1/cellardb.cpp.old 2005-02-28 13:43:19.000000000 +0000
++++ pocketcellar-1.1/cellardb.cpp 2005-02-28 13:42:55.000000000 +0000
+@@ -19,6 +19,7 @@
+
+ #include "cellardb.h"
+ #include <qfile.h>
++#include <qdir.h>
+ #include <qdatastream.h>
+ #include "winedb.h"
+
+@@ -55,16 +56,16 @@
+
+
+ bool CellarDB::load(QListView *parent, QListView *wines, int loc) {
+- QString path("/home");
+-
++ QString path(QDir::homeDirPath());
++
+ if (loc == 1)
+- path = "/usr/mnt.rom/cf";
++ path = "/media/cf";
+ else if (loc == 2)
+- path = "/usr/mnt.rom/card";
++ path = "/media/card";
+
+- mkdir(QString(path + "/QtPalmtop/data/PocketCellar").ascii(), 755);
++ mkdir(QString(path + "/Documents/application/PocketCellar").ascii(), 755);
+
+- QFile f(path+"/QtPalmtop/data/PocketCellar/PCellarDB");
++ QFile f(path+"/Documents/application/PocketCellar/PCellarDB");
+
+ if (!f.open(IO_ReadOnly))
+ return false;
+@@ -102,28 +103,28 @@
+
+ f.close();
+
+- if (loc != 0)
++/* if (loc != 0)
+ unlink("/home/QtPalmtop/data/PocketCellar/PCellarDB");
+ if (loc != 1)
+ unlink("/usr/mnt.rom/cf/QtPalmtop/data/PocketCellar/PCellarDB");
+ if (loc != 2)
+- unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCellarDB");
++ unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCellarDB");*/
+
+ return true;
+ }
+
+
+ bool CellarDB::save(QListView *parent, int loc) {
+- QString path("/home");
+-
++ QString path(QDir::homeDirPath());
++
+ if (loc == 1)
+- path = "/usr/mnt.rom/cf";
++ path = "/media/cf";
+ else if (loc == 2)
+- path = "/usr/mnt.rom/card";
++ path = "/media/card";
+
+- mkdir(QString(path + "/QtPalmtop/data/PocketCellar").ascii(), 755);
++ mkdir(QString(path + "/Documents/application/PocketCellar").ascii(), 755);
+
+- QFile f(path+"/QtPalmtop/data/PocketCellar/PCellarDB");
++ QFile f(path+"/Documents/application/PocketCellar/PCellarDB");
+
+ //qDebug("Filename %s\n", (path+"/QtPalmtop/data/PocketCellar/PCellarDB").latin1());
+ if (!f.open(IO_WriteOnly))
+@@ -143,12 +144,12 @@
+
+ f.close();
+
+- if (loc != 0)
++/* if (loc != 0)
+ unlink("/home/QtPalmtop/data/PocketCellar/PCellarDB");
+ if (loc != 1)
+ unlink("/usr/mnt.rom/cf/QtPalmtop/data/PocketCellar/PCellarDB");
+ if (loc != 2)
+- unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCellarDB");
++ unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCellarDB");*/
+
+ return true;
+ }
diff --git a/recipes-qtopia/pocketcellar/pocketcellar-1.1/gcc3.patch b/recipes-qtopia/pocketcellar/pocketcellar-1.1/gcc3.patch
new file mode 100644
index 0000000..634944a
--- /dev/null
+++ b/recipes-qtopia/pocketcellar/pocketcellar-1.1/gcc3.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- pocketcellar-1.1/wineentry.cpp~gcc3 2002-11-15 02:06:44.000000000 +0100
++++ pocketcellar-1.1/wineentry.cpp 2004-02-11 14:27:26.000000000 +0100
+@@ -35,7 +35,7 @@
+ #include "winedb.h"
+
+
+-WineEditor::WineEditor(QWidget* parent = 0, const char* name = 0, bool modal = FALSE, WFlags fl = 0)
++WineEditor::WineEditor(QWidget* parent, const char* name, bool modal, WFlags fl)
+ : WineEditorBase(parent, name, modal, fl), _databaseList(0)
+ {
+ }
diff --git a/recipes-qtopia/pocketcellar/pocketcellar-1.1/pocketcellar.patch b/recipes-qtopia/pocketcellar/pocketcellar-1.1/pocketcellar.patch
new file mode 100644
index 0000000..a34f9d1
--- /dev/null
+++ b/recipes-qtopia/pocketcellar/pocketcellar-1.1/pocketcellar.patch
@@ -0,0 +1,14 @@
+--- pocketcellar-1.1/pocketcellar.cpp.old
++++ pocketcellar-1.1/pocketcellar.cpp
+@@ -395,9 +395,9 @@
+ _wines->setText(QString::number(stats._wines));
+ _bottles->setText(QString::number(stats._bottles));
+ QString tmp;
+- tmp.sprintf(tr("$%.2f"), stats._totalPrice);
++ tmp.sprintf(tr("%.2f"), stats._totalPrice);
+ _value->setText(tmp);
+- tmp.sprintf(tr("$%.2f ... $%.2f, avg $%.2f"),
++ tmp.sprintf(tr("%.2f ... %.2f, avg %.2f"),
+ stats._minPrice <= stats._maxPrice ?
+ stats._minPrice : 0.0,
+ stats._maxPrice, stats._bottles > 0 ?
diff --git a/recipes-qtopia/pocketcellar/pocketcellar-1.1/winedb.patch b/recipes-qtopia/pocketcellar/pocketcellar-1.1/winedb.patch
new file mode 100644
index 0000000..885a23a
--- /dev/null
+++ b/recipes-qtopia/pocketcellar/pocketcellar-1.1/winedb.patch
@@ -0,0 +1,92 @@
+#
+# Try to remove hardcoded /home path
+#
+--- pocketcellar-1.1/winedb.cpp.old 2005-02-28 13:43:30.000000000 +0000
++++ pocketcellar-1.1/winedb.cpp 2005-02-28 13:40:55.000000000 +0000
+@@ -141,6 +141,7 @@
+ #include <qdatastream.h>
+ #include <qtextstream.h>
+ #include <qfile.h>
++#include <qdir.h>
+
+
+ QDataStream& operator>>(QDataStream& s, Wine& w) {
+@@ -209,15 +210,15 @@
+
+
+ bool WineDB::load(QListView *parent, int loc) {
+- QString path("/home");
++ QString path(QDir::homeDirPath());
+
+ if (loc == 1)
+- path = "/usr/mnt.rom/cf";
++ path = "/media/cf";
+ else if (loc == 2)
+- path = "/usr/mnt.rom/card";
++ path = "/media/card";
+
+- mkdir(QString(path + "/QtPalmtop/data/PocketCellar").ascii(), 755);
+- QFile f(path + "/QtPalmtop/data/PocketCellar/PCWineDB");
++ mkdir(QString(path + "/Documents/application/PocketCellar").ascii(), 755);
++ QFile f(path + "/Documents/application/PocketCellar/PCWineDB");
+
+ if (!f.open(IO_ReadOnly))
+ return false;
+@@ -240,26 +241,26 @@
+
+ f.close();
+
+- if (loc != 0)
++/* if (loc != 0)
+ unlink("/home/QtPalmtop/data/PocketCellar/PCWineDB");
+ if (loc != 1)
+ unlink("/usr/mnt.rom/cf/QtPalmtop/data/PocketCellar/PCWineDB");
+ if (loc != 2)
+- unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCWineDB");
++ unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCWineDB");*/
+ return true;
+ }
+
+
+ bool WineDB::save(QListView *parent, int loc) {
+- QString path("/home");
++ QString path(QDir::homeDirPath());
+
+ if (loc == 1)
+- path = "/usr/mnt.rom/cf";
++ path = "/media/cf";
+ else if (loc == 2)
+- path = "/usr/mnt.rom/card";
++ path = "/media/card";
+
+- mkdir(QString(path + "/QtPalmtop/data/PocketCellar").ascii(), 755);
+- QFile f(path + "/QtPalmtop/data/PocketCellar/PCWineDB");
++ mkdir(QString(path + "/Documents/application/PocketCellar").ascii(), 755);
++ QFile f(path + "/Documents/application/PocketCellar/PCWineDB");
+
+ if (!f.open(IO_WriteOnly))
+ return false;
+@@ -277,12 +278,12 @@
+
+ f.close();
+
+- if (loc != 0)
++/* if (loc != 0)
+ unlink("/home/QtPalmtop/data/PocketCellar/PCWineDB");
+ if (loc != 1)
+ unlink("/usr/mnt.rom/cf/QtPalmtop/data/PocketCellar/PCWineDB");
+ if (loc != 2)
+- unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCWineDB");
++ unlink("/usr/mnt.rom/card/QtPalmtop/data/PocketCellar/PCWineDB");*/
+ return true;
+ }
+
+@@ -290,7 +291,7 @@
+ QStringList WineDB::grapeList;
+
+ bool WineDB::loadGrapeList() {
+- QFile f("/home/QtPalmtop/data/PocketCellar/grapelist.txt");
++ QFile f("/opt/QtPalmtop/data/PocketCellar/grapelist.txt");
+
+ if (!f.open(IO_ReadOnly))
+ return false;
diff --git a/recipes-qtopia/pocketcellar/pocketcellar_1.1.bb b/recipes-qtopia/pocketcellar/pocketcellar_1.1.bb
new file mode 100644
index 0000000..8c0ebec
--- /dev/null
+++ b/recipes-qtopia/pocketcellar/pocketcellar_1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Wine cellar manager. Allows you to record details of wines and \
+those you have in your cellar. The Food Assistant will make suggestions of wines \
+suitable for your meal, and indicate those in your cellar that match."
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "http://www.staikos.net/~staikos/pocketcellar/pocketcellar-${PV}.tar.gz \
+ file://winedb.patch \
+ file://cellardb.patch \
+ file://pocketcellar.patch \
+ file://gcc3.patch"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += " DESTDIR=pkg-cellar/home/QtPalmtop/bin/"
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/data/PocketCellar
+
+ install -m 644 pkg-pcellar/home/QtPalmtop/data/PocketCellar/* ${D}${palmtopdir}/data/PocketCellar/
+ install -m 755 pkg-cellar/home/QtPalmtop/bin/pocketcellar ${D}${palmtopdir}/bin/
+ install -m 644 pocketcellar.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 644 pocketcellar.png ${D}${palmtopdir}/pics/
+ install -m 644 pkg-pcellar/home/root/Settings/foodassist.conf ${D}${palmtopdir}/data/PocketCellar/
+}
+
+FILES_${PN} = "/"
+
+SRC_URI[md5sum] = "ef65260b37a0c11898c680a576846c94"
+SRC_URI[sha256sum] = "5ae5e9816bc8503b768f831f058bd1c379bb821e8c0776015ffeb998e1d912f8"