aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/scummvm/scummvm_0.6.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/scummvm/scummvm_0.6.0.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/scummvm/scummvm_0.6.0.bb')
-rw-r--r--recipes-qtopia/scummvm/scummvm_0.6.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qtopia/scummvm/scummvm_0.6.0.bb b/recipes-qtopia/scummvm/scummvm_0.6.0.bb
new file mode 100644
index 0000000..baf21db
--- /dev/null
+++ b/recipes-qtopia/scummvm/scummvm_0.6.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Virtual Machine for LucasArts Adventures for Qt/Embedded based palmtop environments w/ SDL."
+SECTION = "opie/games"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe tremor libogg zlib \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad mpeg2dec', d)}"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/scummvm/scummvm-${PV}.tar.bz2 \
+ file://sword1.patch \
+ file://tremor.patch \
+ file://mouse.patch "
+PR="r1"
+
+inherit autotools
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+EXTRA_OECONF = "--host=${HOST_SYS} \
+ --backend=sdl \
+ --disable-alsa \
+ --with-ogg-prefix=${STAGING_LIBDIR}/.. \
+ --with-vorbis-prefix=${STAGING_LIBDIR}/.. \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mpeg2', '--with-mpeg2-prefix=${STAGING_LIBDIR}/..', d)} \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '--disable-mad', '--with-mad-prefix=${STAGING_BINDIR_CROSS}/..', d)} \
+ "
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 scummvm ${D}${bindir}/scummvm
+}
+
+
+SRC_URI[md5sum] = "efc4207a7f10b24e9fc5afa10ed9c455"
+SRC_URI[sha256sum] = "ac22ad70ad6f88c7c8450bc06ba38602331c7470abcafb9e7fe62bfb505b1a3b"