aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/tasklistapplet
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/tasklistapplet
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/tasklistapplet')
-rw-r--r--recipes-qtopia/tasklistapplet/tasklistapplet_1.0.5.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qtopia/tasklistapplet/tasklistapplet_1.0.5.bb b/recipes-qtopia/tasklistapplet/tasklistapplet_1.0.5.bb
new file mode 100644
index 0000000..0e3079f
--- /dev/null
+++ b/recipes-qtopia/tasklistapplet/tasklistapplet_1.0.5.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "TaskList Applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sourceforge.net/projects/subapplet/"
+
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/subapplet/tasklist-105.tar.gz"
+
+S = "${WORKDIR}/TaskList-1.0.5"
+
+inherit palmtop
+
+#QMAKE_PROFILES = "subapplet.pro"
+
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/applets ${D}${palmtopdir}/pics/tasklist/
+ install -m 0644 icons/*.png ${D}${palmtopdir}/pics/tasklist/
+ oe_libinstall -so -C rel/opt/Qtopia/plugins/applets libtasklistapplet ${D}${palmtopdir}/plugins/applets/
+}
+
+pkg_postinst() {
+#!/bin/sh
+if pidof -s qpe >/dev/null; then
+ /usr/bin/qcop QPE/TaskBar "reloadApplets()"
+else
+ exit 0
+fi
+ if [ -n "$D" ]; then false; fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+/usr/bin/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}
+
+SRC_URI[md5sum] = "dc62a061d83cf72d1eca7e8ae2c8e1a6"
+SRC_URI[sha256sum] = "4078c44beebfd298995983b9e2ea189167a1ab081d96a7c485a67b65a974e878"