aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/zlapspeed
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/zlapspeed
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/zlapspeed')
-rw-r--r--recipes-qtopia/zlapspeed/zlapspeed-1.0.0/qtopia17.patch25
-rw-r--r--recipes-qtopia/zlapspeed/zlapspeed_1.0.0.bb22
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-qtopia/zlapspeed/zlapspeed-1.0.0/qtopia17.patch b/recipes-qtopia/zlapspeed/zlapspeed-1.0.0/qtopia17.patch
new file mode 100644
index 0000000..320ea5e
--- /dev/null
+++ b/recipes-qtopia/zlapspeed/zlapspeed-1.0.0/qtopia17.patch
@@ -0,0 +1,25 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zlaps-src/zlaps_main.cpp~qtopia17 2004-04-15 04:44:10.000000000 +0200
++++ zlaps-src/zlaps_main.cpp 2004-04-18 12:54:08.000000000 +0200
+@@ -1,5 +1,15 @@
+ #include "zlaps.h"
+ #include <qpe/qpeapplication.h>
+
+-QTOPIA_ADD_APPLICATION("zlaps", zlaps)
+-QTOPIA_MAIN
++//QTOPIA_ADD_APPLICATION("zlaps", zlaps)
++//QTOPIA_MAIN
++
++int main(int argc, char** argv)
++{
++ QPEApplication a( argc, argv );
++ zlaps* w = new zlaps();
++ a.showMainWidget( w );
++ a.exec();
++}
++
++
diff --git a/recipes-qtopia/zlapspeed/zlapspeed_1.0.0.bb b/recipes-qtopia/zlapspeed/zlapspeed_1.0.0.bb
new file mode 100644
index 0000000..55cf650
--- /dev/null
+++ b/recipes-qtopia/zlapspeed/zlapspeed_1.0.0.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Zaurus Race Lap Speed Measuring Application for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.cinlug.org/modules/Static_Docs/data/db/zlaps/zlaps_${PV}_arm.src.tar.gz \
+ file://qtopia17.patch"
+S = "${WORKDIR}/zlaps-src"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'TMAKE_LIBS-="-luuid" TMAKE_LIBS+="-lqpe" CONFIG+=qt CONFIG-=qtopia'
+
+do_install() {
+ install -d ${D}${palmtopdir}/{bin,pics,apps/Applications}
+ install -m 0755 zlaps ${D}${palmtopdir}/bin/
+ install -m 0755 images/zlaps.png ${D}${palmtopdir}/pics/
+ install -m 0644 zlaps.desktop ${D}${palmtopdir}/apps/Applications/
+}
+
+SRC_URI[md5sum] = "6c3d5a05da141c7d3ceac0db3d587441"
+SRC_URI[sha256sum] = "23252f3d76c863f88daae8384c0c02a93638a883048a084a0f2fcfbd804eb5ae"