aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/preferred-opie-git-versions.inc1
-rw-r--r--recipes-opie/opie-bluetoothd/opie-bluetoothd.inc17
-rw-r--r--recipes-opie/opie-bluetoothd/opie-bluetoothd_git.bb4
3 files changed, 22 insertions, 0 deletions
diff --git a/conf/distro/include/preferred-opie-git-versions.inc b/conf/distro/include/preferred-opie-git-versions.inc
index afd947f..61e3f1d 100644
--- a/conf/distro/include/preferred-opie-git-versions.inc
+++ b/conf/distro/include/preferred-opie-git-versions.inc
@@ -39,6 +39,7 @@ SRCREV_pn-opie-backup ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-bartender ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-batteryapplet ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-bluetoothapplet ?= "${OPIE_SRCREV}"
+SRCREV_pn-opie-bluetoothd ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-bluetoothmanager ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-bounce ?= "${OPIE_SRCREV}"
SRCREV_pn-opie-brightnessapplet ?= "${OPIE_SRCREV}"
diff --git a/recipes-opie/opie-bluetoothd/opie-bluetoothd.inc b/recipes-opie/opie-bluetoothd/opie-bluetoothd.inc
new file mode 100644
index 0000000..5cae5be
--- /dev/null
+++ b/recipes-opie/opie-bluetoothd/opie-bluetoothd.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "Bluetooth daemon for Opie"
+SECTION = "opie/base"
+LICENSE = "GPLv2"
+# FIXME stopgap until split archives have license files included
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+APPNAME = "opiebluetoothd"
+
+S = "${WORKDIR}/opiebluetoothd"
+
+inherit opie
+
+do_install() {
+ # Section is "base" so this has to be done manually
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/opiebluetoothd ${D}${bindir}/opiebluetoothd
+}
+
diff --git a/recipes-opie/opie-bluetoothd/opie-bluetoothd_git.bb b/recipes-opie/opie-bluetoothd/opie-bluetoothd_git.bb
new file mode 100644
index 0000000..dac89e4
--- /dev/null
+++ b/recipes-opie/opie-bluetoothd/opie-bluetoothd_git.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/net/opietooth/opiebluetoothd"