aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qtopia/zsafe/zsafe-2.1.3/stream_h.patch17
-rw-r--r--recipes-qtopia/zsafe/zsafe_2.1.3.bb5
2 files changed, 20 insertions, 2 deletions
diff --git a/recipes-qtopia/zsafe/zsafe-2.1.3/stream_h.patch b/recipes-qtopia/zsafe/zsafe-2.1.3/stream_h.patch
new file mode 100644
index 0000000..1f575f4
--- /dev/null
+++ b/recipes-qtopia/zsafe/zsafe-2.1.3/stream_h.patch
@@ -0,0 +1,17 @@
+Replace legacy header usage to fix compilation
+
+stream.h is no longer provided on modern systems, use iostream instead.
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+
+--- zsafe-2.1.3-r1.orig/zsafe.h
++++ zsafe-2.1.3-r1/zsafe.h
+@@ -16,7 +16,7 @@
+
+ #ifndef WIN32
+ #ifndef DESKTOP
+-#include <stream.h>
++#include <iostream>
+ #else
+ #include <sstream>
+ #endif
diff --git a/recipes-qtopia/zsafe/zsafe_2.1.3.bb b/recipes-qtopia/zsafe/zsafe_2.1.3.bb
index 2b73cc2..9b0666a 100644
--- a/recipes-qtopia/zsafe/zsafe_2.1.3.bb
+++ b/recipes-qtopia/zsafe/zsafe_2.1.3.bb
@@ -5,9 +5,10 @@ RCONFLICTS_${PN} = "opie-zsafe"
APPNAME = "zsafe"
APPTYPE = "binary"
APPDESKTOP = "${WORKDIR}"
-SRC_URI = "http://z-soft.z-portal.info/zsafe/zsafe_2.1.3.tgz"
+SRC_URI = "http://zcarsten.dyndns.org/carsten/zaurus/zsafe/zsafe_2.1.3.tgz \
+ file://stream_h.patch"
S = "${WORKDIR}"
-PR = "r1"
+PR = "r2"
inherit opie