aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/opie.bbclass2
-rw-r--r--recipes-opie/libqpe/libqpe-opie.inc7
-rw-r--r--recipes-opie/libqpe/libqpe-opie_git.bb6
-rw-r--r--recipes-opie/opie-help-en/opie-help-en_git.bb1
-rw-r--r--recipes-opie/opie-i18n/opie-i18n_git.bb1
-rw-r--r--recipes-opie/opie-i18n/opie-lrelease-native_git.bb1
-rw-r--r--recipes-opie/opie-i18n/opie-lupdate-native_git.bb1
-rw-r--r--recipes-opie/opie-keytabs/opie-keytabs_git.bb1
-rw-r--r--recipes-opie/opie-mediaplayer1/opie-mediaplayer1_git.bb1
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb1
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_1.2.5.bb2
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb3
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb1
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb1
-rw-r--r--recipes-opie/opie-pics/opie-pics_git.bb1
-rw-r--r--recipes-opie/opie-sounds/opie-sounds_git.bb1
16 files changed, 7 insertions, 24 deletions
diff --git a/classes/opie.bbclass b/classes/opie.bbclass
index 3c799cd..3630baf 100644
--- a/classes/opie.bbclass
+++ b/classes/opie.bbclass
@@ -15,8 +15,6 @@
inherit palmtop
-OPIE_SRCREV ?= "8c3beef263bc9c34443eacfc821e99813e17554f"
-OPIE_GIT_PV ?= "1.2.4+gitr${OPIE_SRCREV}"
DEPENDS_prepend = "${@["libopie2 ", ""][(bb.data.getVar('PN', d, 1) == 'libopie2')]}"
# to be consistent, put all targets into workdir
diff --git a/recipes-opie/libqpe/libqpe-opie.inc b/recipes-opie/libqpe/libqpe-opie.inc
index cc8922f..7ddc40c 100644
--- a/recipes-opie/libqpe/libqpe-opie.inc
+++ b/recipes-opie/libqpe/libqpe-opie.inc
@@ -12,6 +12,13 @@ S = "${WORKDIR}/library"
inherit palmtop
+python __anonymous() {
+ # This doesn't need to be in this recipe specifically, but it's as good
+ # a place as any since it has to be parsed if Opie is going to be built
+ if not bb.data.getVar("OPIE_VERSION", d, True):
+ bb.warn("OPIE_VERSION has not been set; if you are going to build Opie, you need to 'require' an appropriate .inc file from meta-opie/conf/distro/include")
+}
+
OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
QMAKE_PROFILES = "library.pro"
EXTRA_QMAKEVARS_PRE += "CONFIG+=LIBQPE_WITHROHFEEDBACK"
diff --git a/recipes-opie/libqpe/libqpe-opie_git.bb b/recipes-opie/libqpe/libqpe-opie_git.bb
index 41a6e33..585c0ae 100644
--- a/recipes-opie/libqpe/libqpe-opie_git.bb
+++ b/recipes-opie/libqpe/libqpe-opie_git.bb
@@ -1,11 +1,5 @@
require ${PN}.inc
-# OPIE_GIT_PV is defined in opie.bbclass
-# but this recipe does not inherit opie
-# so any updates to OPIE_GIT_PV should happen
-# in both places.
-
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "${INC_PR}.0"
diff --git a/recipes-opie/opie-help-en/opie-help-en_git.bb b/recipes-opie/opie-help-en/opie-help-en_git.bb
index 20bcb5d..78a7590 100644
--- a/recipes-opie/opie-help-en/opie-help-en_git.bb
+++ b/recipes-opie/opie-help-en/opie-help-en_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"
diff --git a/recipes-opie/opie-i18n/opie-i18n_git.bb b/recipes-opie/opie-i18n/opie-i18n_git.bb
index 0d1d913..bf53a7a 100644
--- a/recipes-opie/opie-i18n/opie-i18n_git.bb
+++ b/recipes-opie/opie-i18n/opie-i18n_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"
diff --git a/recipes-opie/opie-i18n/opie-lrelease-native_git.bb b/recipes-opie/opie-i18n/opie-lrelease-native_git.bb
index 13d1345..1581f95 100644
--- a/recipes-opie/opie-i18n/opie-lrelease-native_git.bb
+++ b/recipes-opie/opie-i18n/opie-lrelease-native_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"
diff --git a/recipes-opie/opie-i18n/opie-lupdate-native_git.bb b/recipes-opie/opie-i18n/opie-lupdate-native_git.bb
index 55cfa33..e42251f 100644
--- a/recipes-opie/opie-i18n/opie-lupdate-native_git.bb
+++ b/recipes-opie/opie-i18n/opie-lupdate-native_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"
diff --git a/recipes-opie/opie-keytabs/opie-keytabs_git.bb b/recipes-opie/opie-keytabs/opie-keytabs_git.bb
index c818083..4af259f 100644
--- a/recipes-opie/opie-keytabs/opie-keytabs_git.bb
+++ b/recipes-opie/opie-keytabs/opie-keytabs_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"
diff --git a/recipes-opie/opie-mediaplayer1/opie-mediaplayer1_git.bb b/recipes-opie/opie-mediaplayer1/opie-mediaplayer1_git.bb
index be93a60..2ec08c6 100644
--- a/recipes-opie/opie-mediaplayer1/opie-mediaplayer1_git.bb
+++ b/recipes-opie/opie-mediaplayer1/opie-mediaplayer1_git.bb
@@ -1,5 +1,4 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
index ee206e8..cb85eb0 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
@@ -5,7 +5,6 @@ LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
APPNAME = "opieplayer2"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r3"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_1.2.5.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_1.2.5.bb
index cbd0643..f8ebb6b 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_1.2.5.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_1.2.5.bb
@@ -6,8 +6,6 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
APPNAME = "opieplayer2"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
-OPIE_SRCREV ?= "8c3beef263bc9c34443eacfc821e99813e17554f"
-
PR = "r0"
SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
index 760b21d..3a4e15d 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
@@ -6,9 +6,6 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425
APPNAME = "opieplayer2"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
-OPIE_SRCREV ?= "8c3beef263bc9c34443eacfc821e99813e17554f"
-OPIE_GIT_PV ?= "1.2.4+gitr${OPIE_SRCREV}"
-
PV = "${OPIE_GIT_PV}"
PR = "r4"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
index 0c73e96..952d7e2 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
@@ -5,7 +5,6 @@ LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
APPNAME = "opieplayer2"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r3"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
index a075734..3c0a7fb 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
@@ -5,7 +5,6 @@ LICENSE = "GPL"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
APPNAME = "opieplayer2"
RPROVIDES_${PN} = "opie-mediaplayer2-skin"
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r3"
diff --git a/recipes-opie/opie-pics/opie-pics_git.bb b/recipes-opie/opie-pics/opie-pics_git.bb
index 00fe1da..4dac786 100644
--- a/recipes-opie/opie-pics/opie-pics_git.bb
+++ b/recipes-opie/opie-pics/opie-pics_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r2"
diff --git a/recipes-opie/opie-sounds/opie-sounds_git.bb b/recipes-opie/opie-sounds/opie-sounds_git.bb
index 77efe49..0d2b802 100644
--- a/recipes-opie/opie-sounds/opie-sounds_git.bb
+++ b/recipes-opie/opie-sounds/opie-sounds_git.bb
@@ -1,6 +1,5 @@
require ${PN}.inc
-OPIE_GIT_PV ?= "1.2.2+cvs${SRCDATE}"
PV = "${OPIE_GIT_PV}"
PR = "r1"