aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-tableviewer
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-opie/opie-tableviewer')
-rw-r--r--recipes-opie/opie-tableviewer/opie-tableviewer.inc17
-rw-r--r--recipes-opie/opie-tableviewer/opie-tableviewer_1.2.5.bb11
-rw-r--r--recipes-opie/opie-tableviewer/opie-tableviewer_cvs.bb7
3 files changed, 35 insertions, 0 deletions
diff --git a/recipes-opie/opie-tableviewer/opie-tableviewer.inc b/recipes-opie/opie-tableviewer/opie-tableviewer.inc
new file mode 100644
index 0000000..86a9f3f
--- /dev/null
+++ b/recipes-opie/opie-tableviewer/opie-tableviewer.inc
@@ -0,0 +1,17 @@
+DESCRIPTION = "XML database browsers"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "tableviewer"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/application/libtableviewer.so* bin/tableviewer apps/Applications/tableviewer.desktop
+do_install() {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/pics/${APPNAME}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+}
+
diff --git a/recipes-opie/opie-tableviewer/opie-tableviewer_1.2.5.bb b/recipes-opie/opie-tableviewer/opie-tableviewer_1.2.5.bb
new file mode 100644
index 0000000..f8b83d3
--- /dev/null
+++ b/recipes-opie/opie-tableviewer/opie-tableviewer_1.2.5.bb
@@ -0,0 +1,11 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_noncore_apps_tableviewer.tar.bz2;name=split_noncore_apps_tableviewer \
+ http://sources.openembedded.org/opie-1.2.5-split_pics.tar.bz2;name=split_pics \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_noncore_apps_tableviewer.md5sum] = "9671efbba1bd5483a97b64c2569da026"
+SRC_URI[split_noncore_apps_tableviewer.sha256sum] = "dc6c48d93bc0770a76e133eb38eda5d42590a25ceaab58e92445f0dfbe6c41b9"
+SRC_URI[split_pics.md5sum] = "e9b68749d67295f7080a23e39b17335e"
+SRC_URI[split_pics.sha256sum] = "0a7aab6d0bce04d6a9c257d768d8a1a481d38ba527d6e6e50723973789954b4a"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-tableviewer/opie-tableviewer_cvs.bb b/recipes-opie/opie-tableviewer/opie-tableviewer_cvs.bb
new file mode 100644
index 0000000..3c91ab5
--- /dev/null
+++ b/recipes-opie/opie-tableviewer/opie-tableviewer_cvs.bb
@@ -0,0 +1,7 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/apps/tableviewer \
+ ${OPIE_GIT};protocol=git;subpath=pics \
+ ${OPIE_GIT};protocol=git;subpath=apps"