aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/nonworking
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia/nonworking')
-rw-r--r--recipes-qtopia/nonworking/qtella/qtella_0.6.5.bb14
-rw-r--r--recipes-qtopia/nonworking/zaurss/zaurss_0.4.2.bb33
-rw-r--r--recipes-qtopia/nonworking/zethereal/zethereal_1.0.0.bb58
3 files changed, 105 insertions, 0 deletions
diff --git a/recipes-qtopia/nonworking/qtella/qtella_0.6.5.bb b/recipes-qtopia/nonworking/qtella/qtella_0.6.5.bb
new file mode 100644
index 0000000..382a59c
--- /dev/null
+++ b/recipes-qtopia/nonworking/qtella/qtella_0.6.5.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A GNet Client for Qtopia/Opie based Palmtop Environments"
+SECTION = "opie"
+PRIORITY = "optional"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/qtella/qtella-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-qt-dir=${STAGING_LIBDIR}/.. --with-qt-moc=${STAGING_BINDIR_NATIVE}/moc --with-qt-uic=${STAGING_BINDIR_NATIVE}/uic \
+ --with-qt-includes=${STAGING_INCDIR}/ --with-qt-libs=${STAGING_LIBDIR}/ --with-kde=no --enable-sharp"
+
+
+SRC_URI[md5sum] = "210e5f014e348815d5b32cd26b605d9c"
+SRC_URI[sha256sum] = "0505bed70fca7137753c4650ed03981d56caacbf4e1bee773427999c2c1e4da5"
diff --git a/recipes-qtopia/nonworking/zaurss/zaurss_0.4.2.bb b/recipes-qtopia/nonworking/zaurss/zaurss_0.4.2.bb
new file mode 100644
index 0000000..6fd1cef
--- /dev/null
+++ b/recipes-qtopia/nonworking/zaurss/zaurss_0.4.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "ZauRSS is an RSS aggregator for Qtopia. It can manage multiple RSS feeds. \
+It can also work with NetFront3, and you can see RDF items with it. "
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.daionet.gr.jp/~knok/software/zaurss/"
+APPNAME = "zaurss"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+PR = "r0"
+
+SRC_URI = "http://www.daionet.gr.jp/~knok/software/zaurss/zaurss-${PV}.tar.gz"
+
+inherit opie
+
+OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/qpe"
+EXTRA_QMAKEVARS_POST = "INCLUDEPATH=dialog \
+ INCLUDEPATH+=qhttp \
+ INCLUDEPATH+=${QTDIR}/include"
+
+do_configure_prepend() {
+ rm -f Makefile
+ find . -name "moc*"|xargs rm -f
+}
+
+do_install () {
+ install -d ${D}/${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/*.png ${D}/${palmtopdir}/pics/
+
+}
+
+SRC_URI[md5sum] = "71c6e08a68aba6ed26cd80480da4160a"
+SRC_URI[sha256sum] = "52e8e83cbf00e4c66dd3e862e87cfa5e468089d8aaa78ca9c2d4e1f873cb1817"
diff --git a/recipes-qtopia/nonworking/zethereal/zethereal_1.0.0.bb b/recipes-qtopia/nonworking/zethereal/zethereal_1.0.0.bb
new file mode 100644
index 0000000..08f97c3
--- /dev/null
+++ b/recipes-qtopia/nonworking/zethereal/zethereal_1.0.0.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "The network packet dissector Ethereal, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "glib-1.2 openssl"
+HOMEPAGE = "http://www.cartel-info.fr/pbiondi/zaurus/"
+APPNAME = "zethereal"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+PR = "r0"
+
+inherit autotools qmake_base
+
+EXTRA_OECONF = "--disable-ethereal \
+ --enable-tethereal \
+ --disable-editcap \
+ --disable-mergecap \
+ --disable-text2pcap \
+ --disable-idl2eth \
+ --without-ucdsnmp \
+ --disable-usr-local \
+ --with-pcap=${STAGING_LIBDIR}/.. \
+ --with-zlib=${STAGING_LIBDIR}/.. \
+ --without-x"
+
+export GLIB_CONFIG = "${STAGING_BINDIR_CROSS}/glib-config"
+
+CFLAGS += "-I${STAGING_INCDIR}/glib-1.2"
+LIBS += "-lglib-1.2"
+
+SRC_URI = "http://www.cartel-info.fr/pbiondi/zaurus/ethereal-0.9.5.tar.gz;name=ethereal \
+ http://www.cartel-info.fr/pbiondi/zaurus/zethereal-1.0.tar.gz;name=zethereal"
+S = "${WORKDIR}/ethereal-0.9.5"
+
+SRC_URI[ethereal.md5sum] = "a7a02706c0f22e56a45bd8999dbb35e3"
+SRC_URI[ethereal.sha256sum] = "793ee1a770b6388dce98b7f02eae69b31a8b2172dc69ff3b957376f7df6e8d79"
+SRC_URI[zethereal.md5sum] = "d9107c91098f231350c2abf91d4fcb82"
+SRC_URI[zethereal.sha256sum] = "e13b931584a9d27d77186c15fac60a7f3f8934af375d8640c44d2e9bc7adc0b4"
+
+do_compile() {
+ oe_runmake SUBDIRS="wiretap"
+ mv ${WORKDIR}/qtopia .
+ ${AR} r libzethereal.a packet-*.o afn.o asn1.o column.o conditions.o \
+ capture_stop_conditions.o follow.o in_cksum.o ipproto.o pcap-u \
+ til.o prefs.o print.o ps.o ptvcursor.o reassemble.o ringbuffer.o \
+ util.o xdlc.o xmlstub.o register.o
+ cd qtopia
+ qmake -spec ${QMAKESPEC} zethereal.pro && oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ :
+}
+