aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qtopia')
-rw-r--r--recipes-qtopia/snes9x/64bit.patch110
-rw-r--r--recipes-qtopia/snes9x/snes9x/configure.patch12
-rw-r--r--recipes-qtopia/snes9x/snes9x/linkage.patch31
-rw-r--r--recipes-qtopia/snes9x/snes9x/makefile.patch39
-rw-r--r--recipes-qtopia/snes9x/snes9x/private.patch10
-rw-r--r--recipes-qtopia/snes9x/snes9x_1.43-WIP1.bb32
6 files changed, 0 insertions, 234 deletions
diff --git a/recipes-qtopia/snes9x/64bit.patch b/recipes-qtopia/snes9x/64bit.patch
deleted file mode 100644
index a8388de..0000000
--- a/recipes-qtopia/snes9x/64bit.patch
+++ /dev/null
@@ -1,110 +0,0 @@
---- s/offsets.cpp~ 2004-07-11 22:50:59.000000000 +0100
-+++ s/offsets.cpp 2008-07-27 10:28:40.000000000 +0100
-@@ -100,30 +100,30 @@
- #endif
-
- #define OFFSET(N,F) \
--fprintf (S9xSTREAM, "#define " #N " CPU + %d\n", (int) &((struct SCPUState *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " CPU + %d\n", &((struct SCPUState *) 0)->F);
- #define OFFSET2(N,F) \
--fprintf (S9xSTREAM, "#define " #N " Registers + %d\n", (int) &((struct SRegisters *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " Registers + %d\n", &((struct SRegisters *) 0)->F);
- #define OFFSET3(F) \
--fprintf (S9xSTREAM, "#define " #F " Memory + %d\n", (int) &((class CMemory *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #F " Memory + %d\n", &((class CMemory *) 0)->F);
- #define OFFSET4(N,F) \
--fprintf (S9xSTREAM, "#define " #N " APU + %d\n", (int) &((struct SAPU *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " APU + %d\n", &((struct SAPU *) 0)->F);
- #define OFFSET5(N,F) \
--fprintf (S9xSTREAM, "#define " #N " IAPU + %d\n", (int) &((struct SIAPU *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " IAPU + %d\n", &((struct SIAPU *) 0)->F);
- #define OFFSET6(N,F) \
--fprintf (S9xSTREAM, "#define " #N " ICPU + %d\n", (int) &((struct SICPU *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " ICPU + %d\n", &((struct SICPU *) 0)->F);
- #define OFFSET7(N,F) \
--fprintf (S9xSTREAM, "#define " #N " Settings + %d\n", (int) &((struct SSettings *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " Settings + %d\n", &((struct SSettings *) 0)->F);
- #define OFFSET8(N, F) \
--fprintf (S9xSTREAM, "#define " #N " APURegisters + %d\n", (int) &((struct SAPURegisters *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " APURegisters + %d\n", &((struct SAPURegisters *) 0)->F);
-
- #define OFFSET9(N, F) \
--fprintf (S9xSTREAM, "#define " #N " PPU + %d\n", (int) &((struct SPPU *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " PPU + %d\n", &((struct SPPU *) 0)->F);
- #define OFFSET10(N, F) \
--fprintf (S9xSTREAM, "#define " #N " IPPU + %d\n", (int) &((struct InternalPPU *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " IPPU + %d\n", &((struct InternalPPU *) 0)->F);
- #define OFFSET11(N, F) \
--fprintf (S9xSTREAM, "#define " #N " SA1 + %d\n", (int) &((struct SSA1 *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " SA1 + %d\n", &((struct SSA1 *) 0)->F);
- #define OFFSET12(N, F) \
--fprintf (S9xSTREAM, "#define " #N " SA1Registers + %d\n", (int) &((struct SSA1Registers *) 0)->F);
-+fprintf (S9xSTREAM, "#define " #N " SA1Registers + %d\n", &((struct SSA1Registers *) 0)->F);
-
- int main (int /*argc*/, char ** /*argv*/)
- {
---- s/getset.h~ 2004-07-11 22:50:58.000000000 +0100
-+++ s/getset.h 2008-07-27 10:30:38.000000000 +0100
-@@ -120,7 +120,7 @@
- return (*(GetAddress + (Address & 0xffff)));
- }
-
-- switch ((int) GetAddress)
-+ switch ((long)GetAddress)
- {
- case CMemory::MAP_PPU:
- return (S9xGetPPU (Address & 0xffff));
-@@ -225,7 +225,7 @@
- #endif
- }
-
-- switch ((int) GetAddress)
-+ switch ((long) GetAddress)
- {
- case CMemory::MAP_PPU:
- return (S9xGetPPU (Address & 0xffff) |
-@@ -349,7 +349,7 @@
- return;
- }
-
-- switch ((int) SetAddress)
-+ switch ((long) SetAddress)
- {
- case CMemory::MAP_PPU:
- S9xSetPPU (Byte, Address & 0xffff);
-@@ -482,7 +482,7 @@
- return;
- }
-
-- switch ((int) SetAddress)
-+ switch ((long) SetAddress)
- {
- case CMemory::MAP_PPU:
- S9xSetPPU ((uint8) Word, Address & 0xffff);
-@@ -603,7 +603,7 @@
- {
- return s7r.bank50;
- }
-- switch ((int) GetAddress)
-+ switch ((long) GetAddress)
- {
- case CMemory::MAP_SPC7110_DRAM:
- #ifdef SPC7110_DEBUG
-@@ -669,7 +669,7 @@
- if(Settings.SPC7110&&((Address&0x7FFFFF)==0x4800))
- return s7r.bank50;
-
-- switch ((int) GetAddress)
-+ switch ((long) GetAddress)
- {
- case CMemory::MAP_SPC7110_DRAM:
- #ifdef SPC7110_DEBUG
-@@ -729,7 +729,7 @@
- return;
- }
-
-- switch ((int) GetAddress)
-+ switch ((long) GetAddress)
- {
- case CMemory::MAP_PPU:
- CPU.PCBase = Memory.FillRAM;
diff --git a/recipes-qtopia/snes9x/snes9x/configure.patch b/recipes-qtopia/snes9x/snes9x/configure.patch
deleted file mode 100644
index e9fb685..0000000
--- a/recipes-qtopia/snes9x/snes9x/configure.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure 2009-05-21 15:48:14.000000000 +0100
-+++ configure 2009-05-21 15:48:14.000000000 +0100
-@@ -4474,9 +4474,6 @@
- LIBS="-lX11 -lXext"
- SYSLIBS="$SYSLIBS -L$x_libraries -lX11 -lXext"
- fi
--if test x$x_includes != x ; then
-- XINCLUDES="-I$x_includes"
--fi
- echo $ac_n "checking for XDGAQueryVersion in -lXxf86dga""... $ac_c" 1>&6
- echo "configure:4482: checking for XDGAQueryVersion in -lXxf86dga" >&5
- ac_lib_var=`echo Xxf86dga'_'XDGAQueryVersion | sed 'y%./+-%__p_%'`
diff --git a/recipes-qtopia/snes9x/snes9x/linkage.patch b/recipes-qtopia/snes9x/snes9x/linkage.patch
deleted file mode 100644
index cc007b5..0000000
--- a/recipes-qtopia/snes9x/snes9x/linkage.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- ppu.h~ 2004-07-11 22:50:59.000000000 +0100
-+++ ppu.h 2009-05-21 15:54:06.000000000 +0100
-@@ -332,10 +332,14 @@
- uint8 _5A22;
- } SnesModel;
-
-+START_EXTERN_C
-+
- extern SnesModel* Model;
- extern SnesModel M1SNES;
- extern SnesModel M2SNES;
-
-+END_EXTERN_C
-+
- #define MAX_5C77_VERSION 0x01
- #define MAX_5C78_VERSION 0x03
- #define MAX_5A22_VERSION 0x02
---- dsp1.h~ 2004-07-11 22:50:57.000000000 +0100
-+++ dsp1.h 2009-05-21 15:53:46.000000000 +0100
-@@ -122,9 +122,10 @@
- void S9xResetDSP1 ();
- uint8 S9xGetDSP (uint16 Address);
- void S9xSetDSP (uint8 Byte, uint16 Address);
--END_EXTERN_C
-
- extern struct SDSP1 DSP1;
-
-+END_EXTERN_C
-+
- #endif
-
diff --git a/recipes-qtopia/snes9x/snes9x/makefile.patch b/recipes-qtopia/snes9x/snes9x/makefile.patch
deleted file mode 100644
index dc99864..0000000
--- a/recipes-qtopia/snes9x/snes9x/makefile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- snes9x-1.43-dev-src/snes9x/Makefile.in.old 2004-10-02 17:34:58.000000000 +0100
-+++ snes9x-1.43-dev-src/snes9x/Makefile.in 2004-10-02 17:42:25.000000000 +0100
-@@ -142,7 +142,7 @@
- #INCLUDES = -I../zlib @XINCLUDES@
- INCLUDES = @XINCLUDES@
-
--OPTIMISE = @OPTIMIZE@
-+OPTIMISE = $(filter-out @OPTIMIZE@,-pedantic)
-
- #OPTIMISE=-g -fno-exceptions
-
-@@ -165,7 +165,7 @@
- $(KREEDDEFINES) \
- $(SDD1DEFINES) \
- $(JOYDEFINES) \
---DNO_INLINE_SET_GET @SYSDEFINES@
-+-DNO_INLINE_SET_GET @SYSDEFINES@ $(OECFLAGS)
-
- #-DOLD_COLOUR_BLENDING
- #-DSOUND
-@@ -204,15 +204,15 @@
- #ggisnes9x
- #xf86snes9x
-
--offsets: offsets.o
-- $(CCC) $(INCLUDES) -o $@ offsets.o
-+offsets: offsets.cpp
-+ $(BUILD_CXX) $(INCLUDES) -o $@ $<
- ./offsets >i386/offsets.h
-
- #../zlib/libz.a:
- # cd ../zlib && sh ./configure && make
-
- snes9x: $(OBJECTS) unix/x11.o $(AIDOOBJS) $(GUIOBJS)
-- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(AIDOOBJS) $(GLIDEOBJS) $(OPENGLOBJS) unix/x11.o $(GUIOBJS) $(LDLIBS) $(GLIDELIBS) $(OPENGLLIBS) $(GUILIBS) @SYSLIBS@ -lXext -lX11 $(EXTRALIBS) -lm
-+ $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(AIDOOBJS) $(GLIDEOBJS) $(OPENGLOBJS) unix/x11.o $(GUIOBJS) $(OELDFLAGS) $(LDLIBS) $(GLIDELIBS) $(OPENGLLIBS) $(GUILIBS) @SYSLIBS@ -lXext -lX11 $(EXTRALIBS) -lm
-
- ssnes9x: $(OBJECTS) unix/svga.o
- $(CCC) $(INCLUDES) -o $@ $(OBJECTS) $(GLIDEOBJS) unix/svga.o $(LDLIBS) $(GLIDELIBS) -lvga -lvgagl $(EXTRALIBS) -lm
diff --git a/recipes-qtopia/snes9x/snes9x/private.patch b/recipes-qtopia/snes9x/snes9x/private.patch
deleted file mode 100644
index 83808f4..0000000
--- a/recipes-qtopia/snes9x/snes9x/private.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- unix/x11.cpp.old 2004-10-03 21:27:10.000000000 +0100
-+++ unix/x11.cpp 2004-10-03 21:29:02.000000000 +0100
-@@ -154,6 +154,7 @@
- #if defined (__cplusplus) || defined (c_plusplus)
- #define private c_private
- #include <X11/extensions/xf86vmode.h>
-+#undef private
- #endif
-
- #define ALL_DEVICE_EVENTS 0
diff --git a/recipes-qtopia/snes9x/snes9x_1.43-WIP1.bb b/recipes-qtopia/snes9x/snes9x_1.43-WIP1.bb
deleted file mode 100644
index 1b9091c..0000000
--- a/recipes-qtopia/snes9x/snes9x_1.43-WIP1.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-SECTION = "x11/games"
-PR = "r4"
-LICENSE = "snes9x"
-DEPENDS = "libxxf86dga libxxf86vm"
-DEPENDS_append_i686 = " nasm-native"
-RDEPENDS_epia = "kernel-module-joydev"
-
-SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
- file://makefile.patch;striplevel=2 \
- file://private.patch;striplevel=0 \
- file://64bit.patch \
- file://configure.patch;striplevel=0 \
- file://linkage.patch;striplevel=0"
-
-S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
-
-inherit autotools
-
-export OECFLAGS="${CFLAGS}"
-export OELDFLAGS="${LDFLAGS}"
-
-do_configure() {
- oe_runconf
-}
-
-do_install() {
- install -d ${D}${bindir}
- install snes9x ${D}${bindir}
-}
-
-SRC_URI[md5sum] = "caa2ed89fdc643a18310d2a50db1e02c"
-SRC_URI[sha256sum] = "bc14905c7a7967de59b70909c021d2439d9ec1c9bae835b70cdb786e59caa81c"