aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* opie-button-settings: make whole recipe a machine-onlyDmitry Eremin-Solenikov2011-12-131-1/+1
| | | | | | | | | Currently bitbake spills warnings on opie-button-settings recipe containing machine packages, while being non-machine one. Disable this warning by replacing all PACKAGE_ARCH_xxx stuff with a single PACKAGE_ARCH = "${MACHINE_ARCH}" Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
* task-opie, task-opie-16mb: make whole recipe a machine-onlyDmitry Eremin-Solenikov2011-12-132-10/+4
| | | | | | | | | Currently bitbake spills warnings on task-opie and task-opie-16mb recipes containing machine packages, while being non-machine ones. Disable this warning by replacing all PACKAGE_ARCH_xxx stuff with a single PACKAGE_ARCH = "${MACHINE_ARCH}" Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
* qmake: do also provide nativesdk variantDmitry Eremin-Solenikov2011-12-131-5/+3
| | | | | | | Opie SDK needs nativesdk version of qmake package. To achieve this, replace qmake-native with qmake recipe, which can be built both as virtclass-native and virtclass-nativesdk. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
* uicmoc: do also provide nativesdk variantDmitry Eremin-Solenikov2011-12-137-3/+8
| | | | | | | Opie SDK needs nativesdk version of uicmoc package. To achieve this, replace uicmoc-native with uicmoc recipe, which can be built both as virtclass-native and virtclass-nativesdk. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com>
* Fix LIC_FILES_CHKSUM for change to common LGPL-2.0 license filePaul Eggleton2011-12-0912-12/+12
| | | | | | | | | | | | | The LGPL-2.0 file in OE-core has been changed in OE-core commit 558b5043e1d5a36caff137093fd04abcf025af1c, so update the checksums pointing to it. (For reference, you should avoid pointing to common license files in LIC_FILES_CHKSUM in this way because it provides no protection against unexpected upstream license changes, which is what this variable is supposed to do; plus it can break in exactly this way.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* task-opie: reverse default display width/heightPaul Eggleton2011-09-181-2/+2
| | | | | | | 240x320 is a more appropriate default screen size for a typical Opie target PDA device. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-taskbar-images: add dummy PACKAGES to fix task-opiePaul Eggleton2011-09-181-0/+3
| | | | | | | | | | | In the recent cleanup of this recipe by me (commit id 2baaad67eb73ad3b9762c192b36390fd22948366) some packages that did not install any files were removed; as it turns out they are still needed due to a line adding RRECOMMENDS for both landscape and portrait variants of the images for the task-opie-base package, so add the dummy PACKAGES back in (with an appropriate comment this time). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-zsafe: fix LIC_FILES_CHKSUMPaul Eggleton2011-09-181-3/+2
| | | | | | | A license file is actually already distributed with the source so verify it instead of pointing to a common license file. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-remote: fix LIC_FILES_CHKSUMPaul Eggleton2011-09-181-3/+2
| | | | | | | A license file is actually already distributed with the source so verify it instead of pointing to a common license file. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-keypebble: fix LIC_FILES_CHKSUMPaul Eggleton2011-09-181-2/+2
| | | | | | | A license file is actually already distributed with the source so verify it instead of pointing to a common license file. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-libqrsync: correct LICENSE / LIC_FILES_CHKSUMPaul Eggleton2011-09-181-3/+3
| | | | | | | | opie-libqrsync is LGPLv2.1+ according to the source files, and includes a COPYING file, so correct LICENSE and change LIC_FILES_CHKSUM to verify that file instead of a common license file. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* manufacturers: fix S for git fetcher subpath patchPaul Eggleton2011-09-181-1/+1
| | | | | | | The subpath option should check out the source to the basename of the subpath value, instead of git/. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-wellenreiter: fix LIC_FILES_CHKSUMPaul Eggleton2011-09-181-2/+2
| | | | | | | COPYING is actually already distributed with opie-wellenreiter so verify it instead of pointing to a common license file. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* task-qpe: fix for recipe removals/replacements in meta-opiePaul Eggleton2011-09-181-2/+1
| | | | | | | * qpenmapfe was removed in favour of qpe-nmap * notez was removed (in favour of opie-notes) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* task-qpe: add task-qpe from OE classicPaul Eggleton2011-09-181-0/+143
| | | | | | It seems that this task was missed when creating the repository. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* qpf-qte: remove 3.3.5 versionPaul Eggleton2011-09-181-60/+0
| | | | | | We don't have Qt/E 3.x so we do not need this. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* Correct TrollTech GPL/QPL LICENSE field syntaxPaul Eggleton2011-09-187-7/+7
| | | | | | | Use pipe separator which is standard for OE core, and specify GPLv2 where known. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-icon-reload: for completeness add git versionDmitry Eremin-Solenikov2011-09-181-0/+3
| | | | | Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie: mass GPL->GPLv2 fixupDmitry Eremin-Solenikov2011-09-18151-152/+154
| | | | | Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie: mass-correct licenses for LGPL packagesDmitry Eremin-Solenikov2011-09-1811-20/+20
| | | | | Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie: fix GPLv2 plus licenseDmitry Eremin-Solenikov2011-09-1819-19/+19
| | | | | | | | Some recipes were incorrectly marked as GPL (which means GPLv1), but in reality they are GPLv2+, mark them so. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* qmake: do not try to regenerate mocDmitry Eremin-Solenikov2011-09-182-2/+2
| | | | | | | | There is no point in regenerating moc constantly. Add no_mocdep to the oe qmake config. Also bump PR for this change. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* qte-common: adapt for {moc,uic} -> {moc,uic}2 changeDmitry Eremin-Solenikov2011-09-181-2/+2
| | | | | | | qt2 tools have suffix 2, adapt qt2 class to use them. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* qmake.bbclass: adapt for {moc,uic} -> {moc,uic}2 changeDmitry Eremin-Solenikov2011-09-181-2/+2
| | | | | | | qt2 tools have suffix 2, adapt qt2 class to use them. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* uicmoc-native: install tools with suffix 2Dmitry Eremin-Solenikov2011-09-181-3/+4
| | | | | | | | To remove conflicts with Qt4, install Qt2 tools with suffix "2", like moc2, uic2, qvfb2. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie: drop MOC and UIC overrides on command lineDmitry Eremin-Solenikov2011-09-183-6/+6
| | | | | | | | | We do already provide our OE values for MOC and UIC via qmake.bbclass/linux-oe-g++ qmake config. Don't override MOC/UIC on command line. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* task-opie: provide defaults for screen resolutionDmitry Eremin-Solenikov2011-09-181-0/+2
| | | | | | | | | | Some machine confg files (most notably qemuarm) do not provide MACHINE_DISPLAY_WIDTH/HEIGHT_PIXELS values. Provide sane (QVGA) defaults for those variables, as they are currently used only to select taskbar images packet. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libopieobex0: drop setting of FILES for -dbg packageDmitry Eremin-Solenikov2011-09-181-4/+0
| | | | | | | | | The setting in question makes libopieobex0 ignore global settings regarding -dbg packages and source inclusion. Fix it to respect -dbg package settings in oe-core/other layers. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-libqrsync: package static libraryDmitry Eremin-Solenikov2011-09-181-0/+4
| | | | | | | | Most of qt/opie libraries are normal shared libraries. libqrsync is static lib, so it needs a special handle during packaging. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-today-addressbookplugin: add dependencies on opie-today and libqtaux2Dmitry Eremin-Solenikov2011-09-181-0/+1
| | | | | Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-taskbar: launcher also uses opiepim2 library, add it to LIBSDmitry Eremin-Solenikov2011-09-181-1/+1
| | | | | Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-taskbar: fix linking issues for 1.2.5 versionDmitry Eremin-Solenikov2011-09-182-1/+23
| | | | | | | Link to libcrypt, libm & libopiepim2 explicitly. Signed-off-by: Dmitry Eremin-Solenikov <dbaryshkov@gmail.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libopie2: introduce INC_PRPaul Eggleton2011-09-183-2/+4
| | | | | | | Several of the other core Opie libraries use INC_PR, use it for libopie2 as well. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libqtaux2: use INC_PR for 1.2.5 versionPaul Eggleton2011-09-181-1/+1
| | | | | | | Somehow this recipe was not using INC_PR although the inc file and git version are. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libopieobex0: fix disable-bit-check patch for current gitPaul Eggleton2011-09-172-2/+20
| | | | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-taskbar: fix server.pro patch for current gitPaul Eggleton2011-09-174-2/+71
| | | | | | | Also rename the 1.2.5 version of the patch so that the name makes more sense. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-bluetoothmanager: add RDEPENDS on opiebluetoothd for git versionPaul Eggleton2011-09-171-0/+3
| | | | | | The manager now requires opiebluetoothd in development versions. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-bluetoothapplet: add RDEPENDS on opiebluetoothd for git versionPaul Eggleton2011-09-171-1/+3
| | | | | | The applet now requires opiebluetoothd in development versions. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-bluetoothd: add opiebluetoothd recipePaul Eggleton2011-09-173-0/+22
| | | | | | This is the Opie bluetooth handling daemon for 1.2.6+. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* task-opie: remove opie-bluepin from task-opie-bluetoothPaul Eggleton2011-09-171-2/+2
| | | | | | | opie-bluepin is already in RDEPENDS for opie-bluetoothmanager for 1.2.5, and won't be available for versions after that. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-bluepin: remove git recipePaul Eggleton2011-09-174-7/+4
| | | | | | | opie-bluepin has been removed in latest development versions in favour of agent functionality in the new opiebluetoothd. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* opie-restartapplet2: remove duplicate recipesPaul Eggleton2011-09-172-41/+0
| | | | | | It seems these have been around for quite some time in OE classic. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* preferred-opie-git-versions.inc: update to more recent git versionPaul Eggleton2011-09-091-1/+2
| | | | | | | * Bump up OPIE_SRCREV to the latest git revision * Add libdbus-qt2 Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libopie2: add libdbus-qt2 dependency for libopiebluez2Paul Eggleton2011-09-091-1/+4
| | | | | | This is now required for the new BlueZ 4 support. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libopie2: remove DEFAULT_PREFERENCE of -1 from git versionPaul Eggleton2011-09-091-2/+0
| | | | | | | | | This is not necessary if you use the appropriate include file to select the Opie version (which is mandatory), and this also makes the libopie2 recipe consistent with the other Opie recipes, none of which set DEFAULT_PREFERENCE. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* libdbus-qt2: add new recipe for git versionPaul Eggleton2011-09-092-0/+28
| | | | | | This is a new D-Bus bindings library for Opie (1.2.6+) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* qmake_base.bbclass: remove in favour of the one in OE-corePaul Eggleton2011-09-081-105/+0
| | | | | | The differences are negligible for building Opie. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* Add LIC_FILES_CHKSUM to many recipesPaul Eggleton2011-08-2186-66/+296
| | | | | | | Also take the opportunity to make LICENSE more accurate for some recipes (i.e. specifying GPLv2 or GPLv2+ instead of GPL as appropriate.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* sokoban: fix DESCRIPTIONPaul Eggleton2011-08-211-1/+1
| | | | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
* zauralign: disable debugging to fix compilationPaul Eggleton2011-08-211-0/+4
| | | | | | | Compilation was failing due to use of legacy header "stream.h", however the easiest way to fix it was to disable debugging within the source. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>