aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-30 03:12:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-31 23:39:12 +0100
commit804c1284891c2654e1431fe4d777ca41ac466120 (patch)
tree8bf32ec02edd4af4b707cb1d508bd6f5442e8b20
parent7246d62406acf862d3c79e6f615e0c595d46845e (diff)
downloadopenembedded-core-contrib-804c1284891c2654e1431fe4d777ca41ac466120.tar.gz
libpam: remove MLPREFIX from PN
The commit df3038768f59f7a0c814974ff674d4e59cbdfca4 changed 'libpam' to 'pn', then we don't need the "MLPREFIX + pn" any more, otherwise we would get the name like: "lib32-lib32-libpam-x", and the warn: WARNING: QA Issue: lib32-pam-plugin-access rdepends on lib32-lib32-libpam-suffix, but it isn't a build dependency? [build-deps] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.6.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.6.bb b/meta/recipes-extended/pam/libpam_1.1.6.bb
index 183480d85b..3de7d095f8 100644
--- a/meta/recipes-extended/pam/libpam_1.1.6.bb
+++ b/meta/recipes-extended/pam/libpam_1.1.6.bb
@@ -102,13 +102,12 @@ python populate_packages_prepend () {
def pam_plugin_hook(file, pkg, pattern, format, basename):
pn = d.getVar('PN', True)
libpam_suffix = d.getVar('libpam_suffix', True)
- mlprefix = d.getVar('MLPREFIX', True) or ''
rdeps = d.getVar('RDEPENDS_' + pkg, True)
if rdeps:
- rdeps = rdeps + " " + mlprefix + pn + "-" + libpam_suffix
+ rdeps = rdeps + " " + pn + "-" + libpam_suffix
else:
- rdeps = mlprefix + pn + "-" + libpam_suffix
+ rdeps = pn + "-" + libpam_suffix
d.setVar('RDEPENDS_' + pkg, rdeps)
provides = d.getVar('RPROVIDES_' + pkg, True)