aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-02-29 13:51:10 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 17:52:25 +0100
commit0c32b6e9585a39b14002a5da230222d2fe01ddff (patch)
tree6c51ce24ce822224ac3ab8f7fe6e1468a6a787af
parentab2d5e397d30999929108c9d929767205fee9db4 (diff)
downloadopenembedded-core-contrib-0c32b6e9585a39b14002a5da230222d2fe01ddff.tar.gz
matchbox-session-sato: Update session startup
* Use Adwaita Gtk+ theme * sato-gtk-engine is no longer needed with Adwaita * GTK_CSD tricks are no longer needed since the panel does not draw on top windows * Add meta-theme index file: it used to be provided by gtk-sato-engine and is used by matchbox-config-gtk only (to be able to show a single selection for Gtk+, icon and Matchbox themes). This is a more logical place for it. * Set matchbox-theme gconf key (just to be explicit, this is the default already) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato/index.theme7
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato/session9
-rw-r--r--meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb11
3 files changed, 17 insertions, 10 deletions
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/index.theme b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/index.theme
new file mode 100644
index 0000000000..c9260cfd8d
--- /dev/null
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/index.theme
@@ -0,0 +1,7 @@
+[X-GNOME-Metatheme]
+Encoding=UTF-8
+Type=X-GNOME-Metatheme
+Name=Sato
+GtkTheme=Adwaita
+IconTheme=Sato
+MatchboxTheme=Sato
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
index 42ce483d35..f6313bdebe 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato/session
@@ -14,11 +14,6 @@ else
KEYBOARD_APPLET="keyboard"
fi
-# Tell GTK+3 we really want server side decorations, even with
-# GtkHeaderBar using applications: Without that mb-panel will render
-# on top of the client side decorations.
-export GTK_CSD=0
-
matchbox-desktop &
# Lines containing feature-[foo] are removed at build time if the machine
@@ -28,6 +23,6 @@ START_APPLETS=showdesktop,windowselector
END_APPLETS=clock,battery,$KEYBOARD_APPLET,systray,startup-notify,notify
END_APPLETS=openmoko-panel-gsm,$END_APPLETS # feature-phone
-matchbox-panel --titlebar --start-applets $START_APPLETS --end-applets $END_APPLETS &
+matchbox-panel --start-applets $START_APPLETS --end-applets $END_APPLETS &
-exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
+exec matchbox-window-manager -theme Sato -use_cursor $SHOWCURSOR $@
diff --git a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
index 76de18ae93..fb4750bafd 100644
--- a/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
+++ b/meta/recipes-sato/matchbox-sato/matchbox-session-sato_0.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://session;endline=3;md5=f8a5c5b9c279e52dc094d10e11c2be6
SECTION = "x11"
DEPENDS = "gconf-native"
-RDEPENDS_${PN} = "formfactor gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
+RDEPENDS_${PN} = "formfactor matchbox-theme-sato matchbox-panel-2 matchbox-desktop-sato matchbox-session gconf"
PR = "r30"
# This package is architecture specific because the session script is modified
@@ -19,9 +19,12 @@ inherit distro_features_check
# The matchbox-theme-sato requires x11 in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI = "file://session"
+SRC_URI = "file://session \
+ file://index.theme"
S = "${WORKDIR}"
+FILES_${PN} += "${datadir}/themes/Sato/index.theme"
+
do_install() {
# This is the set of machine features that the script has markers for
FEATURES="phone"
@@ -34,6 +37,7 @@ do_install() {
fi
done
+ install -D ${S}/index.theme ${D}/${datadir}/themes/Sato/index.theme
install -d ${D}/${sysconfdir}/matchbox
sed -f "$SCRIPT" ${S}/session > ${D}/${sysconfdir}/matchbox/session
chmod +x ${D}/${sysconfdir}/matchbox/session
@@ -44,7 +48,8 @@ pkg_postinst_${PN} () {
#type, name, value
gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type $1 --set /desktop/poky/interface/$2 "$3"
}
- set_value string theme Sato
+ set_value string theme Adwaita
+ set_value string matchbox_theme Sato
set_value string icon_theme Sato
set_value bool touchscreen true
set_value string font_name "Sans 9"