aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-05 17:09:05 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-06 09:32:04 +0100
commit9f363f9e2a56d847efc37dfba38764ae393fbfd6 (patch)
treea3849648bc4b303300f64179733ffaa9b5bd6500
parent65121c8ab37907938b1891b5ee8fb44fb4f76d8f (diff)
downloadopenembedded-core-contrib-9f363f9e2a56d847efc37dfba38764ae393fbfd6.tar.gz
fontconfig: enable 64 bit file support
When running 32bit code on a large filessytem with 64bit inodes, the fontcache was not being created correctly because an EOVERFLOW was being returned from the fstat when reading the 64 inode on a 32bit system. The fontcache is created at rootfs time on the host system via qemu. [YOCTO #6338] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
index 797b3218b5..4fa58ab380 100644
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.11.1.bb
@@ -38,5 +38,7 @@ DEBIAN_NOAUTONAME_fontconfig-utils = "1"
inherit autotools pkgconfig
EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts"
+TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
+
BBCLASSEXTEND = "native"