aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-25 14:37:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-25 14:40:56 +0100
commit00608cffffb586e8d2a2075117e710113c471448 (patch)
treeea59035850c560af7032a13de7174839af5f36b7
parentdceba7aed50f9a04e9912a71a550243a2fc4981a (diff)
downloadopenembedded-core-contrib-00608cffffb586e8d2a2075117e710113c471448.tar.gz
perf: Fix config file conflict with 4.1 kernels
If you setup mutlitlibs and then: bitbake perf libb32-perf bitbake perf libb32-perf -c cleansstate bitbake perf libb32-perf you will see races where the two builds get confused about which directory they should be using and they corrupt each other. The issue is that .config-detected is created in ${S}, not $(OUTPUT). We can fix this by moving the file to $(OUTPUT). [YCOTO #8043] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index f18178c7a7..056ac831f7 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -127,12 +127,27 @@ do_configure_prepend () {
# 64 bit build (and library) are not exected. To ensure that libraries are
# installed to the correct location, we can use the weak assignment in the
# config/Makefile.
+ #
+ # Also need to relocate .config-detected to $(OUTPUT)/config-detected
+ # as two builds (e.g. perf and lib32-perf from mutlilib can conflict
+ # with each other if its in the shared source directory
+ #
if [ -e "${S}/tools/perf/config/Makefile" ]; then
# Match $(prefix)/$(lib) and $(prefix)/lib
sed -i -e 's,^libdir = \($(prefix)/.*lib\),libdir ?= \1,' \
-e 's,^perfexecdir = \(.*\),perfexecdir ?= \1,' \
+ -e 's,\.config-detected,$(OUTPUT)/config-detected,g' \
${S}/tools/perf/config/Makefile
fi
+ if [ -e "${S}/tools/perf/Makefile.perf" ]; then
+ sed -i -e 's,\.config-detected,$(OUTPUT)/config-detected,g' \
+ ${S}/tools/perf/Makefile.perf
+ fi
+ if [ -e "${S}/tools/build/Makefile.build" ]; then
+ sed -i -e 's,\.config-detected,$(OUTPUT)/config-detected,g' \
+ ${S}/tools/build/Makefile.build
+ fi
+
# We need to ensure the --sysroot option in CC is preserved
if [ -e "${S}/tools/perf/Makefile.perf" ]; then
sed -i 's,CC = $(CROSS_COMPILE)gcc,#CC,' ${S}/tools/perf/Makefile.perf