aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2016-07-04 14:22:57 +0800
committerChen Qi <Qi.Chen@windriver.com>2016-07-04 14:39:43 +0800
commitba495100243d05c286294ac8e64747793d5dc1c3 (patch)
treeec46dbfd42248ed5c0ebc60ab5b194127b1320db
parent53fcfe4348a2ca727844f2b0bd3fca2902cbdda0 (diff)
downloadopenembedded-core-contrib-ChenQi/gettext-native.tar.gz
openembedded-core-contrib-ChenQi/gettext-native.tar.bz2
openembedded-core-contrib-ChenQi/gettext-native.zip
gettext: fix for low-version recipeChenQi/gettext-native
Make gettext-native in 0.16.1 recipe provides virtual/gettext-native like what gettext-native in 0.19.6 recipe does. Otherwise we would fail to start to do a world build if gettext and gettext-native are set to the low version. Error message is like below. ERROR: Multiple versions of gettext-native are due to be built Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta/recipes-core/gettext/gettext_0.16.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.16.1.bb b/meta/recipes-core/gettext/gettext_0.16.1.bb
index 6095c83232..9998676e94 100644
--- a/meta/recipes-core/gettext/gettext_0.16.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.16.1.bb
@@ -9,7 +9,7 @@ PR = "r6"
DEPENDS = "virtual/libiconv"
DEPENDS_class-native = ""
PROVIDES = "virtual/libintl virtual/gettext"
-PROVIDES_class-native = ""
+PROVIDES_class-native = "virtual/gettext-native"
SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
file://gettext-vpath.patch \