aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-12-19 00:27:54 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-24 17:48:58 +0000
commit9e906f4260d9ce44a78cc315930677b3bd0ab9c1 (patch)
tree50cdf2bda7072e637f81aede55665791e5446939
parent98caaf4b92bf3350cc74ef66dc9eda35aa7d428a (diff)
downloadopenembedded-core-contrib-9e906f4260d9ce44a78cc315930677b3bd0ab9c1.tar.gz
lsb: remove sendmail from sysroot
The sysroot/${libdir}/sendmail conflicts with esmtp's, and it's a symlink to ${sbindir}/sendmail which is meaningless for sysroot, so remove it. Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index 69f3962ec4..b4ef98eea7 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -121,3 +121,11 @@ FILES_${PN} += "/lib64 \
${base_libdir}/lsb/* \
${libdir}/sendmail \
"
+
+# The sysroot/${libdir}/sendmail conflicts with esmtp's, and it's a
+# symlink to ${sbindir}/sendmail which is meaningless for sysroot, so
+# remove it.
+SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_sendmail"
+remove_sysroot_sendmail() {
+ rm -r "${SYSROOT_DESTDIR}${libdir}/sendmail"
+}