aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-06-13 18:03:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-14 08:43:41 +0100
commit4625eb0793ff59e4414017df0371ee9b89f47b38 (patch)
tree1e24af6e63594c4936d5f6f911f72e94a87f75ba
parent15345ddd4be6a0b041b3d6caaad48d46b22142e9 (diff)
downloadopenembedded-core-contrib-4625eb0793ff59e4414017df0371ee9b89f47b38.tar.gz
neard: fix more parallel build issues
One fix, another appears... root-cause to a magic dependency hiding at the bottom of the Makefile, and add all binaries to it. [ YOCTO #6416 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/neard/neard/Fix-snep-send-parallel-build.patch31
-rw-r--r--meta/recipes-connectivity/neard/neard/parallel-build.patch40
-rw-r--r--meta/recipes-connectivity/neard/neard_0.14.bb2
3 files changed, 41 insertions, 32 deletions
diff --git a/meta/recipes-connectivity/neard/neard/Fix-snep-send-parallel-build.patch b/meta/recipes-connectivity/neard/neard/Fix-snep-send-parallel-build.patch
deleted file mode 100644
index f3029927d0..0000000000
--- a/meta/recipes-connectivity/neard/neard/Fix-snep-send-parallel-build.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From fbbf600df474865172b47212d94e3dc5013cc2df Mon Sep 17 00:00:00 2001
-From: Cristian Iorga <cristian.iorga@intel.com>
-Date: Wed, 4 Jun 2014 16:40:18 +0300
-Subject: [PATCH] tools: Fix snep-send parallel build
-
-tools/snep-send object might cause a
-parallel build failure,due to undetected
-dependency on dbus.h header file.
-
-Upstream-Status: Pending
-Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
----
- Makefile.am | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/Makefile.am b/Makefile.am
-index 26f49e7..0e4a5b5 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -169,6 +169,8 @@ tools_snep_send_SOURCES = $(gdbus_sources) src/log.c src/dbus.c \
- src/agent.c
- tools_snep_send_LDADD = ${GLIB_LIBS} ${DBUS_LIBS}
-
-+tools/snep-send.$(OBJEXT): include/near/dbus.h
-+
- tools_nfctool_nfctool_SOURCES = tools/nfctool/main.c \
- tools/nfctool/nfctool.h \
- tools/nfctool/adapter.h \
---
-1.9.1
-
diff --git a/meta/recipes-connectivity/neard/neard/parallel-build.patch b/meta/recipes-connectivity/neard/neard/parallel-build.patch
new file mode 100644
index 0000000000..1837ad010c
--- /dev/null
+++ b/meta/recipes-connectivity/neard/neard/parallel-build.patch
@@ -0,0 +1,40 @@
+Upstream-Status: Pending
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 488e898300f7a4ab9ba73307967ae9e02b7a6511 Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Fri, 13 Jun 2014 17:49:45 +0100
+Subject: [PATCH] Makefile: add missing binaries to dependency on
+ local_headers
+
+seeld and snap_send were missing from the rule that generates the header symlink
+farm, resulting in headers not being available in highly parallel builds.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ Makefile.am | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index c51351f..8e58ac1 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -254,7 +254,14 @@ se/plugin.$(OBJEXT): se/builtin.h
+ se/builtin.h: src/genbuiltin $(builtin_se_sources)
+ $(AM_V_GEN)$(srcdir)/src/genbuiltin $(builtin_se_modules) > $@
+
+-$(src_neard_OBJECTS) $(tools_nfctool_nfctool_OBJECTS) $(plugin_objects): $(local_headers)
++$(src_neard_OBJECTS) \
++$(tools_nfctool_nfctool_OBJECTS) \
++$(plugin_objects) \
++$(se_seeld_OBJECTS) \
++$(unit_test_ndef_parse_OBJECTS) \
++$(unit_test_ndef_build_OBJECTS) \
++$(unit_test_snep-read_OBJECTS) \
++$(tools_snep_send_OBJECTS): $(local_headers)
+
+ include/near/version.h: include/version.h
+ $(AM_V_at)$(MKDIR_P) include/near
+--
+1.7.10.4
+
diff --git a/meta/recipes-connectivity/neard/neard_0.14.bb b/meta/recipes-connectivity/neard/neard_0.14.bb
index 663d7ea768..daf3a4b7d1 100644
--- a/meta/recipes-connectivity/neard/neard_0.14.bb
+++ b/meta/recipes-connectivity/neard/neard_0.14.bb
@@ -1,7 +1,7 @@
require neard.inc
SRC_URI = "${KERNELORG_MIRROR}/linux/network/nfc/${BPN}-${PV}.tar.xz \
- file://Fix-snep-send-parallel-build.patch \
+ file://parallel-build.patch \
file://neard.in \
file://neard.service.in \
"