aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-06-24 17:13:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-25 11:49:39 +0100
commit6a8144390eb2dee6e1baf7be75cffcacbb247002 (patch)
tree51491db707cc1b0a8b044808fca1040ee438a4e3
parent3af33d60f03afb19543247b5350137ff3a7ee7e0 (diff)
downloadopenembedded-core-contrib-6a8144390eb2dee6e1baf7be75cffcacbb247002.tar.gz
curl: Convert CURLGNUTL to PACKAGECONFIG
This will allow for easier configuration of curl for SSL vs gnutls [YOCTO #6329] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.37.0.bb18
1 files changed, 7 insertions, 11 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.0.bb b/meta/recipes-support/curl/curl_7.37.0.bb
index 1dc4ff3249..f6b05a7787 100644
--- a/meta/recipes-support/curl/curl_7.37.0.bb
+++ b/meta/recipes-support/curl/curl_7.37.0.bb
@@ -23,6 +23,13 @@ SRC_URI[sha256sum] = "24502492de3168b0556d8e1a06f14f7589e57b204917d602a572e14239
inherit autotools pkgconfig binconfig multilib_header
+PACKAGECONFIG ??= "gnutls ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+PACKAGECONFIG_class-native = "ipv6 ssl"
+PACKAGECONFIG_class-nativesdk = "ipv6"
+PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
+PACKAGECONFIG[ssl] = "--with-ssl, --without-ssl, ,"
+PACKAGECONFIG[gnutls] = "--with-gnutls=${STAGING_LIBDIR}/../, --without-gnutls, gnutls,"
+
EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
--without-libssh2 \
--with-random=/dev/urandom \
@@ -31,19 +38,8 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
--disable-ldap \
--disable-ldaps \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
- ${CURLGNUTLS} \
"
-CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
-CURLGNUTLS_class-native = "--without-gnutls --with-ssl"
-CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl"
-
-PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
-PACKAGECONFIG_class-native = "ipv6"
-PACKAGECONFIG_class-nativesdk = "ipv6"
-
-PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
-
do_configure_prepend() {
sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac
}